Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

2 Netzwerke (rot und blau :) ) verbinden

Frage Netzwerke Router & Routing

Mitglied: mikeemike

mikeemike (Level 1) - Jetzt verbinden

18.08.2006, aktualisiert 24.08.2006, 5413 Aufrufe, 8 Kommentare

Auf dem Bild ist der Aufbau des Netzes ersichtlich.
41e50a3daa690a922d37be6564f3af19-unbenannt-2 - Klicke auf das Bild, um es zu vergrößern

WICHTIG ! DER PC RECHTS OBEN HAT NICHT DIE IP 192.168.20.2 sondern 192.168.20.3 !! WAR EIN FEHLER BEI DER ERSTELLUNG DES BILDES.

Der Labtop hat 2 Karten, eine WLAN (rot) und eine Interne (blau).

Der einzelne PC 192.168.20.4 steht in einem anderen Gebäude und bekommt seine Internet- und Netzwerkverbindung per WLAN durch den Outdoor Router 192.168.20.11.

Leider ist die WLAN Karte (rot) des Labtops nicht stark genug. Somit soll der Labtop, wenn er im anderen Gebäude ist, per LAN (blau) eine Verbindung aufbauen können.

Dazu ist der blaue Teil des Netzwerkes gedacht. Darin befindet sich auch ein Router.
Die Geräte haben alle die IP's 192.168.19.*.

Wie stelle ich nun Labtop (192.168.20.2 / 192.168.19.2), Router ( ---- / 192.168.19.10) und PC (192.168.20.4 / 192.168.19.1) richtig ein, um eine Verbindung zu dem roten Teil des Netzes herstellen zu können ?
Mitglied: cykes
18.08.2006 um 10:57 Uhr
Hi,

wirgendwas stimmt in Deiner Zeichnung nicht, ist die IP Adresse 192.168.20.2 wirklich 2x
vergeben (einmal oben rechts und einmal in dem grauen Kasten)?
Besteht nun ein Verbidung zwischen 192.168.20.11 und 192.168.20.4/192.168.19.1,
dann könntest Du doch die Router auf dem Server, der in beiden Netzen hängt entsprechend
anpassen.

Gruß

cykes
Bitte warten ..
Mitglied: mikeemike
18.08.2006 um 11:56 Uhr
Ja, ich habe obigem Text ja schon eine Korrektur hinzugefügt, vielleicht hattest du da aber schon gepostet. Der PC rechts oben hat nicht die 2 sondern die 3. Somit ist nichts doppelt vergeben ;)

Was meinst du damit, den Router am PC 192.168.20.4 anzupassen ?
Bitte warten ..
Mitglied: alpha-centauri
18.08.2006 um 17:09 Uhr
wär ne netzwerkbrücke ne idee, lokal in dem pc eingerichtet?
Bitte warten ..
Mitglied: cykes
18.08.2006 um 17:53 Uhr
Mit "Router" hab ich mich vertippt meinte "Route".

Also eine Route zwischen den beiden Netzadaptern, das die Pakete vom einen Subnetz ins andere (und umgekehrt) können.
Bitte warten ..
Mitglied: aqui
18.08.2006 um 23:10 Uhr
Die .19.10 ist aber nicht wirklich ein Router, denn beide Segmente daran befinden sich ja im gleichen .19er Netz. Da kann er dann irgendwie nicht routen !? Oder hat der noch ein 3. Bein irgendwohin und die beiden blauen Verbindungen sind über einen Switch im Router verbunden ???
Die Frage ist ferner wohin zeigt das default Gateway vom Laptop im .19.0er Segment ? Zeigt es auf den PC mit der .19.1 dann ist die weitere Frage: Was ist für ein OS hier drauf ?? Linux, Windows ???
Ists Windows XP musst du hier IP Forwarding (Routing) einschalten damit Packete ins 20er Segment kommen. Wie es geht steht hier:

www.microsoft.com/windows2000/de/server/help/default.asp?url=/windows2000/de/server/help/sag_TCPIP_pro_EnableForwarding.htm

Ists 2003 musst du das im TCP/IP Setting einschalten (Checkbox). Bei Linux musst du im System setup die Variable ip_forwarding auf YES setzen.
Nun vermittelt der PC Packete mit der Zieladresse .20.0 an das 20er Netz.
Hier musst du jetzt darauf achten das Zielsysteme dann ebenfalls den PC als Gateway eingetragen haben sollten sonst finden die Packete den Rückweg nicht ! Ist dem nicht so und das def. Gateway ein Router braucht der eine statische Route wie:
192.168.19.0 mask 255.255.255.0 gateway 192.168.20.4
Dein PC ist also somit Router zwischen dem 19er und 20er Segment. Nachteil ist das der immer online sein muss, sonst verlierst du die Connectivity. Ein wichtiger Punkt ist dann ihm feste statische Adressen zu geben sofern du Routen von anderen Systeme auf ihn zeigen lässt. Nutzt du weiterhin dynmaische Adressen wie z.Zt. dann können die sich ändern und dann ist eine externe Route zu ihm mit einmal nutzlos, da si dann ins IP Nirwanan zeigt.
Besser ist da nen alten PC mit 2 Netzwerkkarten,Floppy und fli4l (www.fli4l.de) hinzusetzen, dann bist du davon unabhängig.
Bitte warten ..
Mitglied: mikeemike
22.08.2006 um 10:05 Uhr
Da ich inzwischen ein bisschen probiert habe ... nunja ... ich versuche gerade verzweifelt einige Routen wieder zu löschen, aber wenn ich den Befehl z.B. route delete 192.168.20.4 eingebe sagt er nur "Route nicht gefunden" oder so ...

Habe euch mal nen Screenshot eingestellt wie die Routingtabelle momentan aussieht ...

http://img180.imageshack.us/img180/3386/unbenannt1ow3.jpg

Außerdem habe ich das richtig verstanden ?

Ich gebe nun am PC mit der 192.168.20.4 / 192.168.19.1 folgendes ein :

ROUTE ADD 192.168.19.0 MASK 255.255.255.0 192.168.20.10 METRIC 1
ROUTE ADD 192.168.20.0 MASK 255.255.255.0 192.168.19.10 METRIC 1

Dann am Labtop als Gateway die 192.168.19.4 eintragen, richtig ?
Bitte warten ..
Mitglied: mikeemike
23.08.2006 um 09:02 Uhr
aqui, oder jemand der eine Ahnung hat .... Hilfe Es geht nicht ... Ich habe mir schon gedacht, dass ich den entscheidenden Ansatz noch nicht kapiert habe .. !
Bitte warten ..
Mitglied: aqui
24.08.2006 um 13:09 Uhr
Nein, am PC mit der 20.4 brauchst du KEINERLEI statische Routen in die Netze:
192.168.20.0 und
192.168.19.0
eingeben ! Wozu auch denn dieser PC kennt ja beide Netze, da er mit ihnen verbunden ist !!!

Wichtig ist erstmal zu klären ob dieser PC selber in der Lage ist zu routen !!!
Ist das Registry Bit (bei XP oder 2000) entsprechend der MS Anleitung unter:
www.microsoft.com/windows2000/de/server/help/default.asp?url=/windows2000/de/server/help/sag_TCPIP_pro_EnableForwarding.htm
gesetzt oder nicht ???
Ist es nicht gesetzt wirst du immer Schiffbruch erleiden weil der PC dann gar keine Packete weiterleitet !!!

Das ist das erste was du sicherstellen musst mit einem Ping Check!

Das default Gateway im Laptop zeigt dann für das .20.0er Netz (rot WLAN) auf die 192.168.20.4
und beim 19.0er Netz (blau LAN) auf die 192.168.19.1 !!!
Dann sollte es eigentlich gehen sofern auch die Gateway Einträge der anderen Maschinen in den Segmenten .20.0 und .19.0 stimmen. Die MÜSSEN ebenfalls alle auf die .19.1 zeigen (im .19.0er Segment !) und auf die .20.4 (im .20.0er Segment) !!!

Das Gerät mit der .19.10 ist kein Router nach deiner Zeichnung (vermutlich die Config Adresse des WLAN Accesspoints ??!), hat also in irgendwelchen Routing Einträgen und Gateway Einträgen nichts zu suchen !

Ist das alles so richtig muss ein Ping in beide Segmente funktionieren vorausgesetzt das diese nicht durch irgendwelche Firewall SW geblockt werden....
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
LAN, WAN, Wireless
Zwei Netzwerke per Richtfunk verbinden (49)

Frage von jimb0p zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst Zwei unterschiedliche IP Netzwerke über WLAN verbinden (26)

Frage von Oggy01 zum Thema Router & Routing ...

LAN, WAN, Wireless
Zwei private Netzwerke (LAN und WLAN) mit SXT Lite5 verbinden (9)

Frage von MWelslau zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst Zwei Netzwerke in einem Haus verbinden, Hardwarevorschlag (10)

Frage von KotyrbaSe zum Thema Router & Routing ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...