Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

2 Netzwerke verbinden mit Mikrotik 750GL

Frage Netzwerke Router & Routing

Mitglied: afischer

afischer (Level 1) - Jetzt verbinden

16.11.2012 um 10:17 Uhr, 4719 Aufrufe, 14 Kommentare

Hallo zusammen - bin am Verzweifeln !

Hallo !
Ich quäle mich seit Tagen mit einem Problem herum.

Folgende Ausgangssituation :

Büro und Privathaus sind keine 100m Luftlinie entfernt.
Ziel ist es beide Netze zu verbinden, damit man von beiden Seiten Zugriff auf Geräte der anderen Seite hat.
Die Verbindung wurde über WLAN hergestellt.
Schnittstelle ist mein neuer Mikrotik 750GL, den ich mir wegen der Empfehlung - unter anderem in dem Howto "Netzwerk mit 2 Netzwerkkarten...." zugelegt habe

Privat :
192.168.1.0-Netzwerk
Zentrale ist eine Fritzbox 7390, die als DHCP und Internet-Router fungiert
Als statische Route für 192.168.0.0 ist Gateway 192.168.1.252 eingetragen

Schnittstelle Mikrotik :
Adressen
LAN1 192.168.1.252
LAN2 192.168.0.252
Firewall deaktiviert

Büro :
192.168.0.0-Netzwerk
W2k03-Server 192.168.0.11 als DHCP/DNS mit Weiterleitung an 192.168.0.66
Internet-Router Fritzbox 3270 192.168.0.66
Statische Route an der Fritzbox 192.168.1.0 an 192.168.1.252

Soweit so gut.
Vom Büro kann ich auch wunderbar nach Privat zugreifen.
Umgekehrt leider nicht.
Bis zum Mikrotik kann ich pingen und auch zugreifen - mehr nicht.
Ein Tracerout endet bereits an der Fritzbox ...1.1.

Ich hab mir schon x Artikel durchgelesen, ich komme nicht weiter.
Es muß nur ein kleines Deatil sein, aber ich komm nicht drauf.

Vielleicht kann mir jemand weiterhelfen und mich erlösen.

Vielen Dank im Voraus

Viele Grüße

Alex
Mitglied: aqui
16.11.2012, aktualisiert um 10:42 Uhr
Ist ja ein vielgefragtes Thema im Moment auch wenn man zu faul ist die Suchfunktion mal zu bemühen:
http://www.administrator.de/forum/2-netzwerke-mit-einem-mfp-via-mikroti ...

Dieses Tutorial sollte alle deine Probleme im Handumdrehen lösen:

http://www.administrator.de/contentid/56073

Im Abschnitt "Routing ohne Server"
Zusaätzlich sollte dir noch http://www.administrator.de/wissen/mit-einem-wlan-zwei-ip-netzwerke-ver ... helfen was die Grundlagen anbetrifft.

Ein paar Sachen die auffallen:
"Route an der Fritzbox 192.168.1.0 an 192.168.1.252" Das ist natürlich technischer Blödsinn, denn du schreibst ja selber oben das die Büro Fritzbox im .0.0er Netzwerk ist.
Was soll denn bitte diese sinnfreie Route bewirken ??
Wenn der Mikrotik die .0.252 im Büronetz hat dann muss sie lauten 192.168.1.0, Maske: 255.255.255.0, Gateway: 192.168.0.252 !
Um deine ToDos nochmal zu wiederholen: (Annahme der MT750 hat immer die .252 in den jeweiligen Netzen !)
  • Mikrotik gemäss Tutorial mit den o.a. IPs als Router einrichten und Default Profil löschen.
  • An der FB Privatnetz folgende statische Route eingeben: Zielnetz: 192.168.0.0, Maske: 255.255.255.0, Gateway: 192.168.1.252
  • An der FB Büronetz folgende statische Route eingeben: Zielnetz: 192.168.1.0, Maske: 255.255.255.0, Gateway: 192.168.0.252
  • Alle Endgeräte in den jeweiligen Netzen haben immer die FBs der jeweiligen netze als Gateway und DNS eingestellt.
  • Ggf. default Route des MT750 auf eine der beiden FBs setzen. (Time Server, DNS etc.) ist aber optional und für die Funktion unwichtig.
  • Pingen von einem Endgerät auf den lokalen Router, lokales MT Interface und FB Router im anderen Netz und vice verso MUSS funktionieren
  • Traceroute (tracert) zeigt dir auch immer den entsprechenden Routing Weg !
Wenn das alles klappt können sich auch alle Endgeräte sehen und anpingen und alles sollte klappen wie gewohnt !
Bitte warten ..
Mitglied: afischer
16.11.2012 um 11:13 Uhr
Vielen Dank für die schnelle Antwort.
Zu faul bis ich nicht - vielleicht aber zu dumm...

Das mit der statischen Route ist ein Tippfehler. Das läßt die FB ja auch gar nicht zu, dass der GW außerhalb des eigenen Netzes ist. Sorry.

Eigentlich hab ich ja auch alles so eigerichtet.
Nur das default-profile hab ich nicht gelöscht.
Ist es das unter PPP ? Das läßt mich der Mikrotik nicht löschen.

Im Büro sind DNS und Internet-GW getrennt:
W2k03-Server=DNS mit Weiterleitung an FB, für alles IPs außerhalb seiner Zuständigkeit
FB hat als staische Route den Verweis an den Mikrotik.

Könnte mein Problem durch diese Trennung entstehen ?

VG

Alex
Bitte warten ..
Mitglied: aqui
16.11.2012, aktualisiert um 12:16 Uhr
Zu dumm auch nicht wohl aber mal wieder zu faul zum Lesen !! Bitte lies dir das obige Tutorial wirklich durch !
PPP ist auch Quatsch, denn das nutzt du doch gar nicht bei dir ! Also ruhig bleiben und l e s e n !
Dort steht doch ganz klar: (Zitat):
Durch die Eingabe von "r" an der Konsole (die man per Telnet z.B. mit PUTTY erreicht.) verhindert man eine werkseitige Default Konfiguration die den Mikrotik als klassischen DSL NAT Router konfiguriert.
Analog kann man per Telnet
PUTTY mit dem menügesteurten Kommando /system reset-conf skip-backup=yes no-defaults=yes die werkseitige Default Konfig (4 Port Switch plus 1 NAT Routerport) deaktivieren und einen simplen 5 Port Router aus dem Mikrotik machen.
Ohne diese Default Konfig hat man dann einen "nackten" und transparenten 5 Port Router vor sich der dann max. 5 (mit VLANs entsprechend mehr) separate IP Netze routen kann.


Geht auch über das mittlerweile vorhandene WebGUI.
Wenn du das Löschen der Defalt Konfig NICHT machst ,wie du vermutlich..., dann rennt bei dir die default Konfiguration des MT wo 4 Ports einen Switch darstellen und der 5te Port ein WAN Interface mit einer NAT Firewall ist.
Wenn du einen so konfigurierten MT in dein Netzwerk Szenario hängst muss man dir wohl nicht mehr genau erklären was dann passiert, oder ?!
Bitte warten ..
Mitglied: afischer
16.11.2012 um 13:04 Uhr
OK, das war mein Fehler.
Ich habe die default-config entfernt und alles nach Anleitung eingerichtet.
Trotzdem komme ich von Privat nicht ins Büro.
Der Tracerout bleibt bei der FB hängen.
Zumindest bis zum MT müßte die Route doch verlaufen.
Ich hab ja die statische Route eingerichtet.
Und die FB kennt den MT auch, da er in der Netzwerkliste erscheint.
...???...
Bitte warten ..
Mitglied: afischer
20.11.2012 um 19:38 Uhr
Ich komme einfach nicht weiter.
Vom Büro nach Privat geht alles einwandfrei.
Nur von Privat ins Büro geht es nicht.
Ich kann den MT per Ping über seine .1.252-Adresse erreichen.
Ein tracert ins Büronetz bleibt an der Fritzbox hängen.
Dort ist aber definitiv die statische Route 192.168.0.0 255.255.255.0 192.168.1.252 eingerichtet und aktiviert.
Warum geht der tracert nicht wenigstens bis zur MT ?
Bin echt am verzweifeln.

VG

Alex
Bitte warten ..
Mitglied: aqui
21.11.2012, aktualisiert um 12:07 Uhr
Das zeigt ganz klar das du immer noch die Mikrotik Default Konfig drin hast und eben diese NICHT gelöscht hast. ( 4 Ports als Switch und der 5te Port als NAT Firewall mit Adress Translation)
Dadurch das es nur einseitig geht sieht man ganz klar das du immer noch die NAT Firewall auf dem Mikrotik hast !

Bitte lösche die Default Konfig aus der Mikrotik Box wie es im Tutorial steht !!!
Dann funktioniert das alles auch im Handumdrehen !! oder poste hier mal die /system reset-conf mit dem print Kommando !! Bzw. ein Screenshot deiner Interface configs wie auch im Tutorial zu sehen !! (Upload hier mit Bilder Upload wenn du deine Frage mit "Bearbeiten" editierst und den Bild URL postest)
Nur das ist noch dein Fehler !! Mehr nicht !
Bitte warten ..
Mitglied: afischer
21.11.2012 um 13:43 Uhr
Hallo aqui,

vielen Dank für deine Geduld.

Jetzt komme ich langsam der Sache näher.
Anscheinend ist wirklich immer noch die default-Konfig. drin.
Ich habe jetzt mit 3 verschiedenen Methoden probiert sie wegzubekommen (über putty mit r, mit dem langen Befehl und über die winbox).
Nach den Befehlen bootet der MT neu, ist aber dann nicht mehr erreichbar.
Erst durch den Resetknopf komm ich wieder rein.
Dann ist aber wieder diese blöde default-Konfig drin.
Warum nimmt der MT den Befehl nicht an ?
Hab ich da noch was verkehrt gemacht ?
Oder hat er am Ende noch einen Defekt ?
Bitte warten ..
Mitglied: aqui
21.11.2012 um 22:44 Uhr
Bitte nutze das WinBox Programm. Das arbeitet auf Layer 2 d.h. über die Mac Adresse des Mikrotik.
Damit kannst du auf den MT auch OHNE IP Adresse immer zugreifen !!! Discovery dann über Mac in der Winbox.
Damit kommst du dann wieder drauf kannst deinen IP Adressen einstellen und alles wird gut !!
Bitte warten ..
Mitglied: afischer
23.11.2012 um 07:29 Uhr
So, hab die default-config löschen können.
Anschließend bei Adresses eingetragen :
ether1 192.168.1.252/24 255.255.255.0 - da hängt das Privatnetz dran
ether2 192.168.0.252/24 255.255.255.0 - da hängt das Büronetz dran

FB Privat Stat.Route 192.168.0.0 255.255.255.0 192.168.1.252
FB Büro Stat.Route 192.168.1.0 255.255.255.0 192.168.0.252

Alle Endgeräte kennen in ihrem Netz die jeweilige FB als Gateway.

Trotzdem geht es immer noch nur in einer Richtung.
Vom Büro kann ich auf Privat alles erreichen, umgekehrt nix.
Der tracert von Privat endet schon bei der FB.
Bitte warten ..
Mitglied: afischer
27.11.2012 um 10:08 Uhr
Ich weiß, dass ich lästig bin, aber ich komm nicht weiter.

Wenn ich mit tracert von Privat aus eine Adresse (z.B. die Büro-FB 192.168.0.66) verfolge, dann komme ich nur bis zur FB 192.168.1.1.
In dieser ist ja die statische Route zum MT (192.168.0.0 255.255.255.0 192.168.1.252) hinterlegt.
Anpingen kann ich vom Privatnetz auch die MT 192.168.1.252.
Dann bleibt das Paket doch schon in der FB stecken, obwohl die MT erreichbar wäre.
Also liegt es an der FB ?
Oder liege ich da falsch.
Bitte warten ..
Mitglied: aqui
29.11.2012 um 19:03 Uhr
Mmmmhhh, ist schon komisch ! Normal ist das nicht ! Kanst du den MT bzw. das MT Interface in beiden Netzen anpingen ??
Mach mal einen Test der die FBs umgeht...
  • Nimm dir 2 PCs, einen im Privatnetz und einen im Büronetz
  • An diesen PCs stellst du statt der Default Route auf die FB jetzt die IP des jeweiligen MT Interfaces ein in dem Netz. Damit routetst du dann direkt zwischen beiden Netzen ohne die FBs
  • Achte darauf das du die lokalen Firewalls in den Rechneren anpasst, denn die blocken meist immer das was von Fremdnetzen kommt. Du musst also immer das eine oder andere netz erlauben bzw. testweise mal die lokale FW ausschalten.
  • DAS sollte nun klappen. Sowohl Ping als auch Traceroute

Ist dem so ist der böse Buhmann die Fritzbox !!
Ist dem nicht so hast du immer nochwas falsch im MT eingestellt was aber nun eigentlich nicht mehr sein kann....
Bitte warten ..
Mitglied: dog
30.11.2012 um 00:16 Uhr
Hast du geguckt ob die Firmware auf beiden Fritzboxen aktuell ist?
Welche hast du auf dem MT?
Gib im Terminal mal /export compact ein und poste die Ausgabe hier.
Wie ist die WLAN-Verbindung zwischen den Gebäuden genau aufgebaut??
Bitte warten ..
Mitglied: afischer
30.11.2012 um 08:53 Uhr
---
[admin@MikroTik] > /export compact
  1. jan/04/1970 22:22:22 by RouterOS 5.21
  2. software id = YIXK-GF89
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip address
add address=192.168.1.254/24 interface=ether3
add address=192.168.0.254/24 interface=ether4
[admin@MikroTik] >
---

Hab versuchsweise auf 254 umgestellt statt wie vorher 252.

Die WLAN-Verbindung ist folgendermaßen :
FB Privat 7390 (aktuelle FW) - FritzRepeater 300E - Kabelverbindung - 1.TP-Link WA7510N BridgeAP-Modus - 2.TP-Link WA7510N BridgeAP-Modus - Kabelverbindung - Mikrotik 750GL FW5.21 - Büro-Switch mit Anschluss zu W2k03-Server und FB Büro
Bitte warten ..
Mitglied: aqui
30.11.2012 um 12:18 Uhr
  • Kannst du ganz sicherstellen das die WLAN Bridge funktioniert ?? Bzw. hast du diese VORHER auf korrekte Bridging funktionalität getestet indem du da z.B. mal auf jeder Seite einen PC angeschlossen hast und gepingt hast ?? Das ist essentiell wichtig um das als Fehler ausschliessen zu können. Dazu gehört natürlich auch die WLAN Strecke mal mit dem inSSIDer auszumessen (Kanalverteilung) das die nicht gestört wird von Nachbar WLANs und auch den Fritzbox WLAN Einstellungen (4-5 Funkkanäle Abstand !) usw. !! Der Vorab Test der Bridge ist also wichtig !!
  • Parallel dazu solltest du in jedem Falle identisch den MT so testen. PCs auf jede Seite, Gateway IP auf die MT IP und anpingen. Auch das MUSS funktionieren.

Erst wenn das BEIDES sauber auf Funktion getestet ist steckst du die Komponenten zusammen ! Denk dran das du den Bridge APs entsprechend korrekte IPs und Gateway IPs gibst um die auch testweise anpingen zu können und so die Funktion der Verbindung zu testen.
Denke ebenso daran das bei Bridging die IP immer in einem gemeinsamen IP Netz liegen müssen !! Eine Bridge funktioniert auf Mac Adress Basis also Layer 2.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
Zwei private Netzwerke (LAN und WLAN) mit SXT Lite5 verbinden (9)

Frage von MWelslau zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst Zwei Netzwerke in einem Haus verbinden, Hardwarevorschlag (10)

Frage von KotyrbaSe zum Thema Router & Routing ...

LAN, WAN, Wireless
Zwei Netzwerke per Richtfunk verbinden (49)

Frage von jimb0p zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...