Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

2 PC"s mit Crossover Kabel verbunden und einer davon soll auch Internet haben

Frage Netzwerke

Mitglied: 40723

40723 (Level 1)

28.12.2006, aktualisiert 01.01.2007, 6226 Aufrufe, 12 Kommentare

So hallo erst mal,

ich berichte mal alles ganz genau:

So,

mein Laptop und mein Hauptrechner.
Der Laptop hat einen Drahtlose Internetverbindung zu der Fritz Box unten im Büro.
Mein Hauptrechner neben mir ist durch ein Crossover Kabel mit dem Laptop verbunden.
Ich kann weder Daten austauschen noch mit dem Hauptrechner ins Netz.
Das Problem ist auch, dass ich wenn ich die LAN Verbindung aktiviere, die Internet Verbindung auf meinem Laptop auch nicht mehr funktioniert.

Ich schreib mal die Daten auf mit den IPs und jemand wird ja dann schon denke ich sehen was ich falsch gemacht habe:

(Hierzu habe ich in die Kommandozeile "ipconfig" eingegeben und folgendes stand dort)

Hauptrechner:

Ethernetadapter LAN-Verbindung:

Verbindungsspezifisches DNS-Suffix:
IP-Adresse. . . . . . . . . . : 192.160.170.25
Subnetzmaske. . . . . . . : 255.255.255.0
Standardgateway. . . . . : 192.168.178.2


Laptop:

Ethernetadapter Drahtlose Netzwerkverbindung:

Verbindungsspezifisches DNS-Suffix:
IP-Adresse. . . . . . . . . : 192.168.178.26
Subnetzmaske. . . . . . : 255.255.255.0
Standardgateway. . . . : 192.168.178.1


Ethernetadapter LAN-Verbindung:

Verbindungsspezifisches DNS-Suffix:
IP-Adresse. . . . . . . . . : 192.168.178.24
Subnetzmaske. . . . . . : 255.255.255.0
Standardgateway. . . . : 192.168.178.3


Ich weis ja nicht ob jemand damit was anfangen kann aber so habt ihr zumindest schon mal die Zahlen von beiden Rechnern. Vielleicht findest jemand ja einen Fehler in den ganzen Zahlenreihen.
Ich komm da einfach nicht mehr weiter. Ich bekomme noch nicht mal eine normale Verbindung zu beiden Rechnern so dass ich zumindest mal Daten austauschen kann.
Hat vielleicht die Windows Firewall damit was zutun oder AntiVir?


Naja ich bedanke mich schon mal im Voraus und hoffe das jemand ne Antwort hast!
Mitglied: Dani
28.12.2006 um 14:50 Uhr
Hi,
also erstmal solltest du die IP-Adresse von Laptop - LAN Verbindung ändern. Die Beiden können nur "miteinander reden", wenn Sie im gleichen Subnetz sind. Im Moment sind sie das aber nicht.

Notebook:
01.
Ethernetadapter LAN-Verbindung: 
02.
Verbindungsspezifisches DNS-Suffix: 
03.
IP-Adresse. . . . . . . . . : 192.168.170.2 
04.
Subnetzmaske. . . . . . : 255.255.255.0 
05.
Standardgateway. . . . :
Rechner:
01.
Ethernetadapter LAN-Verbindung: 
02.
Verbindungsspezifisches DNS-Suffix: 
03.
IP-Adresse. . . . . . . . . . : 192.168.170.2 
04.
Subnetzmaske. . . . . . . : 255.255.255.0 
05.
Standardgateway. . . . . :
In der Windows-Firewall sollst du einen Hacken Bei Drucker &- Dateifreigabe setzen. Jetzt müssten sich die beiden Rechner anpingen können. Am besten setzt du die Arbeitsgruppe der beiden Rechner gleich. Start => Einstellungen => Systemsteuerung => System => Computername => Ändern.

Wenn du die Änderungen an beiden Seiten gemacht hast, poste bitte mal die Routingtabelle vom Notebook. Dazu die Eingabeaufforderungen öffnen und "route print" eingeben. Danke...


Gruß
Dani
Bitte warten ..
Mitglied: aqui
28.12.2006 um 15:13 Uhr
Da ist dem Dani oben aber ein kleiner Flüchtigkeitsfehler unterlaufen, den du unbedingt korrigieren musst !
Die beiden LAN (Crossover) Host Adressen dürfen natürlich NICHT gleich sein !!! Also einer muss die .1 und einer die .2 haben !
Sascha hat den typischen Anfängerfehler mit IP Adressen gemacht ! Dein IP Segment im LAN (Crossover) und WLAN MUSS unterschiedlich sein ! Also sowas wie:

(Internet)---(Router).X---WLAN 192.168.178.0---.26(Latop).1---LAN 192.168.170.0---.2(PC)

Also wenn der Hauptrechner PC statisch die 192.168.170.2, Maske 255.255.255.0 und Gateway die 192.168.170.1 hat ist das schonmal ok.
Damit auch das Internet funktioniert MUSST du hier auch im DNS Servereintrag statisch die 192.168.178.x WLAN Adresse des Routers eintragen !!!)
Der Laptop hat dann analog am LAN Adapter die 192.168.170.1, Maske 255.255.255.0 (KEIN Gateway Eintrag und KEIN DNS Eintrag hier !!!)

Ein Ping in der Eingabeaufforderung und ein lokaler Datenaustasch sollte dann erstmal problemlos möglich sein, sofern Firewall auf den PCs/Laptop das zulassen und die Benutzerdaten entsprechend richtig eingestellt sind.
Alle weiteren Details zu deinem Setup findest du auch in Attis Tutorial:

http://www.administrator.de/Zwei_Netze_%FCber_WLAN_miteinander_verbinde ...

hier in der Rubrik Netzwerke -> Wireless LAN
Ewiger Nachteil dieser Konstruktion ist das dein Laptop immer aktiv sein muss damit der Hauptrechner ins Internet kann. Besser ist es vielleicht für 15 Euronen eine WLAN Karte für den Hauptrechner zu erwerben und den ebenfalls über das vorhandene WLAN an den Router zu hängen sofern dieser noch in WLAN Reichweite des Routers ist.
Bitte warten ..
Mitglied: Dani
28.12.2006 um 15:16 Uhr
Hi,
immer diese blöden copy und paste Fehler. Danke


Gruß
DAni
Bitte warten ..
Mitglied: 40723
28.12.2006 um 15:50 Uhr
Vielen Dank Leute!!!
Echt nett das man hier so schnell ne Antwort bekommt!!!
Hab mich heute erst angemeldet!!!

Sobald ich zuhause bin werde ich es mal probieren und euch dann davon berichten!

Gruß Sascha
______________________
www.swentertainment.de.ki
Bitte warten ..
Mitglied: 40723
29.12.2006 um 13:33 Uhr
So ich habe nun alles so gemacht wie beschrieben doch auf einander zugreifen kann ich noch nicht... der Laptop zeigt bei in der Netzwerkumgebung nur die Shared Docs von nem Kumpel an der mal mit mir Verbunden war und wenn ich von dem Ordner auf "Arbeitsgruppe" gehn will dann hängt diese sich auf. Beim Hauptrechner sieht man nur die Shared Docs von ihm selber und wenn ich da auf "Arbeitsgrupe" gehe dann zeigt er sich selber und den Laptop an doch auf den Laptop kann ich nicht zugreifen. Er sagt: Netzwerkpfad nicht gefunden. Ins Internet kann ich auch immer noch nur mit dem Laptop...

Ich habe beide Firewalls von Windows ausgeschaltet da ich auf dem Laptop Zone Alarm benutze und auf dem Hauptrechner im moment noch nix.

Was kann ich nun noch tun?

Gruß
Sascha.


PS.: Wie kann ich Bilder in ein Beitrag anzeigen damit ihr die Routing Tabelle mal sehen könnt?
oder soll ich sie per mail senden, Dani? Habe deine Addi aber nicht.
Bitte warten ..
Mitglied: aqui
29.12.2006 um 17:03 Uhr
Das Problem ist vermutlich Zone Alarm. Es gibt zuhauf hier Threads die dies belegen. Auch wenn Zone Alarm vermeintlich ausgeschaltet ist filtert es weiterhin oder "verbiegt" irgendwie den IP Stack ! Nicht mal ein Deinstallieren hilft, da immer noch Reste von Zone Alarm auf dem Rechner verbleiben und Unsinn machen...ein übles Produkt ! Auf der Zone Alarm Seite und anderen Quellen gibt es mitlerweile eine extra SW die diese Auswüchse komplett entfernen kann.

Leider schreibst du nicht ob ein Ping vom Rechner zum Laptop sowohl auf das Laptop LAN Interface als auch auf das Laptop WLAN Interface und das WLAN Interface des Routers klappt !! (Für letzteres vergiss die statische Route im Router nicht einzutragen auf dein Crossover Segment sofern du nicht mit ICS arbeitest !)
Das ist das Minimum was vorerst funktionieren MUSS ansonsten ist jedes weitere Troubleshooting sinnlos ! Der Ping verifiziert erstmal die nackte IP Verbindung und ist eine wesentliche Grundlage !
Ohne ein erlogreiches Ping wirst du auch keine Windows Shares sehen und natürlich auch kein Internet obwohl das Window Sharing wieder eine separate Baustelle ist, denn stimmen hier die Benutzersettings und Rechte nicht bei beiden Rechnern überein wirds auch damit nichts !
Fazit: Zone Alarm töten, Pings checken und dann sehen wir mal weiter....
Bitte warten ..
Mitglied: 40723
29.12.2006 um 17:21 Uhr
Wenn ich aber ZoneAlarm "töte" dann werde ich ohne eine Firewall ins Netz gehen und das ist wohl nicht sehr gut...
Weis ja nicht ob die Windows Firewall da besser hilft als ZoneAlarm...
Und was das Wort "Ping" betrifft da komm ich nicht mit klar...weis nur dass das was mit der Verbindung zu tun hat. Wie checke ich diese Pings? Und wie bekomme ich Zone Alarm komplett vom Rechner und diese fiesen Reste?

Danke das ihr alle so fleisig zurück schreibt!!! Komme dem Ergebniss immer ein Stück näher!

Gruß
Sascha
_______________________
www.swentertainment.de.ki
Bitte warten ..
Mitglied: aqui
30.12.2006 um 19:36 Uhr
Wenn du einen SP2 Patch drauf hast leistet die Win FW dasselbe. Externe FW sind sowieso umstritten, da sie gegen die richtigen Angriffe meist nicht helfen. Gerade Zone Alarm hat sich da in den letzten ct Test nicht gerade mit Ruhm bekleckert. Es gibt alternative Produkte wie Sygate oder Kerio die nicht so übel sind wie ZA wenn man denn wirklich unbedingt sowas einsetzen will....

Ping ist eines der wichtigsten Tools im Bereich von IP Connectivity und auf jedem Rechner OS verfügbar.
Wie das funktioniert siehst du indem du die Eingabeaufforderung aufmachst und dort mal "ipconfig" oder "ipconfig -all" (ohne ") eingibst. Dann siehst du deine eigene IP Adresse des Rechners !
Ein "ping 192.168.1.3" (wenn 192.168.1.3 die IP deines Rechners sein sollte) gibt dir dann ein
--Antwort von 192.168.1.3: Bytes=32 Zeit=8ms TTL=255--
zurück.
Ein sicheres Indiz das dein Rechner erreichbar ist im Netz. Also das gleiche wenn du einem Freund am anderen Ende der Strasse zurufst "Kannst du mich hören" und er dir ein "Jaaaa" zurückgibt
Nun ist es natürlich langweilig seinen eigenen Rechner zu pingen denn das der lokal im Rechner erreichbar ist ist klar....
Spannend wird es andere Rechner im Netz anzupingen und das geht immer mit "ping <RechnerIP-Adresse>" in der Eingabeaufforderung. Klappt das und du bekommst eine Antwort zurück ist alles OK mit deiner Adressierung, Verkabelung, Routing etc.
Du siehst, ein wichtiges Tool um dein Netz auf Funktion zu testen !
Bunte Bilder im Browser und Windows Verzeichnisse setzen nur darauf auf. Funktioniert das Ping nicht, funktioniert auch der Rest nicht.....
Ausnahmen passieren dann nur wenn dort finstere nicht richtig konfigurierte Firewalls wie ZA dazwischen sind und diese Netzwerk Packete blocken... Du kannst dir denken das es hier im Forum viele Leute gibt die auch nicht wissen was ein Ping ist, was ja auch generel kein Fehler ist. Von denen dann zu erwarten sie haben eine perfekt konfigurierte Firewall ist utopisch. Das gibt dir mal einen Eindruck wie komplex solche Vorhaben von dir sind und was man eigentlich hier alles erklären müsste wenn Teile eines Basiswissens dafür einfach fehlen....
Dafür machst du witzige Filme mit kleinen Hunden die in Fussbälle beissen...
Bitte warten ..
Mitglied: 40723
31.12.2006 um 12:57 Uhr
Perfekt! Dieses doofe ZoneAlarm war der Fehler!
Naja habe es runter geschmissen vom Notebook und die Windows Firewall aktiviert...
Dann all das gemacht was "aqui" beschreiben hat.
Nun funktioniert der Ping!!! Perfekt! Datenübertragung is nun kein Problem mehr! Super leistung!! Danke!!!
Doch ins Internet gehen mit dem Rechner das geht noch nicht...
Aber immerhin sind wir schon ein ganzes Stück weiter gekommen!

Danke!


Gruß
Sascha
Bitte warten ..
Mitglied: aqui
31.12.2006 um 15:32 Uhr
OK, das war dann der erste Schritt, dann machen wir mal weiter.....
Deine IP Adressen sollten damit 192.168.170.1 (Laptop) und .2 Hauptrechner sein. Sowie 192.168.178.26 auf dem WLAN Interface des Laptops und 192.168.178.1 auf dem Interface des Routers (FritzBox)

Auf dem Laptop solltest du erstmal das Routing einrichten wenn noch nicht geschehen:

http://www.microsoft.com/windows2000/de/server/help/default.asp?url=/wi ...

und ihn danach kaltstarten.
Ist er wieder startklar und du hast eine aktive WLAN Verbindung auf den Router machst du folgendes:

1.) Ping vom Hauptrechner auf das Crossover Interface des Laptops ! (Muss klappen)
2.) Ping vom Hauptrechner auf das WLAN Interface des Laptops ! (Muss klappen)

Funktioniert das ists nur noch ein kleiner Schritt:
Jetzt richtest du im Setup der Fritzbox eine zusätzliche statische Route ein in der Rubrik "zulätzliche Gateways oder zusätzliche Routen. Sie müsste sowas haben als Rubrik im Setup...
Der Eintrag in die Eingabefelder muss folgendermaßen aussehen:

Zielnetz: 192.168.170.0, Maske: 255.255.255.0, Gateway: 192.168.178.26

Damit bringen wir der Fritzbox den Weg zum .170er Netz zum Hauptrechner bei, denn woher sollte sie das kennen, es "versteckt" sich ja hinter dem Laptop !!!

Hier siehst du aber jetzt lauert auch die große Gefahr !!! Warum ???:
Der Router geht damit davon aus, das dein Laptop IMMER die .178.26 als Adresse hat um zum .170er Netz zu gelangen !
Wahrscheinlich lässt du den Laptop aber per DHCP (automatischer Adressvergabe) laufen und wenn dieser jetzt einmal NICHT mehr durch diese Dynamik die .178.26 erhält funktioniert nichts mehr in deinem Netz !!!

Fazit: Es ist besser dem Laptop der ja nun quasi nebenbei auch als Router für deinen Hauptrechner arbeitet auf der WLAN Interface eine STATISCHE IP Adresse zu vergeben, damit diese sich nicht durch DHCP ändern kann !!!
Das bedeutet für dich in den TCP IP Eigenschaften die Adresse FIX auf eine hohe Nummer zu setzen die man sich leicht merken kann wie die 192.168.178.222.

Also IP Adresse WLAN Interface fest auf die 192.168.178.222, 255.255.255.0 ändern und AUCH das Gateway UND den DNS Server statisch auf die 192.168.1.1 also die Routeradresse setzen !!!
Entsprechend natürlich dann die statische Route anpassen in der FB:

Zielnetz: 192.168.170.0, Maske: 255.255.255.0, Gateway: 192.168.178.222

So, das wars ! Nun folgende Pings probieren:
1.) Ping vom Hauptrechner auf das Crossover Interface des Laptops ! (Muss klappen)
2.) Ping vom Hauptrechner auf das WLAN Interface .178.222 des Laptops ! (Muss klappen)
3.) Ping vom Hauptrechner auf das Router Interface .178.1 ! (Muss klappen)

Wenn das alles klappt sollte nun auch final der Internetzugang vom Hauptrechner klappen.
Vergiss hier am HR nicht statisch den DNS Server die 192.168.178.1 (die FB) einzutragen und als Gateway die 192.168.170.1 (den Laptop) !!!

Bitte lese dir nochmal die Details in Attis Turorial durch hier unter "Wireless" !
http://www.administrator.de/Zwei_Netze_%FCber_WLAN_miteinander_verbinde ...

Dort steht nochmal alles genau drin (Routing Variante !). Zwar "umgedreht" für dich aber das Prinzip ist aber immer das gleiche !!!
Bitte warten ..
Mitglied: 40723
01.01.2007 um 14:53 Uhr
Der Ping vom Hauptrechner auf das W-LAN Interface funktioniert nicht! Die Konsole ziegt nur an: Zeitüberschreitung der Anforderung.

Das Prpblem is auch! Egal was ich für eine Ip Adresse ich in das Drahtlose Netzwerk rein schreibe,
es steht in der Konsole (nach eingabe von "ipconfig") immer das selbe dort.
Auch ein Gatewayeintag ist Vorhanden den ich irgentwann mal dort Eingetragen habe aber schon längst wieder rausgenommen habe. Auserdem wenn das WLAN Interface die Adresse nicht automatisch bezieht, dann klappt auch das Internet auf dem Laptop nicht mehr! und die Adresse die er bezieht kann ich auch nicht im "ipconfig" nachlesen weil ja immer das selbe angezeit wird obwohl was anders in der Registrierkarte steht!

Gruß
Sascha

PS.: Reg Eintrag habe ich geändert. So wie oben^^ beschreiben.
Bitte warten ..
Mitglied: aqui
01.01.2007 um 16:10 Uhr
Mmmmhhh, da hast du dann erstmal ein grundsätzliches Problem !!! Auf dem WLAN Adapter sollte problemlos in den Eigenschaften von "Internetprotokoll" eine statische IP Adresse, ein statisches Gateway und ein statischer DNS Server konfigurierbar sein und natürlich dann auch permanent drinbleiben.
Windows ist da aber oft zickig und der Stack hängt. Ein reboot mit den neuen statischen Werten sollte die aber permanent verankern und spätestens nach dem Reboot auch mit ipconfig richtig anzeigen.
Nur mal nebenbei: Siehst du bei der Adresse auch wirklich auf die WLAN IP oder evtl. auf das Kupferinterface ??? Da ändet sich natürlich nicht
Evtl gibst du mal ipconfig -all ein, dann bekommst du eine etwas detailiertere Ausgabe und die Interfaces werden beschriftet.

Das der Internet Zugang mit der statischen Adresse ad hoc nicht funktioniert kann normal sein, denn dein Router hat im ARP Cache ja noch die alte IP Adresse drin und versucht den Rechner immer noch damit zu erreichen.
Ein einfache Reload des WLAN Routers oder ein Ping vom Laptop auf den Router sollte den ARP Cache updaten und alles sollte wieder klappen.
Der Hauptrechner MUSS beide Interfaces des Laptops pingen können, sonst brauchst du erstmal nicht weiterzumachen......
Nochmal zur Erinnerung: Der Laptop hat NUR auf dem WLAN Interface ein Gateway und ein DNS Server konfiguriert außer der IP, auf dem LAN (Crossover) Interface wird lediglich nur IP und Maske konfiguriert sonst nichts !!
Der hauptrechner hat dann wieder alles drin, IP, Maske Gateway und DNS Server !
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Batch & Shell
WinXP-PC mit einem Barcodescanner herunterfahren (6)

Frage von Sinzal zum Thema Batch & Shell ...

CPU, RAM, Mainboards
Angetestet: PC Engines APU 3a2 im Rack-Gehäuse (2)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Router & Routing
Spielzeiten auf pc und handy steuern (7)

Frage von fisch56 zum Thema Router & Routing ...

CPU, RAM, Mainboards
PC Engines apu3a4 product file (7)

Link von ashnod zum Thema CPU, RAM, Mainboards ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...