Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

2 Raid Controller Falsche Bootsequenz

Frage Hardware Festplatten, SSD, Raid

Mitglied: Kabularasa

Kabularasa (Level 1) - Jetzt verbinden

28.12.2005, aktualisiert 30.12.2005, 6246 Aufrufe, 6 Kommentare

Von 2 im System installierten Raidcontrollern wird die bootsequenz immer vom alten zuerst initialisiert

Hallo
an alle die sich die Rübe über 2 im System verbauten Controllern zermattern wollen

Kacker hier schon 2 Tage ohne produktives Ergebnis rum, und wiege dem letzten Zahnarztbesuch mittlerweile mehr symphatie zu.

Es geht um folgendes:

Hatte in meinem System welches auf einem MSI K7N2 Delta-L basiert einen Silicon Image 0680 ATA Raid Controller mit 3 Platten im Stripping (Raid-0) Modus laufen. Der Verbund bekam 2 Partitionen ( 1xSystem, 1xStorage). SystemPartition mit WinXP begann vor kurzem bockmist zu machen, da hal.dll beschädigt war, nach dem ersetzen dieser die meldung von wegen boot.ini sei defekt. Also Reperatur Console gestartet und ma chkdsk laufen lassen, paar fehler gefunden und behoben. Wunderbar, dannach /bootcfg list und ein anschiessendes /bootcfg rebuild sollte abhilfe schaffen, tat es aber nichtl. Daraufhin linux-live system gebootet, raid eingebunden und ma mit ntfsfix gekuckt, hat nix gefunden, dannach nochmal /mbrfix... hat auch nix gebracht.... also kurzerhand systempartition gelöscht. (war ja nix wichtiges druf, 2. partition mit den ganzen krimskrams is ja noch da, und lässt sich auch lesen)

Ab zum nächsten Computer Shop und ma nen neuen Controller gekauft der sowieso schon her sollte. Und zwar einen Adaptec Serial ATA II 1420SA und dazu auch gleich ne WD Raptor mit 36 als neue System Platte.

Meine Idee dabei: Neuen Controller verbauen, WinXP auf den neuen Raptor drauf und die übrig gebliebene Storage partition vom alten Controller Backupn damit das mistding raus kann.

Gesagt getan, neuen Controller rein, WinXP Setup gestartet, installiert - siehe da... geht ja ab wie Sau (während der Installation alles unnötige ausgebaut und im mobo bios deaktiviert, damit nach erfolger installation schrittweise alles eingebunden werden kann)

Häng ich jetz den alten Controller mit den 3 Raid-0 Platten wieder ran, is nix mehr mit booten . Bootsequenz im MoBo Bios nach all mir sinnvoll (auch nicht sinnvollen) einstellungen durchgetestet.... noch immer kein Booten.
Nun gut, könnt ja sein das anhand der auf den PCI Lanes hängenden Karten die abfolge bestimmt wird, also einfach ma die 2 PCI plätze der Controller getauscht. (Aber jetz muss ja gehen) .... NOCH IMMER KEIN BOOTEN

Lass ich den alten raidcontroller drin und häng nur die 3 platten vom strom ab... Passt... Das Teil fährt in windeseile hoch. Das gleiche natürlich auch wenn der alte Controller überhaupt draussen is.

Neue Idee... Schreibst an Silicon Image.. die sollen dir ein Bios schicken das nicht bootfähig is... warte... warten... warten... keine antwort...
White Papers downgeloadet, vielleicht gibts ja ne jumper-setting für sowas ... auch nit...

So.. Nun steh ich hier ich armer Thor und bin so Schlau als wie zuvor

Also wer hier auch nur einen Ansatz einer Lösungsmöglichkeit wüsste oder auch nur vermutet... Bitter her damit... bin mittlerweile auch für unkonventionelle Lösungsmöglichkeiten offen... ( Der Lötkolben schreit schon nach Arbeit )

Danke im Voraus
Robert
Mitglied: leknilk0815
28.12.2005 um 15:11 Uhr
Hi,
ich tippe mal, daß aus Deiner Urkonfig auf den alten Platten ein Verweis von XP steht, welcher nun nicht mehr richtig verwertet werden kann, da Du ja in Abwesenheit der alten Platten neu installiert hast.
Ich denke, eine Neuinstallation (oder Reparatur der Bestehenden) mit eingebauten Platten sollte Dein Problem lösen, da hierbei der MBR an die aktuelle Konfig angepasst wird.
Gruß - Toni
Bitte warten ..
Mitglied: Kabularasa
28.12.2005 um 15:36 Uhr
*KLATSCH - Mir auf die Birne hau*

Warum mir sowas nicht einfällt LOL, der Lösung doch schon so nahe, aber zu blöde das wesentliche zu erkennen...

Jawohl Ja, dank dir vielmals werd ich sofort ausprobieren.
Geb dann bescheid obs gefunkt hat

Danke nochmal
lg Robert
Bitte warten ..
Mitglied: Kabularasa
29.12.2005 um 19:01 Uhr
Also jetz tuts schön langsam weh... *HAARE-ZERAUF*

Was bissher geschah:
200 GB Platte von Kollega geborgt, onboard angeschlossen, und mit einer temporären ebenfalls onboard angeschlossenen platte inkl. Winxp gestartet, Backup gemacht, somit is das wichtige zeugs mal in sicherheit.
Dannach die Platten des alten Raid-0 Verbundes komplett geleert, formatiert, komplett partitioniert, somit is da nix mehr mit mbr der ins leere zeigt.

Wieder umgesteckt... und zwar wie folgt:

onboard: DVD-Reader CD-Writter DVD-Writter
SIL 0680er PCI Controller: 3 Hitachi Platten im Raid - (´habe das raid auch aufgelöst und neu gebildet)
Adaptec 1420SA PCI Controller: die WD Raptor mit dem neuen WinXP System druf..

sollte ja nix mehr schiefgehen können... aber was muss ich zu meiner verwunderung feststellen?

Egal an welchen PCI slots ich die 2 Controller hänge - sobald auf dem Alten Sil 0680er Controller die Platten nur dranhängen will er mir nix mehr vom neuen Adaptec booten ... WTF!!!!!
Die platten am SIL dann neu partitioniert .... erweiterte partition das da ja nix is was nach bootbarem zeugs aussschaut... ja warum zum teufel nochmal ... erkennt das teil nit das es da nix zum booten gibt, und bootet dann eben vom andren (neuen) controller vom dem er das auch soll !?!?!?!?!?!?
Also bin schon so weit das ich demjenigen der mir des Rätsels Lösung anbieten kann einen Fetten Geschenkskorb mit Wein & Käse zukommen lasse.... oder was auch immer LOL

Robert
Bitte warten ..
Mitglied: leknilk0815
29.12.2005 um 19:37 Uhr
Hi,
der SIL hat doch bestimmt ein Konfi- Menü, welches man beim booten starten kann. Eigentlich sollte man hier das BIOS des Kontrollers deaktivieren können (bei Adaptec ist das zumindest so)???
Gruß - Toni
(baldauchnixmehrweiß)
Bitte warten ..
Mitglied: Kabularasa
29.12.2005 um 20:49 Uhr
Hi,

Leider nicht, es gibt natürlich ein BIOS des Controllers allerdings sind meine Einstellungs-Möglichkeiten hier auf das verwalten der Platten beschränkt. Raid erstellen, löschen usw..
Mehr kann man da nicht anstellen.
Es gibt zwar ... sage und schreibe 1en Jumper... mit dem kann man BAR5 en/dis ablen..
Konnte allerdings keine Infos dazu finden was das sein soll. Auch Silicon Image selber hat mir noch nicht geantwortet... aber naja... werd ma schauen was sich da tut wenn man umsteckt LOL..
Bericht folgt in Kürze obs was geholfen hat oder nit
Bitte warten ..
Mitglied: Kabularasa
30.12.2005 um 04:34 Uhr
Tjoa... das zucken im Augenberreich nimmt nun schon verheerende Ausmaße an

Also auch der Bar5 Jumper konnte an der Momenten Situation nix ändern. Und das BIOS des SIL 0680er lässt hier auch nicht die geringste Einstellungsmöglichkeit zu....

Maybe doch noch jemand eine Idee !?!?!?! Habe auch schon versucht im MoBo Bios die IRQ Prioritäten der einzelnen PCI Lanes zu ändern damit der Controller von dem gebootet werden soll eine höhere zugiewesen bekommt.... aber das juckt dem Kerl auch nit wirklich...

Also einzige Lösung die mir im Mom noch einfällt is hier ne firmware die das booten des Controllers einfach deaktiviert... Sollt sowas für jemanden der Assembler aus dem FF beherrscht machbar sein !?!?!?!

Grüße Robert
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Festplatten, SSD, Raid
gelöst Adaptec 6805 Raid Controller - defekt? (15)

Frage von Axel90 zum Thema Festplatten, SSD, Raid ...

Festplatten, SSD, Raid
RAID Controller mit oder ohne Cache (24)

Frage von oce zum Thema Festplatten, SSD, Raid ...

Server-Hardware
gelöst RAID-Controller externer Anschluss (Mini-SAS) (3)

Frage von Grimrott zum Thema Server-Hardware ...

Festplatten, SSD, Raid
gelöst Welchen Hardware Raid Controller für Workstation (27)

Frage von michi1983 zum Thema Festplatten, SSD, Raid ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...