Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

2 Router hintereinander schalten (Upload sinkt)

Frage Netzwerke

Mitglied: eXitus01

eXitus01 (Level 1) - Jetzt verbinden

09.10.2010, aktualisiert 18.10.2012, 5085 Aufrufe, 5 Kommentare

Hallo zusammen,

ich habe bei mir 2 Router hintereinander geschaltet doch wenn ich dazwischen keinen Switch benutze ist mein Upload ca. bei 44 kByte/s und normal ist ca. 127 kByte/s.

Ich versuche es mal dazustellen

Router1(LAN) <---Lankabel1---> Switch <----Lankabel2---> Router2(WAN) = 127 kByte/s
Router1(LAN) <---Lankabel1--->Router2(WAN) = 44 kByte/s

An Router2(LAN) hängt mein Client dran.

Wenn ich den direkten Weg von Router1 auf Router2 gehe, sinkt mein Upload stark, wenn ich ABER dazwischen einen Switch schalte ist alles ganz normal.

Kann mir einer sagen wo mein Fehler ist?


Hier die Daten der Router. Der Switch ist nicht konfigurierbar (Layer2?!)

Router1
Typ: AVM Fritz.Box 7050
IP-LAN: 10.1.0.254


Router2
Typ: Draytek Vigor2200E+
IP-WAN: 10.1.0.253
IP-LAN: 10.0.0.254
Gateway: 10.1.0.254
DNS: 10.1.0.254


Client
IP: 10.0.0.51
Gateway: 10.0.0.254
DNS: 10.1.0.254


MfG
eXitus01
Mitglied: aqui
09.10.2010, aktualisiert 18.10.2012
Man kann nur hoffen das due 24 Bit Subnetzmasken bei deinen IP Netzen benutzt (255.255.255.0) sonst hast du ein Problem mit der IP Adressierung.
Dein Szenario ist im großen und ganzen dieses hier, richtig ?:
http://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ...

Vermutlich gibt es ein Autonegotiation Problem an den WAN bzw. Switchports der beiden Routerkomponenten. Die sind dann nicht in der Lage sauber auszuhandeln welche Geschwindigkeit sie haben und welchen Duplex Modus sie fahren.
Dadurch kommt es auf dem Verbindungslink zu Kollisionen und alles rennt im 3ten Gang. Ist ein typisches Problem. Der Switch dazwischen kompensiert das vermutlich.
Was du machen kannst um das zu fixen:
  • Anderes Verbindungskabel mit besserer Qualität probieren.
  • Ein Ethernet Crossover Kabel benutzen zur Verbindung.
  • Verbindungsports einzeln statisch auf feste Geschwindigkeit und festen Duplex Modus einstellen.
Eins der Maßnahmen sollte das Problem fixen.
Bitte warten ..
Mitglied: ButterkeksXXL
09.10.2010 um 17:04 Uhr
Hallo.

Für mich stellen sich gerade 2 Fragen.

1. Warum überhaupt der 2te Router, wenn du doch ein Switch hast, mit dem du den PC verbinden kannst?
2. Hast du bei dem Router, der nicht direkt mit dem Inet verbunden ist sämtliche "Router-Funktionalitäten" deaktiviert? (z.B. NAT, sollte man im Normalfall Zuhause in einem LAN nicht benötigen)

Aber auf jeden Fall erst mal Möglichkeit 3 von aqui probieren.

@aqui:
Was genau soll die Verwendung eines Crosskabels in diesem Falle bewirken? (meines Wissens nach benutzte man diese Technologie vor einigen Jahren um eine kabelgebundene P2P Verbindung herzustellen)
Zu Möglichkeit 1:
Inwiefern soll die Verwendung eines qualitativ besseren Kabels helfen? Wenn bei der Switch Methode ein Durchsatz >127kByte/s erreicht werden kann, stellt das Verbindungskabel in diesem Szenario keineswegs ein Bottle-Neck dar (bitte korrigiere, sollte ich mich irren)


Beste Grüße,
Keks
Bitte warten ..
Mitglied: aqui
09.10.2010 um 18:00 Uhr
@Butterkeks
Häufig behindern billige nicht geschirmte Taiwankabel die bei Routern oft als Dreingabe im Paket liegen die korrekte Autonegotiation durch Übersprechen etc. Deshalb der Tip.
Bei einem Crosskabel ist es das gleiche. Systeme die kein richtiges MIDI-X supporten haben meist auch Probleme die Autonegotiation richtig hinzubekommen, dehalb der Tipp mit dem Crosskabel was das auschliesst da so 1:1 TX auf TX Pärchen kommt und RX auf RX.
Zu deiner Frage 1:
Es ist denkbar das Kollege eXitus01 sich eine "DMZ des kleinen Mannes" bauen will:
http://www.heise.de/netze/artikel/DMZ-selbst-gebaut-221656.html
Dafür sind zwingend solche Router Konstellationen erforderlich. Ein dummer L2 Switch nutzt ihm da dann herzlich wenig ! Falls er nur die Anzahl der LAN Ports an einem Router vervielfachen will ist der Ersatz eines 2ten Routers natürlich Blödsinn, da hast du zweifelsfrei Recht !
Kann man nur hoffen das er nun keinen Exitus erleidet
Bitte warten ..
Mitglied: eXitus01
10.10.2010 um 10:16 Uhr
Hallo zusammen,

und nein ich bin noch nicht eXitus...

Erstmal Danke für die Tipps doch leider bin ich nicht sehr viel weiter gekommen.

Wieso ich 2 Router hintereinander schalte:
Router1 also die fritz.box macht WLAN und das Telefon für VoIP ist dort angeschlossen.
Der Router2 also der Draytek ist für VPN zuständig, weil die Fritz.Box das nicht kann.

@aqui
Meine Subnetzmask lautet immer (255.0.0.0) weil ich im Class A Bereich bin "10.1.x.x / 10.0.x.x"

Ein anderes Kabel steht mir nicht zur Verfügung in dieser länge aber das Kabel was ich momentan benutze ist relativ neu und gut. Also kann meiner Meinung nach der Fehler nicht am Kabel liegen.

NAT kann ich bei mir am Router2 nicht deaktivieren, und unter NAT habe ich die offnen Ports eingetragen für einige Programme.

DMZ Host ist bei mir in Router2 deaktiviert.

Ich habe momentan nur versucht die Geschwindigkeit in Router2 manuell festzulegen (100MBit/s Voll Duplex) zum Test auch (100MBit/s Halb Duplex) doch leider ohne Erfolg, der Upload liegt immer noch bei 44 kByte/s.

Was ich ganz oben vergessen habe zu erwähnen ist, dass der Download mit Switch und auch ohne Switch konstant bleibt.

Deswegen kann ich mir nur vorstellen, dass es eine Fehleinstellung irgendwo gibt.

Ich wäre auch bereit jemand per TeamViewer oder VNC draufschauen zu lassen.
Bitte warten ..
Mitglied: aqui
10.10.2010 um 11:34 Uhr
"Klassen" gibt es schon lange nicht mehr bei IP Adressen, vergiss das also. Außerdem kannst du das 10er IP Netz ja auch beliebig subnetten und dort auch eine 24 Bit Maske verwenden mit 255.255.255.0 das ist kein Thema.
Nebenbei ist deine Angabe oben Unsinn ! "10.1.x.x / 10.0.x.x" würde ja bedeuten das du dann mit einer 16 Bit maske (255.255.0.0) arbeiten würdest und nicht mit einer 8 Bit maske (255.0.0.0)

Solltest du wirklich nur mit einer 8 Bit Maske arbeiten bzw. das so auf deinem Draytek eingestellt haben hast du einen schweren Kardinalsfehler bei der IP Adressierung begangen und dann ist es klar das es nicht funktionieren kann.
Mit einer 8 Bit Maske (255.0.0.0) wären beide Interfaces des Draytek in einem einzigen IP Netz, denn die ersten 8 Bit der Maske maskieren ja nur das Netzwerk 10.0.0.0 !!
10.1.x.x ist dann eine normal Host Adresse in dem selben IP Netz. Damit kann der Dratek dann nicht mehr routen da er keine unterschiedlichen Netze mehr an seinen Interfaces hat sondern nur noch ein einziges IP Netz, das 10er Netz !!
Lies dir also besser erstmal die einfachen Grundlagen der IP Adressierung durch:
http://de.wikipedia.org/wiki/IP-Adresse#Netzwerkteil_und_Ger.C3.A4tetei ...

Du benötigst also zwingend eine 16 Bit Maske (255.255.0.0) im 10er Netz (oder 24 Bit 255.255.255.0 geht auch)
Richtig muss dann deine Einstellung der Netze an den Routern mit 16 Bit Maske so lauten:
Router 1
Typ: AVM Fritz.Box 7050
IP-LAN: 10.1.0.254, Maske: 255.255.0.0

Router 2
Typ: Draytek Vigor2200E+
IP-WAN: 10.1.0.253, Maske: 255.255.0.0
IP-LAN: 10.0.0.254, Maske: 255.255.0.0
Gateway: 10.1.0.254

Die verbindung der Router sieht so aus:
(Internet)-----DSL-Port(Fritzbox)LAN-Port----10.1.0.0 /16----WAN-Port(Draytek)LAN-Port----10.0.0.0 /16----(Client)

So und nicht anders wird ein Schuh draus ! Ansonsten "Exitus" für den Draytek !!
Bitte warten ..
Ähnliche Inhalte
DNS
DNS Probleme bei bei mehreren Routern hintereinander
Frage von istike2DNS4 Kommentare

Hallo, wir haben einen SFR Modem (eigentlich auch ein Router) und ein Synology-Router dahinter. Der Synology Router macht QoS, ...

Netzwerke
Upload bei Router eingeschränkt
Frage von rich500Netzwerke18 Kommentare

Hallo, bin ein relativ unwissender und würde eure Hilfe benötigen. Habe einen Load Balance Router (Tp Link ER 5120) ...

Router & Routing
4G Router vor Vigor 2830 schalten
Frage von hoschi1974Router & Routing12 Kommentare

Hallo, ich habe hier einen Vigor 2830 und habe das Internet bisher über ADSL bekommen. Habe eine VPN Verbindung ...

LAN, WAN, Wireless
Transferrate im PowerLAN sinkt "über Nacht"
gelöst Frage von Super-NerdLAN, WAN, Wireless7 Kommentare

Folgende Netzwerkumgebung findet sich in meinem privaten Haushalt: VDSL von o² 50 MBit/10MBit. Diese werden auch tatsächlich stabil geliefert ...

Neue Wissensbeiträge
Mac OS X

MacOS wo ist die Tilde ?

Tipp von Alchimedes vor 6 StundenMac OS X1 Kommentar

Hallo, ich hab eine MacOS qwertz Keyboard auf US Layout umgestellt da die Sonderzeichen besser erreichbar sind. Leider fehlt ...

Datenschutz

Weitere Informationen zum Sicherheitsproblem BeA

Information von Penny.Cilin vor 13 StundenDatenschutz

Im folgenden ein weiterer Bericht über die Sicherheitsprobleme von Bea. Fataler Konstruktionsfehler im besonderen elektronischen Anwaltspostfach Gruss Penny

Windows 10

Systemdienste behalten nach Win10 inplace-Upgrade nicht die ggf. modifizierte Startart bei

Tipp von DerWoWusste vor 15 StundenWindows 103 Kommentare

Stellt Euch vor, Ihr habt ein Win10 System und modifiziert dort die Startart von Systemdiensten. Zum Beispiel wollt Ihr ...

Microsoft Office

Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei

Anleitung von SarekHL vor 18 StundenMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...

Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von fyrb38Windows 1018 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Microsoft Office
Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei
Anleitung von SarekHLMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...