Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

2 Vlans die auf einem Server zugreifen

Frage Netzwerke LAN, WAN, Wireless

Mitglied: chaotize

chaotize (Level 1) - Jetzt verbinden

24.08.2012 um 10:14 Uhr, 5773 Aufrufe, 10 Kommentare

Hallo,

Ich habe ein Problem. Ich soll für ein Praktikum Vlans auf einem Hp procurve 2524 konfigurieren.
Es gibt 2 Clients und einen Server
jeder Client soll in einem anderen Vlan sein. Beide sollen voneinander getrennt sein aber auch auf den server zugreifen können.
Client 1: Ip: 192.168.200.30
Client 2: Ip: 192.168.201.30
Server: Ip1: 192.168.200.2
Ip2: 192.168.201.2
Ich benutze für den Server einen Hp Netserver 10/100tx Netzwerkadapter
Habe mir ProSuit von intel installier da die Karte das unterstüzen sollte
Habe auf dem Server 2 Vlans konfiguriert und auf dem ProCurve den server in beiden Vlans auf Tagged geschaltet
Sobald ich aber die beiden Vlans auf dem Netzwerkadapter konfiguriere bekomme ich keine Verbindung mehr zum Switch.
Meine frage ist wo lieg mein fehler??
bitte um eine schnelle Antwort

Mit freundlichen Grüßen Chaotize
Mitglied: jayjay0911
24.08.2012 um 10:26 Uhr
Bin in VLANs net mehr 100% fit, aber wäre es nicht einfach sinnvoller, im Server 2 Netzwerkkarten zu verwenden, für jedes VLAN eine??
Bitte warten ..
Mitglied: chaotize
24.08.2012 um 10:29 Uhr
Würde ich wenn ich könnte kann ich aber nicht.
Wie schon gesagt ist für das Praktikum.
Der Server wird mir lediglich zur verfügung gestellt.
Bitte warten ..
Mitglied: aqui
24.08.2012 um 11:40 Uhr
Diese beiden Tutorial sollten alle deine Fragen umfassend beantworten:
http://www.administrator.de/contentid/110259 (Routing wegdenken)
und
http://www.administrator.de/contentid/58974
2 NICs ist unsinnig, denn die brauchst du bei VLANs nicht.
Bitte warten ..
Mitglied: chaotize
24.08.2012 um 12:49 Uhr
Nach dem zweiten Tutorial habe ich auch gearbeitet habe den Switch configuriert (vom Server aus) habe dann den server als Tagged in Vlan 10 und 20 deklariert und habe dann per Intel ProSuit die 2 Vlans hinzugefügt danach habe ich auch 3 seperate netzwerke. Das Problem der eigentliche physische Adapter ist dann nicht mehr verbunden (die beiden Vlans schon) wenn ich dann probiere die Ip-addresse an dem Adapter zu ändern (nicht an den Vlans) dann funktioniert das nicht die Vlan-adapter kann ich eigene IPs geben und trotzdem kann ich danach nicht mehr auf die Konfigurationsseite des Switches....
Bitte warten ..
Mitglied: aqui
24.08.2012, aktualisiert um 13:08 Uhr
Doch, der ist noch verbunden ! Leider hast du wie so oft hier das Tutorial nicht richtig gelesen oder verstanden
(Zitat) "Man darf nicht vergessen das das VLAN 1 als sog. Default VLAN laut Standard IEEE 802.1q immer auf dem Adapter und auch dem Switch verfügbar ist. Lediglich wird es ohne den VLAN Label am Packet also untagged übertragen. Hat man also nur 2 Netze würde auch die Einrichtung nur eines VLANs theoretisch reichen.
(Zitatende)
Der native NIC Adapter ist folglich immer untagged an dem Anschluss. (802.1q Standard !!) Wenn nicht anders am Switch konfiguriert (native VLAN) dann wird dieser untagged Traffic vom Switch immer ins Default VLAN geforwardet.
Das Default VLAN ist immer das VLAN 1, das sollte auch bei den grauslichen HP ProCurve Gurken so sein !
Wenn du also einen Client an einem Default VLAN 1 Port am Switch anschliesst kommst du ach wieder auf den eigentlichen physischen Adapter.
Die Konfigurationsseite des Switches ist (sofern du es nicht verändert hast in der Konfig) immer im VLAN 1.
Kann man auch selber immer leicht an der ProCurve Konfig ablesen wenn man sich denn mal die Mühe macht...:
vlan 1
name "DEFAULT_VLAN"
untagged 1-24
ip address 172.16.1.1 255.255.255.0
exit
vlan 10
name "VLAN-10"
untagged 10-15
tagged 1
exit
vlan 20
name "VLAN-20"
untagged 20-24
tagged 1
exit

Obwohl die Ports 10 bis 15 und 20 bis 24 tagged in den VLANs 10 bzw. 20 sind sind sie IMMER untagged in VLAN 1.
Folglich kannst du also nur und einzig über das VLAN 1 (das default VLAN) auf den Switch zugreifen und auch über dieses VLAN 1 die native NIC des Servers ! IP Bereich von der nativen NIC IP des Servers und des Switches sollten sich also immer in einem gemeinsamen IP Netzwerk befinden...logisch !
Alle VLANs sind pyhsisch voneinander getrennt wie das ja nunmal bei VLANs so ist. Eine Kommunikation zwischen den VLANs ist also nicht möglich.
Ausnahme du hast einen Layer 3 fähigen Switch (Routing) oder du routest über den Server selber:
http://www.administrator.de/contentid/56073
was du aber am Server aktivieren musst !
Wenn du also von einem der anderen VLANs kommst und auf den Switch in VLAN 1 zugreifen willst MUSST du also irgendwie in einer Form routen zwischen den VLANs.
Steht auch alles so im Tutorial !!
Vermutlich hast du also entweder das Routing im Server zw. den VLANs nicht aktiviert (Server ist dann hier VLAN Router) oder du hast einen Switch der kein Layer 3 Switching (Routing) kann oder nicht aktiviert hat.
Leider sagst du zu dem Thema ja rein gar nix so das wir hier nur im freien Fall raten können
Bitte warten ..
Mitglied: chaotize
24.08.2012, aktualisiert um 13:13 Uhr
Ja das routing auf dem server ist nicht aktiviert xD
Hat mir ja so schon geholfen. Der Procurve 2524 switch ist glaube ich ein Layer 2 switch. Bin mir aber nicht 100% sichert.

Jetzt noch was mir war schon klar das ich nur an den Switch herankomme wenn ich im Default-Vlan bin das hab ich auch ausprobiert sprich ein neuen Virtuellen netzwerk adapter gemacht fürs Vlan 1 trotzdem tat sich nichts .

der Server hängt an Port 4 die Clients habe ich noch nicht dran weils Virtuelle sind xD
An port eins Hängt ein weiterer Procurve 2524 switch der aber noch nicht im Gebrauch ist.

Waren das jetzt alle Infos die du haben wolltest xD??
Bitte warten ..
Mitglied: aqui
24.08.2012, aktualisiert um 13:34 Uhr
.. .sprich ein neuen Virtuellen netzwerk adapter gemacht fürs Vlan 1 trotzdem tat sich nichts...
Das ist auch Blödsinn, denn das funktioniert nicht. Damit käme das mit einer VLAN ID (Tag) 1 dort raus, den ignoriert der Switch aber da das VLAN 1 das Default VLAN ist das man nicht taggen kann.
Klar also das der Versuch in die Hose geht !
Wie gesagt: Immer der nackte NIC Adapter, das also was du auch ohne virtuelle VLAN Verbindungen im Netzwerk Setup des Servers siehst DAS ist immer im Default VLAN 1, denn dieser Traffic von dieser LAN Verbindung kommt immer untagged ,also ohne VLAN Tag, wie oben schon mehrfach geschrieben zum Switch.
Dieser Traffic landet dann also folglich immer im Default VLAN (1) des Switches ! Das musst du immer so hinnehmen und ist so Fakt.
Bei besseren Switches kannst du diesen untagged Traffic an einem tagged Port auch am Switch in eine anderes VLAN forwarden z.B. mit dem Kommando "switchport native vlan 30" z.B. ins VLAN 30.
M.W. supporten die ProCurve Gurken sowas aber nicht oder du musst mal im Manual nachsehen ob sie es in der Zwischenzeit können.
Es ist ja aber so oder so kein Problem, denn ob der Traffic nun in VLAN 1 oder VLAN x rauskommt ist für das was du vorhast ja erstmal vollkommen Latte. Jeglicher Traffic vom Server ist ja immer sauber in die VLANs getrennt genau wie es sein soll !

Damit das zum anderen Procurve Switch transparent klappt musst du dort also folgendes tun:
  • Auf dem 2ten Switch auch die VLANs 10 und 20 (identisch zu den VLAN IDs die am Server und am 1.Switch eingerichteten) einrichten !
  • An Port 1 diese beiden VLANs tagged einrichten auf beiden Switches ! Dann beide Switches über Port 1 verbinden. Das Default VLAN 1 liegt so oder so immer untagged an und wird so auch übertragen.
Wenn du jetzt einmal strategisch vorgehst und dir auf einem oder beiden Switches mal je einen Endgeräteport untagged ins VLAN 10 und einen untagged ins VLAN 20 setzt dann kannst du die Verbindung doch ganz einfach testen:
  • Client z.B. Test-Laptop aufgesteckt an einem Port untagged in VLAN 1 mit entsprechender IP Adresse aus VLAN 1: Hier MUSS nun ein Ping auf die native NIC IP am Server und auf die Switch IP möglich sein !
  • Client z.B. Test-Laptop aufgesteckt an einem Port untagged in VLAN 10 mit entsprechender IP Adresse aus VLAN 10: Hier MUSS nun ein Ping auf die virtuelle VLAN IP am Server möglich sein !
  • Client z.B. Test-Laptop aufgesteckt an einem Port untagged in VLAN 20 mit entsprechender IP Adresse aus VLAN 20: Hier MUSS nun ein Ping auf die virtuelle VLAN IP am Server möglich sein !
Das sollte dann von beiden Switches funktionieren wenn du alles richtig konfiguriert hast !
Hast du das schon mal gemacht bzw. getestet ??
Sehr sinnvoll wäre es mal du postest hier einmal deine Switchkonfig wie die Beispielkonfig oben der relevanten Ports UND postest mal welche IPs du in den VLANs verwendest. DAS wären hilfreiche Infos die weiterführen ?!
Hier zwingst du uns ja auch zum in die Kristallkugel sehen
Bitte warten ..
Mitglied: chaotize
24.08.2012 um 13:45 Uhr
Glaub jetzt hab ich verstanden was du von mir möchtest .
Einen testClient habe ich noch nicht angeschlossen. Muss erstmal einen aufsetzen etc. Bin auch gerade nicht bei den Switches kann dir aber ungefähr mal die Konfiguration posten:

Verwende momentan ja nur einen switch der andere ist nich im gebrauch td schon konfiguriert.

Switch 1 IP: 192.168.200.10
Switch 2 an port 1 IP: 192.168.200.11
Client 1 soll später an Port 2 ins Vlan 10 IP:192.168.200.30
Client 2 soll später an Port 3 ins Vlan 20 IP:192.168.201.30
Server an Port 4 Vlan 10 IP:192.168.200.2, Vlan 20 IP: 192.169.201.2

Vlan 10
Port 1 Tagged
Port 2 Untagged
Port 3 no
Port 4 Tagged

Vlan 20
Port 1 Tagged
Port 2 no
Port 3 Untagged
Port 4 Tagged

Ich meine so hatte ich gestern die Configuration.

schon allein das du so schnell schreibst möchte ich dir danken
.
Bitte warten ..
Mitglied: aqui
24.08.2012, aktualisiert um 14:14 Uhr
Moment ich muss erstmal die Lupe suchen um deine Schrift lesen zu können...
OK, VLAN Konfig ist soweit richtig.
Den Test kannst du dann wie oben beschrieben mal über Port 2 und Port 3 machen was die VLAN Interfaces auf dem Server anbetrifft.
Für die physische NIC nimmst du dann einen Port der untagged im default VLAN 1 ist und pingst dann da mal die Server IP mit.
Soweit zu dem...
Was niemals geht ist das die Switches mit ihren IP Adressen auch im VLAN 10 liegen. Damit ist eine VLAN übergreifende Konfig nicht möglich denn du hast das gleiche IP Netz dort wie auch im VLAN 10 Segment und damit dann am Server doppelte IPs. Ein no go im IP Design wie jeder kundige Netzwerker weiss.
Wie gesagt, der Server, der ja wenn du so willst jetzt 3 NICs hat, hat damit an der physischen NIC und an der NIC VLAN 10 das gleiche IP Netzwerk !!
Das geht natürlich nicht, siehe auch HIER.
Vermutlich ist das dein Kardinalsfehler im IP Design !
Was geht ist z.B. folgendes:
  • Switch 1 IP: 192.168.200.10 /24 und Switch 2 IP: 192.168.200.11 / 24 (255.255.255.0 Maske = /24)
  • Server an Port 4 Vlan 10 IP:192.168.210.2, Vlan 20 IP: 192.169.220.2
  • Client 1 an Port 2 ins Vlan 10 IP:192.168.210.30
  • Client 2 an Port 3 ins Vlan 20 IP:192.168.220.30
  • Client im Default VLAN 1 mit IP:192.168.200.30 der dann Zugriff hat auf die native Server NIC IP 192.168.200.2 und die beiden Switch IPs .200.10 und .200.11
So wird ein Schuh draus und nicht anders !
Damit sind alle Segmente eindeutig adressiert und wenn du noch Routing am Server aktivierst wie im Tutorial beschrieben kannst du auch von allen VLANs auf den Switch und auch alle Clients in anderen VLANs zugreifen. Natürlich nur sofern das gewollt ist...sonst eben kein Routing.
Besser ist da dann auch ein kleiner externen Router wie es das Tutorial ja auch umfassend beschreibt.
Liest man die Tutorial mal aufmerksam steht das dort auch genau so zu IP Adressierung !
Bitte warten ..
Mitglied: chaotize
30.08.2012 um 08:59 Uhr
Hallo Aqui,

und auch hier hast du mir wieder geholfen. Habe mich heute noch mal an die Vlans gesetzt und ausprobiert ob der Server von beiden VLANs erreichbar ist. Es hat funktioniert =). Ich will dir wirklich für deine hilfe danke =).
Der beitrag kann also als glöst makiert werden =).
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Netzwerke
gelöst Zugriff auf Server von verschiedenen VLANs aus (6)

Frage von Kroeger02 zum Thema Netzwerke ...

LAN, WAN, Wireless
VLAN mit pfSense Routing: Server als Mitglied in mehreren VLANs (1)

Frage von Ruuder zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
gelöst Aus dem Heimnetzwerk (Fritzbox) auf VNC Server mit fester IP-Adresse zugreifen? (3)

Frage von BigL15 zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (21)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...