Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Netzwerke LAN, WAN, Wireless

GELÖST

2 Vlans über Trunk (LACP)

Mitglied: nestasko

nestasko (Level 1) - Jetzt verbinden

08.07.2009, aktualisiert 19:18 Uhr, 16466 Aufrufe, 4 Kommentare

Hallo zusammen,

ich arbeite an einem Projekt wo ich momentan nicht weiterkomme und hoffe dass der eine oder andere mir evtl dabei weiterhelfen kann.

Ich habe 2 Vlans erstellt mit der ID1 und ID2
VLAN1 (10.10.100.1/24) soll die komplette IT Infrastruktur aufnehmen (Switche, Controller, Server etc.) und VLAN2 (10.0.0.0/24) den Internet Traffic.
Eigesetzt habe ich diverse HP Switche 2900, 2626, dabei ist es so, dass sich ein Teil der Infrastruktur an einem anderen Platz befindet der mit dem IT Zentrum verbunden werden muss.
Um eine grösst mögliche Bandbreite zu haben benutze ich einen Trunk (channel bonding) vom Standord A über einen Hop (Standord B) nach Standord C.
Am Standord A wird der Trunk erstellt. Standord B übernimmt den Trunk und sendet ihn schliesslich nach Standord C.
Vom Standord B und C aus kann ich ohne Probleme auf jegliche Schnittstellen im VLAN1 zugrreifen, aber komme auf keine Schnittstelle im VLAN2.

Eingreichtet habe ich den Trunk folgendermaßen:

Switch am Standord A

VLAN1 VLAN2
Port 23/24 TRK1 untagged tagged


Switch am Standord B

VLAN1 VLAN2
Port 1/2 Dyn1 Dyn1 LACP (hier kommt der Trunk an)
Port 23/24 TRK1 untagged tagged (hier neu definiert)


Switch am Standord C

VLAN1 VLAN2
Port 23/24 TRK1 Dyn1 Dyn1 LACP


Wo ist mein Denkfehler hierbei? Das tagging muss ich einsetzen da man nicht 2 Vlans untagged über einen Port senden kann.
Ich habe diverse Endgeräte benutzt die VLAN Tagging beherrschen aber komme nicht auf diese Schnittstellen?

Ich wäre sehr dankbar für mögliche Ansatzpunkte!

Gruss
Mitglied: aqui
09.07.2009 um 10:59 Uhr
Dein Netzwerk sieht vermutlich so aus, richtig ??

83d3679a3a692e58e19e4c81cea1af58-hpvlan - Klicke auf das Bild, um es zu vergrößern

Als erstes musst du wissen das das VLAN 1 das Default VLAN ist und IMMER untagged bei HP über tagged Links übertragen wird !!! Wenn du es also tagged übertragen willst musst du eine andere VLAN ID wie z.B. 10 und 20 wählen aber es funktioniert auch so... !

Gemäss deiner o.a. Vorgaben und zusätzlich der Ports 9 bis 12 für Endgeräte im VLAN 2 sähe eine Konfig der Switches so aus:
Switch - A
interface 23
name "Trunk Link auf Switch B(Port-1)"
interface 24
name "Trunk Link auf Switch B(Port-2)"

vlan 1
name "DEFAULT_VLAN"
untagged 1-8, 13-24
ip address 172.16.1.254 255.255.255.0
no untagged 23-24
exit
vlan 2
name "Internet"
untagged 9-12
tagged 23-24
exit
spanning-tree protocol-version rstp
Interface eth23-eth24 lacp active

Switch - B
interface 1
name "Trunk Link auf Switch A(Port-23)"
interface 2
name "Trunk Link auf Switch A(Port-24)"
interface 23
name "Trunk Link auf Switch C(Port-23)"
interface 24
name "Trunk Link auf Switch C(Port-24)"

vlan 1
name "DEFAULT_VLAN"
untagged 1-8, 13-24
ip address 172.16.1.253 255.255.255.0
no untagged 23-24
exit
vlan 2
name "Internet"
untagged 9-12
tagged 1-2, 23-24
exit
spanning-tree protocol-version rstp
Interface eth1-eth2 lacp active
Interface eth23-eth24 lacp active

Switch - C
interface 23
name "Trunk Link auf Switch B(Port-23)"
interface 24
name "Trunk Link auf Switch B(Port-24)"

vlan 1
name "DEFAULT_VLAN"
untagged 1-8, 13-22
ip address 172.16.1.252 255.255.255.0
no untagged 23-24
exit
vlan 2
name "Internet"
untagged 9-12
tagged 23-24
exit
spanning-tree protocol-version rstp
Interface eth23-eth24 lacp active

Bedenke das die Trunks VOR dem Zusammenstecken der Switches konfiguriert werden müssen und das du STP einschaltest !
Damit sollte es dann sauber funktionieren !!
Wie gesagt VLAN 2 Endgeräte sind hier im Beispiel die Ports 9 bis 12 zugewiesen. Alles andere ist im Default VLAN 1 !

Weitere Infos zu Trunks steht hier:
http://ftp.hp.com/pub/networking/software/Mgmt-Oct2005-59906023-Chap12. ...
Bitte warten ..
Mitglied: aqui
11.07.2009 um 17:13 Uhr
Wenns das jetzt war dann bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Mitglied: nestasko
12.07.2009 um 13:45 Uhr
Hallo aqui,

Danke für deine Hilfe. Ich bin bereits selber drauf gekommen. HP steckt dynamische Trunks immer ins Default VLAN, deshalb kam ich nicht ins VLAN2.
Also die Lösung des Problems sind statische Trunks, das ist auch das was du oben beschreibst.

Gruß
Bitte warten ..
Mitglied: aqui
16.07.2009 um 13:13 Uhr
Das ist Unsinn, denn wenn du LACP benutzt dann benutzt du IMMER dynmaische Trunks. LACP ist ja das Protokoll was die Trunks dynmaisch aufbaut....
Da hast du wohl was nicht richtig verstanden bei Trunking ?!

Du hast wohl nur schlicht vergessen es einzuschalten !
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
LACP Trunk mit VLANS zwischen HP und Cisco
gelöst Frage von 14116LAN, WAN, Wireless4 Kommentare

Ich habe hier den bestehenden LACP Trunk um ein VLAN 60 und um ein VLAN 80 zu erweitern. Ich ...

Netzwerkprotokolle
Problem bei VLAN Trunk mit LACP zwischen HP und Cisco
gelöst Frage von markuswoNetzwerkprotokolle11 Kommentare

Hallo zusammen, folgende situation: - Ubuntu server 14.04 mit DHCP für verschiedene Ranges - Cisco SG300 L3 Switch welcher ...

Netzwerkmanagement
LACP Trunk über 2 HP V1910 Switches
gelöst Frage von ResalSRNetzwerkmanagement5 Kommentare

Hallo zusammen, wir haben hier 2 x HP V1910-24 PoE Switches und 1 x Windows HP ProLiant Server, auf ...

Netzwerkprotokolle
HP Procurve 2530 - Trunk (LACP)
gelöst Frage von FlatcherNetzwerkprotokolle6 Kommentare

Hallo Admin´s, Ich betreibe 2x HP Procurve 2530 und möchte hier nun mit 4x Cat6 einen Trunk machen. Vlans ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 6 StundenLinux1 Kommentar

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 1 TagTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 1 TagSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 1 TagSicherheit9 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Sicherheit
Meltdown und Spectre: Die machen uns alle was vor
Information von FrankSicherheit23 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Netzwerkgrundlagen
Welches Modem für VDSL 50000 der T-Com
gelöst Frage von Windows10GegnerNetzwerkgrundlagen22 Kommentare

Hallo, ein Kollege von mir will sich VDSL50000 von der T-Com holen, um daran einen Server zu betreiben. Ich ...

Netzwerke
Packet loss bei "InternetLeitungsvollauslastung"
gelöst Frage von Freak-On-SiliconNetzwerke17 Kommentare

Servus; Ja der Titel klingt komisch, is aber so. Wenn die Internetleitung voll ausgelastet ist, hab ich extreme packet ...

Ubuntu
Ubuntu - Starter für nicht vertrauenswürdige Anwendungen
Frage von adm2015Ubuntu17 Kommentare

Hallo zusammen, Ich verwende derzeit die Ubuntu Versionen 17.10 bzw. im Test 18.04. Ich habe mehrere .desktop Dateien in ...