Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

250 GB IDE läßt sich nicht formatieren

Frage Hardware Festplatten, SSD, Raid

Mitglied: Marjorie

Marjorie (Level 1) - Jetzt verbinden

17.08.2008, aktualisiert 22.08.2008, 5756 Aufrufe, 1 Kommentar

Neue Festplatte kann nicht formatiert werden / IDE Treiber wie austauschen?

Hallo!

Ich habe hier zwei Probleme. Es fing damit an, daß ich in meinen 6 Jahre alten PC eine zweite größere Festplatte einbauen wollte. Zum System:

Mainboard Gigabyte GA-8PE667 Pro
80 GB Systemplatte mit Windows XP Professional SP2 am primären IDE Kanal
250 GB Seagate (neu) am sekundären IDE-Kanal
Beide Festplatten als Master, alle weiteren IDE Laufwerke mittlerweile abgezogen.

Die neue Festplatte wurde im BIOS korrekt mit 250 GB erkannt. Unter Windows in der Datenträgerverwaltung aktiviert und eine primäre Partition über die gesamte Festplattengröße eingerichtet. Formatierung läuft bis 100% durch und dann kommt die Meldung "Die Formatierung wurde nicht fehlerfrei durchgeführt".

Nun lese ich in verschiedenen Foren identische Fehlerbilder und folgenden Lösungsvorschlag:
Festplatten größer als 137 GB können nur im 48-Bit LBA Modus angesteuert werden. Windows XP unterstützt diesen seit SP1. Bei meinem BIOS bin ich mir da nicht so sicher. Habe gerade ein Biosupdate gemacht, das letzte verfügbare ist allerdings auch nur von 2002.

Angeboten werden dort im IDE Setup die Modi Normal, Large, LBA und Auto. Habe es jetzt auf LBA eingestellt, aber die Formatierung klappt immer noch nicht. Gibt es irgendwelche weiteren Vorschläge?

Das zweite Problem: Nachdem der Übertragungsmodus immer noch auf PIO stand, obwohl "DMA, wenn verfügbar" eingestellt ist (lag wohl daran, daß vorher ein ZIP-Laufwerk angeschlossen war), habe ich den sekundären IDE-Kanal deinstalliert. Er wurde beim Neustart wieder eingerichtet (das soll angeblich helfen, wenn die Übertragung nicht mehr auf DMA gehen will).

Seitdem wird im Gerätemanager unter IDE/ATA Controller folgendes angezeigt:
- Primärer IDE-Kanal (deutsch!)
- Secondary IDE-Channel (englich!)

Der primäre IDE-Kanal hat den Treiber atapi.sys Ver. 5.1.2600 von Microsoft.
Der secondary IDE-Channel hat den Treiber IdeChnDr.sys Ver. 2.2.0.2126 von Intel. Das ist der selbe Treiber, den auch der IDE/ATA-Controller hat. Nur dieser zeigt unter Eigenschaften keine "Erweiterte Einstellungen" mehr an, so daß ich nicht mal mehr sehen kann, welcher Übertragungsmodus aktiv ist.

Wie kann ich für den secondary IDE-Channel wieder den Microsoft-Treiber zurückholen? Unter "Treiber Aktualisieren" heißt es jedenfalls, "es konnte kein passenderer Treiber als der bereits installierte gefunden werden".
Mitglied: Marjorie
22.08.2008 um 12:04 Uhr
So, das Problem ist inzwischen gelöst. Der Microsoft KB Artikel 303013 nennt 3 Voraussetzungen um den 48-Bit LBA Modus zu aktivieren:
1. Das BIOS muß 48-Bit LBA Modus kompatibel sein
2. Die Festplatte muß größer als 137 GB sein (logisch)
3. Es muß mindestens SP 1 installiert sein.

Ich hatte zwischenzeitlich sogar den erwähnten Registryschlüssel EnableBigLba aktiviert. An all dem hat es aber nicht gelegen. Bekanntlich schert XP sich wenig um das BIOS, sondern greift bei den Laufwerken immer direkt auf die Hardware zu.

Von der Seagate-Supportseite zum 137GB-Problem stammt der Tip, den Intel Application Accelerator zu installieren, falls ein Intel-Chipsatz vorhanden ist. Genau das habe ich gemacht, zufällig hat mein Mainboard einen Intel 845er Chipsatz. Jetzt habe ich auf beiden IDE-Kanälen den englichsprachigen Intel-Treiber, allerdings in seiner neuesten Version (2.3.x), und die Festplatte wurde problemlos formatiert.

Detaillierte Informationen zum Übertragungsmodus an den IDE-Kanälen liefert nun die zugehörige Anwendersoftware "Intel Application Accelerator".
Bitte warten ..
Ähnliche Inhalte
Windows 7
gelöst WIN7 Gesamtdaten von 77 GB auf 155 GB angewachsen (20)

Frage von Clarissa zum Thema Windows 7 ...

Drucker und Scanner
gelöst Officejet 250 WLAN nicht vorhanden (9)

Frage von Kimaro zum Thema Drucker und Scanner ...

Peripheriegeräte
gelöst USB Stick Formatieren fehler (12)

Frage von Yannosch zum Thema Peripheriegeräte ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...

E-Business
Wo tragt ihr eure privaten Termine ein? (13)

Frage von honeybee zum Thema E-Business ...

Netzwerkprotokolle
Leiten "dumme" Switches VLAN-Tags mit durch? (13)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Windows Server
Terminalserver starten willkürlich neu (12)

Frage von thaefliger zum Thema Windows Server ...