Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

2te IP Adresse einer VM zuweisen

Frage Netzwerke

Mitglied: dokazjasni

dokazjasni (Level 1) - Jetzt verbinden

11.05.2013 um 03:13 Uhr, 4244 Aufrufe, 9 Kommentare, 1 Danke

Hallo zusammen,



ich habe bei Strato einen Root Server wo Ubuntu 12.04 läuft. Auf diesem habe ich VMware Workstation 9.0.2 laufen.
Dort in VMware ist ein Debian System installiert.

Was ich die ganze Zeit versuche ist die zweite IP Adresse die mir bei Strato zur Verfügung steht für den virtuellen Debian Server als IP zu verwenden. Leider klappt das irgendwie nicht.. sobald ich die ip adresse manuell dem Debian System zuweise bekommt er keine Internetverbindung nach draußen. Unter VMware ich verwende den bridge adapter.

hier noch ein paar Zusatzinfos.

Root Server (85.214.211.111)
zweite IP (85.214.215.149)

route
Ziel Router Genmask Flags Metric Ref Use Iface
default 85.214.192.1 0.0.0.0 UG 100 0 0 eth0
85.214.192.1 * 255.255.255.255 UH 0 0 0 eth0

vielen dank vorab
Mitglied: EvilMoe
11.05.2013 um 08:03 Uhr
Hallo,

sicher das Bridged überhaupt geht bei Strato? Kenne das von anderen Anbietern das dies in der Regel nicht möglich ist, man kann dort aber z.B. eine Virtuelle Mac erstellen die dann auf deinen Vmware VPS eingestellt werden muss, dann gehts.

Etwas was ohne Bridged gehen sollte: http://www.administrator.de/forum/1und1-debian-minimal-iptables-forward ...
Bitte warten ..
Mitglied: dokazjasni
11.05.2013 um 08:51 Uhr
Hi,

nach so viel herumprobieren denke ich auch mitlerweile das es nicht geht. In VMware kann ich eine MAC generieren, doch als vmnet0 (also Bridged Adapter) wird keine IP zugewiesen. Verstehe dan überhaupt nicht warum strato eine 2te ip vergibt wenn man sie nichmal vernünftig benutzen kann.

Danke sehr für deine Antwort.
Bitte warten ..
Mitglied: dokazjasni
11.05.2013 um 08:55 Uhr
Mit NAT kriege ich es hin, doch funktioniert dan nicht das was ich vorhab. Und zwar möchte ich das ich dort in der VMware einen VPN Server laufen lasse und diesen dan von draußen erreichen kann. Das bedeutet nicht nur mit einem Benutzernamen sonder mit mehreren Benutzern gleichzeitig. Leider klappt nur eine VPN Verbindung mit iptables (also mit NAT) sobald ich mich vom anderen Gerät verbinde, wird die erste gekappt und die zweite aufgebaut..

Finde nach wie vor keineLösung..
Bitte warten ..
Mitglied: LordGurke
11.05.2013 um 11:26 Uhr
Der Grund dass es nicht geht ist ein ganz einfacher:

Strato filtert an seinen Switch-Ports auf bekannte MAC-Adressen. Deine VM hat aber natürlich eine andere MAC als dein Server und wird damit gefiltert.
Vermutlich wird Strato die IP auch nicht einfach auf deinem Switchport "rausfallen" lassen, sondern dir auf deine Haupt-IP-Adresse routen. Also musst du dein Host-System diese IP-Adresse weiterrouten lassen.

OK, viel Verwirrung, ich drösel das mal auf:
Stelle den Netzwerkadapter deiner VM auf den Bridged-Mode und gib deiner VM ganz normal die IP, die sie haben soll.
Als Gateway stellst du allerdings die IP-Adresse deines Host-Systems ein.
Auf dem Host-System musst du jetzt eine statische Route anlegen:
01.
ip -4 route add 85.214.215.149 dev DEVICEDEINERVM
"DEVICEDEINERVM" musst du durch den Interfacenamen auf deinem Host-System ersetzen - z.B. "vmnet0".
Zusätzlich musst auf dem Host das IP-Forwarding aktiviert werden - wie das geht kann man sich schneller zusammengooglen als ich es hier niederschreibe.

Damit sollte es dann eigentlich funktionieren...
Bitte warten ..
Mitglied: dokazjasni
11.05.2013 um 12:03 Uhr
Hallo maxi89,

also erstmal vielen Dank für deine schnelle Antwort. Das gibt mir wieder Hoffnung das es doch klappen könnte.
Das Problem was ich jetzt habe ist das er mir sagt das vmnet0 nicht gefunden werden kann. Unter ifconfig steht es auch nicht, die anderen beiden vmnet2 und vmnet8 sind aber da.

ip -4 route add 85.214.213.149 dev vmnet0
Cannot find device "vmnet0"
Und habe ich das richtig verstanden, ich trage die 2te ip adresse die ich bei strato zusätzlich habe als IP Adresse der Virutellen Maschine oder was meintest du mit die "IP die sie haben soll..."

Was trage ich denn als Router ein? Und muss die weite ip adresse unter ifconfig als eth0:1 aufgelistet werden?

Sorry für so viele Fragen..

Dennoch vielen vielen Dank für jede Hilfe..
Bitte warten ..
Mitglied: LordGurke
11.05.2013, aktualisiert um 12:13 Uhr
Zitat von dokazjasni:
Das Problem was ich jetzt habe ist das er mir sagt das vmnet0 nicht gefunden werden kann. Unter ifconfig steht es auch nicht, die
anderen beiden vmnet2 und vmnet8 sind aber da.

Ich meinte vmnet0 beispielhaft - wenn deine VM das Device vmnet2 hat (z.B.) musst du natürlich die IP darauf routen

Zitat von dokazjasni:
Und habe ich das richtig verstanden, ich trage die 2te ip adresse die ich bei strato zusätzlich habe als IP Adresse der
Virutellen Maschine oder was meintest du mit die "IP die sie haben soll..."

Genau, der gibst du deine 2. IP - halt die, unter der du deine VM später aus dem Internet erreichen willst.

Zitat von dokazjasni:
Was trage ich denn als Router ein? Und muss die weite ip adresse unter ifconfig als eth0:1 aufgelistet werden?

Als Router trägst du dort irgendeine IP ein, die dein Host hast - z.B. die 85.214.211.111.
Dem Host selbst darfst du die 85.214.215.149 auf garkeinen Fall selbst zuweisen, denn sonst hättest du ja zwei Mal die selbe IP im Netzwerk
Bitte warten ..
Mitglied: dokazjasni
11.05.2013 um 12:23 Uhr
Zitat von LordGurke:
Ich meinte vmnet0 beispielhaft - wenn deine VM das Device vmnet2 hat (z.B.) musst du natürlich die IP darauf routen

sorry nicht vmnet2, vmnet1 und vmnet8 sind da. vmnet1 ist als Host only und vmnet8 dient als NAT..
vmnet0 was unter Network Editor angezeigt wird und auch als Bridge Adapter angezeigt wird, erscheint leider auf dem Host nicht. Hab gerade das hier gelesen

VMnet0 never displays as a Virtual Network Adapter like NAT (VMnet8) or Host-only (VMnet1) Network Adapters because it's not a Network Adapter, it's a Protocol and will appear in the Host's Physical Network Adapter's Properties as VMware Bridge Protocol.



Als Router trägst du dort irgendeine IP ein, die dein Host hast - z.B. die 85.214.211.111.
Dem Host selbst darfst du die 85.214.215.149 auf garkeinen Fall selbst zuweisen, denn sonst hättest du ja zwei Mal die selbe
IP im Netzwerk

die 85.214.211.111 ist ja meine Root ip adresse. Unter route ist ja das Gateway 85.214.192.1 eingetragen. Kann ich dieses einfach nehmen?
Bitte warten ..
Mitglied: LordGurke
11.05.2013 um 12:29 Uhr
Zitat von dokazjasni:
sorry nicht vmnet2, vmnet1 und vmnet8 sind da. vmnet1 ist als Host only und vmnet8 dient als NAT..
vmnet0 was unter Network Editor angezeigt wird und auch als Bridge Adapter angezeigt wird, erscheint leider auf dem Host nicht.

Gibt es bei VMWare noch den Host-Only-Adapter? Der erfüllt seinen Zweck in diesem Fall genauso.
Allerdings ist es beim Host-Only-Adapter meines Wissens so, dass man dem eine IP zuweisen muss. In diesem Fall kannst du dem Ding einfach irgendeine private IP zuweisen (z.B. 10.2.3.4) und in der VM diese dann als Router eintragen. Klingt doof, funktioniert aber.


Zitat von dokazjasni:
die 85.214.211.111 ist ja meine Root ip adresse. Unter route ist ja das Gateway 85.214.192.1 eingetragen. Kann ich dieses einfach
nehmen?

Wenn du den Router von Strato einträgst würdest du dort wieder mit der falschen MAC-Adresse aufschlagen - resp. eben garnicht, weil die Pakete bereits am Switch gefiltert werden.
Trägst du deinen eigenen Server als Router ein leitet er die Pakete an das ihm bekannte Gateway (das von Strato) weiter, aber mit seiner eigenen freigeschalteten MAC-Adresse.
Bitte warten ..
Mitglied: dokazjasni
11.05.2013 um 12:48 Uhr
Zitat von LordGurke:
Gibt es bei VMWare noch den Host-Only-Adapter? Der erfüllt seinen Zweck in diesem Fall genauso.
Allerdings ist es beim Host-Only-Adapter meines Wissens so, dass man dem eine IP zuweisen muss. In diesem Fall kannst du dem Ding
einfach irgendeine private IP zuweisen (z.B. 10.2.3.4) und in der VM diese dann als Router eintragen. Klingt doof, funktioniert
aber.
Ja den gibt es. Hab jetzt unter
ip route show
default via 85.214.192.1 dev eth0 metric 100
85.214.192.1 dev eth0 scope link
85.214.211.111 dev vmnet1 scope link
192.168.12.0/24 dev vmnet1 proto kernel scope link src 192.168.12.1
192.168.13.0/24 dev vmnet8 proto kernel scope link src 192.168.13.1

folgendes stehen.

Die VMaschine hat jetzt die 192.168.12.128, Subnetzt 255.255.255.0 und beim Router habe ich 192.168.12.2 eingetragen.
Muss ich auch den gleichen DNS Server meines Hosts nehmen?
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
KVM
gelöst KVM- VM eigene IP Adresse (8)

Frage von denndsd zum Thema KVM ...

LAN, WAN, Wireless
gelöst TP-Link WA501G als Client einrichten - Keine IP Adresse wir bezogen (14)

Frage von bestelitt zum Thema LAN, WAN, Wireless ...

E-Mail
gelöst Falsche SMTP Server IP Adresse (6)

Frage von laster zum Thema E-Mail ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...