Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

3Com Switch 4500 mit 2 Vlans und einem DHCP Server 2008

Frage Netzwerke LAN, WAN, Wireless

Mitglied: eac1903

eac1903 (Level 1) - Jetzt verbinden

20.09.2009, aktualisiert 18.10.2012, 8605 Aufrufe, 19 Kommentare

Hallo,

Ich versuche mir die Konfiguration von Vlans selber beizubringen um Sie dann in der Praxis einzusetzten. Jetzt komme ich leider nicht mehr weiter.
Ich habe auf einem 3Com Switch 4500 3Vlans, dass default Vlan1, Vlan 100, und Vlan 200.
Das default Vlan 1 liegt auf Port 1 und dort ist der Server 2008 mit der Rolle DHCP angeschlossen. Das Vlan100 liegt auf den Ports 2 -12 und das Vlan200 liegt auf den Ports 13 - 24.
Auf dem Server habe ich zwei DHCP Bereiche angelegt Vlan100 und Vlan200.
Wie kann ich es erreichen, dass das Vlan100 vom DHCP Server die IP des Bereiches Vlan100 bekommt und das Vlan 200 die IP des Bereiches Vlan200 bekommt?
Muss ich den Port des default Vlans1 irgendwie taggen, damit alle anderen Vlans auf den Server zugreifen können.
Ach ja der Server hat keine NIC wo ich Vlans eintragen kann.

Danke für hilfe
eac1903
Mitglied: dog
20.09.2009 um 21:12 Uhr
Ach ja der Server hat keine NIC wo ich Vlans eintragen kann.

Tja dann....vergiss es, klappt nicht

Grüße

Max
Bitte warten ..
Mitglied: eac1903
21.09.2009 um 07:30 Uhr
Hi,

Das ist ja mist . Da muss ich mir wohl mal eine Kaufen.
Wie währe die Konfiguration wenn ich ein Vlanfähige NIC habe?

eac1903
Bitte warten ..
Mitglied: Xaero1982
21.09.2009 um 08:54 Uhr
Du musst der NIc dann die VLans zuweisen .... und den Port 1 taggen für alle Vlans

lg
Bitte warten ..
Mitglied: Lousek
21.09.2009 um 09:06 Uhr
Hallo eac1903

Wenn ich dich richtig verstanden habe, willst du den DHCP-Server für beide VLANs nutzen.
Was hast du denn für ein Server?

Wenn du VLAN verwendest, werden den Paketen ein paar bytes mit der VLAN-ID angehängt (getagged)... dadurch weiss auch z.B. ein anderer Switch, in welches VLAN das Paket gehört.
Bei den CISCO-Geräten gibt es zwei Möglichkeiten, wie du einen Port konfigurieren kannst, bei anderen, z.B. HP heisst es anderst:
AccessMode:
Das VLAN beginnt erst ab dem Switchport ... der Switch tagged eingehende Pakete für ein bestimmtes VLAN (fügt die ID an) und untagged ausgehende Pakete.
Für das angeschlossene Netzwerkgerät ist dies eine ganz normale Verbindung, da die ganze Arbeit der Switch macht.
Pakete, die bereits getagged an dem Port ankommen, werden nicht durchgelassen.
Trunk:
Das VLAN beginnt schon "vor" dem Switchport, d.h. die Pakete sind bereits getagged und werden nicht mehr vom Switch selbst getagged / untagged. Pakete, die nicht getagged sind bekommen die VLAN-ID1.
Mit diesem Trunk ist es möglich, mehrere VLANs über eine Verbindung laufen zu lassen, da die Pakete bereits getagged sind ... z.B. soll über eine Verbindung zweier Switches das VLAN100 UND das VLAN200 --> Trunk
D.h. aber, dass das angeschlossene Netzwerkgerät die Pakete auf die richtige Art und Weise mit den VLAN-Tags versehen muss.

Wenn du eine VLAN-fähige Netzwerkkarte hast, benötigst du einen Trunk, damit beide VLANs über eine Verbindung kommen ...
Wenn du keine VLAN-fähige Netzwerkkarte hast, kannst du auch (sofern du eine zweite NIC hast) zwei Verbindungen mit dem Switch herstellen, wobei die Ports auf AccessMode eingestellt sind ... einmal für das VLAN100 und einmal fürs VLAN200.

Vieleicht hilft dir das ein wenig ;)

Greetz, Lousek
Bitte warten ..
Mitglied: aqui
21.09.2009, aktualisiert 18.10.2012
VORSICHT hier mit der Bezeichnung "Trunk" !

Leider wird auch sehr häufig mit dem Begriff Trunk eine Link Aggregation also das Parallelschalten mehrere Links zur Bandbreitenerhöhung, bezeichnet.

Die o.a. Erklärung von lousek die für einen sog. tagged Link richtig ist, ist nicht unbedingt immer ein Trunk.
Hier ist überigens ein Fehler in der Erklärung: Es ist Unsinn das untagged Pakete die VLAN ID 1 bekommen. Untagged Pakete bleiben untagged auf einem Trunk. Laut IEEE 802.1q Standard wird das default VLAN (meist 1) immer parallele untagged übertragen auf einem tagged Trunk. So gut wie alle Hersteller halten sich auch daran !
Leider ist der Gebrauch diese Begriffes Trunk hier sehr uneinheitlich und man muss schon mal genauer nachfragen was gemeint ist....

Erklärung zu tagged Links findest du hier:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
http://www.administrator.de/wissen/vlan-routing-%c3%bcber-802.1q-trunk- ...

Was ein Trunk (hier mit Link Aggregation) ist, sagen dir diese Threads:
http://www.administrator.de/forum/motherboard-mit-2-onboard-lan-anschl% ...
http://www.administrator.de/forum/traffic-am-server-auf-2-nics-verteile ...
http://www.administrator.de/forum/kann-man-einen-server-zur-performaces ...
http://www.administrator.de/forum/bonding-mit-broadcom-slb-117829.html
http://www.administrator.de/forum/link-aggregation-frage-zur-hash-confi ...
Bitte warten ..
Mitglied: Lousek
21.09.2009 um 11:04 Uhr
Ok, man lernt ja nie aus ... schliesslich bin ich auch erst in der Ausbildung ;)

Bei den CISCO-Geräten gibt es zwei Möglichkeiten, wie du einen Port konfigurieren kannst, bei anderen, z.B. HP heisst es anderst:
AccessMode:

... ich habe mich auf CISCO-Geräte bezogen
Bei HP-Geräten ist ein Trunk dasselbe wie bei CISCO ein Ether-Channel, also eine Link Aggregation ... wenn ich mich nicht irre.

Greetz,
Lousek
Bitte warten ..
Mitglied: runcmd
21.09.2009 um 16:43 Uhr
hi,

diese konfig läuft hier:

- 3com 4900
- 2 vlans definiert
- die entsprechenden ports getagged (portbased konfig)
- 2 dhcp separate scopes definiert (kein superscope!, das funktionierte nicht)
- udp helper gesetzt
- kein separates vlan für den dhcp server

der "trigger" für den dhcp server, welcher addresspool nun zu verwenden ist, kommt vom definierten gateway der vlans, genau kann ich das aber nicht sagen. der server hat keine vlan-fähige karte, warum auch... funktioniert einwandfrei.

beim 4500 kann es sein, dass das so nicht funktioniert. ein kollege meinte, die layer 3 unterstützung, bzw. der udp helper sind nur rudimentär...

grüße
Bitte warten ..
Mitglied: eac1903
21.09.2009, aktualisiert 18.10.2012
Das sind ja ganz schön viel Informationen auf einem haufen.

Also wenn ich das richtig verstanden habe, muss ich auf dem Switch den Port 1mit dem Vlan1,Vlan100 und Vlan200 taggen und auf der Server NIC die Vlans 1, 100 und 200 taggen. Die DHCP-Scopes auf dem Server müssen genau so heißen wie die VLan ID's oder? Wie in diesem Link beschrieben "http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ..." wird auf dem Server Aktiviertes Routing vorausgesetzt. Brauche ich das wenn ich eine VLAN-Tagging fähige NIC habe?

Wie ist das eigentlich wenn ich auch noch einen Router im Vlan 1 betreibe muss der auch Vlanfähig sein oder nicht??


Gruß
eac1903
Bitte warten ..
Mitglied: aqui
21.09.2009, aktualisiert 18.10.2012
Um diese Frage beantworten zu können, musst du erstmal posten ob dein 3Com 4500er ein Layer 3 Switch ist, also ob er routen kann zwischen den VLANs oder nicht, also ob er nur im Layer 2 Modus arbeitet !!
Erst dann macht es Sinn weiter zu machen...
Nur soviel:

Hast du die Layer 3 Option, reicht es wie runcmd beschrieben hat eine sog. "ip helper adresse" am IP VLAN Interface des Switches zu konfigurieren. Der Server wird dann ganz normal an einen untagged Port angeschlossen und der DHCP dort bedient alle Subnetze in den VLANs, da der Switch entsprechende DHCP Requests aus den einzelnen VLANs zentral an den DHCP Server forwardet !

Hast du keine L3 Option auf dem Switch, dann muss der Server zwangsläufig ein Bein in jedem Netzwerk haben und dann benötigst du einen tagged Port im Server. (Oder eben Einzelstrippen mit soviel NICs wie du VLANs hast was aber eine weniger sinnvolle HW Konfig ist, logischerweise !)
Alle Details dazu wie man es macht kannst du hier nachlesen:
http://www.administrator.de/wissen/vlan-routing-%c3%bcber-802.1q-trunk- ...
Bitte warten ..
Mitglied: eac1903
22.09.2009 um 07:35 Uhr
Hallo aqui,

Der 4500er ist ein Layer 3 Switch. Dann probiere ich das mal mit dem sog. "ip helper adresse".

Gruß

eac1903
Bitte warten ..
Mitglied: eac1903
23.09.2009 um 16:23 Uhr
Hi runcmd,

ich habe auf meinem 4500 Switch jetzt 2 vlans erstellt, ein vlan200 mit dem Port 1/0/2 und ein vlan201 mit dem port 1/0/3. Auf dem Port 1/0/1habe ich das default vlan1 leigen. Dann habe ich auf dem interface vlan-interface 1 den udp-helper auf die IP des Servers gelegt und den udp-helper aktiviert. Den port 1/0/1 habe ich mit den Vlans 1, 200 und 201 getaggt. Es funktioniert leider nicht, ich komme nicht auf den Server.

Muss ich den Port 1/0/1 auf trunk setzten?
Gruß
eac1903
Bitte warten ..
Mitglied: aqui
26.09.2009, aktualisiert 18.10.2012
Nein, Trunk ist eine Link Aggregation und hat damit erstmal rein gar nichts zu tun ! Siehe Erklärung zu dem Thema oben !!
Das tagging musst du vom Port 1/0/1 zwingend entfernen !! Dieser Port liegt untagged einzig NUR im VLAN 1 deinem Server VLAN ! Also auch das Tagging auf diesem Port für die VLANs 200 und 201 zwingend entfernen !!

Du solltest erstmal die korrekte Layer 3 (Routing) Funktion deines Switches über die VLANs mit statischen IP Adressen verifizieren BEVOR du auf DHCP gehst !!
Leider ist deine Beschreibung des Anschusses der Komponenten am Switch recht oberflächlich so das man gezwungen ist zu raten...
Raten wir mal die folgende Anschlussituation bei dir:
  • Switch Port 1/0/1 untagged nur in VLAN 1 hier kommt der Server dran mit seiner Netzwerkkarte !
Beispiel Portzuweisung VLANs nach deiner o.a. Beschreibung:
Port 1/0/1 = untagged Server
Port 1/0/2 bis 12 = untagged in VLAN 100
Port 1/0/13 bis 24 = untagged in VLAN 200

Beispiel IP Adressierung VLANs:
IP Netzwerk VLAN 1: 172.16.1.0, Maske: 255.255.255.0, Switch VLAN IP: 172.16.1.254
IP Netzwerk VLAN 100: 172.16.100.0, Maske: 255.255.255.0, Switch VLAN IP: 172.16.100.254
IP Netzwerk VLAN 200: 172.16.200.0, Maske: 255.255.255.0, Switch VLAN IP: 172.16.200.254

Server IP:
172.16.1.1, Maske: 255.255.255.0, Gateway: 172.16.1.254 (Switch IP in VLAN1)
Client VLAN 100 an Port 1/0/10:
172.16.100.1, Maske: 255.255.255.0, Gateway: 172.16.100.254 (Switch IP in VLAN100)
Client VLAN 200 an Port 1/0/20:
172.16.200.1, Maske: 255.255.255.0, Gateway: 172.16.200.254 (Switch IP in VLAN200)


So, das sind deine Grundvoraussetzungen für einen Funktionstest !! Das musst du erstmal genau so umsetzen bevor du weitermachst !!
Ist dem so, sollte folgendes dann problemlos klappen:
  • Ping Server auf Switch VLAN IP Adressen 172.16.1.254, 172.16.100.254 und 172.16.200.254 sollte problemlos klappen !
  • Ping Client in VLAN 100 auf Server IP 172.16.1 sollte problemlos klappen !
  • Ping Client in VLAN 200 auf Server IP 172.16.1 sollte problemlos klappen !

Wenn das alles geklappt hat funktioniert deine VLAN Einrichtung, dene VLAN Adressierung und auch dein IP Routing zwischen den 3 VLANs sauber !
Nun kannst du dadran gehen die Clients in den VLANs 100 und 200 mit DHCP IP Adressen in ihrem Segment vom Server zu versorgen !
Dafür gehst du folgendermaßen vor:
  • Auf dem Server einen zusätzlichen Scope (IP Netz/Bereich) für das 172.16.100.0er Netzwerk mit einer 24 Bit Maske erstellen (255.255.255.0). Per DHCP zu vergebendes gateway in diesem Bereich eintragen 172.16.100.254 (Switch IP Adresse in diesem VLAN !), DNS Server etc.
  • Auf dem Server einen zusätzlichen Scope (IP Netz/Bereich) für das 172.16.200.0er Netzwerk mit einer 24 Bit Maske erstellen (255.255.255.0). Per DHCP zu vergebendes Gateway in diesem Bereich eintragen 172.16.200.254 (Switch IP Adresse in diesem VLAN !), DNS Server etc.
  • Achtung: KEIN Supersope !! Es müssen 2 separate DHCP Scopes (Bereiche) sein wie unten auch im Kommentar von runcmd angemerkt !
  • Auf dem Switch IP Interface des VLAN 100 das Kommando ip helper-address 172.16.1.1 eingeben. (Helper Adress im VLAN 100 auf die Server IP eintragen !!)
  • Auf dem Switch IP Interface des VLAN 200 das Kommando ip helper-address 172.16.1.1 eingeben. (Helper Adress im VLAN 200 auf die Server IP eintragen !!)
  • Client im VLAN 100 auf "IP Adresse automatisch beziehen" einstellen (DNS ebenso!) und ein ipconfig -renew ausführen !
  • Client im VLAN 200 auf "IP Adresse automatisch beziehen" einstellen (DNS ebenso!) und ein ipconfig -renew ausführen !

Nun sollten beide Clients vom Server sauber ihre IP Adressen in den VLANs bekommen und alles sollte dann endlich so klappen wie du es geplant hast !!

Beispiele für solche VLANs findest du auch in diesen Threads: (Letzteres auch mit deinem Switchmodell)
http://www.administrator.de/VLAN_einrichten_-_Mehrere_Betriebe_und_Rout ...
http://www.administrator.de/forum/6-vlans-mit-3com-4200g-switche-verst% ...
Bitte warten ..
Mitglied: runcmd
27.09.2009 um 20:06 Uhr
hi aqui,

was soll man dazu noch hinzufügen? tolle antwort.

nur noch der hinweis aufs superscope, damit hat´s hier nicht funktioniert, nur zwei echte separate scopes am DHCP-server konnten die anfragen aus den vlans beantworten.

und ja, zu oft sind die anfragen so kurz gehalten, dass man nur raten kann, welche situation vorliegt, anworten darauf sind eigentlich reine quizshow.
Bitte warten ..
Mitglied: eac1903
28.09.2009 um 17:32 Uhr
Hi aqui,

Danke. Werde es gleich mal ausprobieren ob es klappt. Ich denke bei dieser ausführlichen Beschreibung wird es jetzt was. Ein Frage habe ich noch. die Server IP (die Zeilen in Rot), die muss ich in der Vlan fähigen Netzwerkkarte des Servers eintragen? Oder brauceh ich da 3 Netzwerkkarten?

Gruß
eac1903
Bitte warten ..
Mitglied: aqui
28.09.2009 um 17:47 Uhr
@eac1903
Nein, die Netzwerkkarte des Servers muss nicht VLAN fähig sein ! Das ist ja bei einem layer 3 Switch wie du ihn hast nicht mehr nötig, denn der routet dann ja, was auch sehr sinnvoll ist so !
Antwort: Nein, VLANs auf der Server NIC deaktivieren und den Server ganz normal mit einer IP in das Server VLAN stecken

@runcmd
So war das auch gemeint aber vermutlich falsch ausgedrückt. Dank dir für die Klarstellung und das Feedback ! (Habs im Text korrigiert !)
Bitte warten ..
Mitglied: aqui
06.10.2009 um 13:04 Uhr
@eac1903
War es das denn jetzt ?? Dann bitte auch
http://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Mitglied: eac1903
15.10.2009 um 17:10 Uhr
Hi,

Leider funktioniert das mit dem DHCP in den Vlans nicht.
habe im interface vlan-interface 100 und 200 den UDp-helper auf den Server gesetzt. aber klappt nicht mit zuweisung von Adressen. Woran kann das liegen??

eac903
Bitte warten ..
Mitglied: Xaero1982
15.10.2009 um 17:25 Uhr
OT: Ich will nur keine Messages mehr bekommen!
LG
Bitte warten ..
Mitglied: eac1903
27.10.2009 um 17:18 Uhr
Hat alles jetzt einwandrei funktioniert. So wie aqui beschrieben hat.
Danke für die Hilfe.

Gruß
eac1903
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Netzwerk
Windows Server 2008 R2 mit 2 DHCP, 1 MAC-Filter (11)

Frage von Nathenn zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...