Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

3Com Switch 4800 - Startprobleme im Netzwerk

Frage Hardware Switche und Hubs

Mitglied: Klingel

Klingel (Level 1) - Jetzt verbinden

20.07.2010 um 10:05 Uhr, 5627 Aufrufe, 11 Kommentare

Hallo alle zusammen,


mal wieder muss ich mich mit einem Problem an euch wenden.
Ich hab 2 3Com Switch 4800G vor mir liegen. Diese wollte ich nun zum testen einmal in einer einfachen Startkonfiguration in Betrieb nehmen.

Starten, Benutzer anpassen, WebServer starten, VLAN einrichten, war alles kein Problem. Auch wenn ich sagen muss, das ich Cisco oder HP lieber mag.
Im Netzwerk bei mir im Büro (2 Rechner und der Switch) gibt es keine Probleme. Wenn ich den Switch nun aber mit unserem Netzwerk koppel, Deaktivert der HP Switch an den ich ihn anstecken will sofort den Port und spuckt im Protokoll eine STP Fehler aus.

Duplex Fehler hab ich auch schon versucht auzuschließen. Hat aber keinen Unterschied gebracht.
Im Moment verzweifel ich auch etwas, da mein Verstand die Logik nicht ganz versteht, wieso es in einem eigenen kleinen Netz geht, aber nicht mit einem zweiten Switch.

Hab ich da irgendwas vergessen, zu aktivieren?

Würde mich über Hilfe freuen. Es reichen auch ein paar Stichwörter nur.

Vielen Dank

lg
Mitglied: dog
20.07.2010 um 10:22 Uhr
im Protokoll eine STP Fehler aus.

Sehr präzise.

Aber wahrscheinlich solltest du auf dem 3com einfach mal STP deaktivieren oder auf die selbe Variante wie am HP einstellen...
Bitte warten ..
Mitglied: aqui
20.07.2010 um 10:26 Uhr
Billigheimer HP kann kein Per VLAN Spanning Tree sondern nur einen Global Spanntree. Damit ist HP nicht koppelbar mit Cisco die so oder so ihr eigenes STP (PVSTP+) Verfahren haben und auch 3Com die auch PVST supporten.
D.h. die beiden STP Verfahren PVSTP und Global sind inkompatibel und dann kommt es zu solchem Verhalten.
Ferner hat HP das default VLAN (1) immer untagged parallel auf einem getaggten Port. 3Com hat das nicht (jedenfalls bei früheren Geräten). HP nutzt aber das default VLAN für seinen Global Spanntree. Wäre also ein 2ter möglicher Grund.
In jedem Falle musst du hier tagged Uplinks im Paralellmodus betreiben und auch den STP Prozess auf Global umstellen um mit HP kompatibel zu sein !
Alternative sofern du keine Layer 2 Redundanz hast zw. den Switches und wie dog es oben schon vorgeschlagen hat: Ganz einfach Spanning Tree komplett ausschalten. Das löst dein Problem im Handumdrehen, birgt aber die sehr hohe Gefahr eines möglichen Loops im Netz !
Für den Produktivbetrieb mit gemischten Herstellerumgebungen solltest du also immer besser den STP Prozess anpassen auf das kleinste gemeinsame Vielfache !
Dumm nur das wenn man HP im Netz hat in die STP "Steinzeit" mit Neandertalmodus zurückfallen muss Das ist aber nun mal so bei Billigheimern die nicht alle Features supporten...
Ein einfacher Sniffer Trace mit dem Wireshark an diesem Port auf die STP BPDU Pakete zeigt dir das Verhalten sofort auf. Hast du vermutlich noch nicht gemacht, oder ??
Bitte warten ..
Mitglied: dog
20.07.2010 um 11:21 Uhr
Billigheimer HP kann kein Per VLAN Spanning Tree sondern nur einen Global Spanntree.

Bei HP kann so ziemlich alles außer die 1700er/1800er MSTP.
Bitte warten ..
Mitglied: aqui
20.07.2010 um 17:23 Uhr
MSTP ist aber kein wirkliches PVSTP bzw. PVSTP+. Mal abgesehen davon das HP gar kein PVSTP+ von Cisco supportet. Wenn man es genau betrachtet ist es wieder ein globaler STP Prozess mit mehreren Instanzen die dann auf Gruppen von VLANs per Policy übertragen werden.
Also eher ein quasi PVST aber kein wirklicher, denn bei "richtigem" PVST rennt ein separater STP Prozess autark pro VLAN. Muss ja auch einen Grund haben warum die HPs so billig sind
Sgelet bei MSTP die Instanz ab segelen alle VLANs diese Instanz mit ab.... OK, immer noch besser als ein rein singulärer Global STP wie sonst Default bei HP ! Aber auch ein Grund warum sich MSTP nicht so wirklich durchgesetzt hat...
Bitte warten ..
Mitglied: Klingel
23.07.2010 um 15:47 Uhr
Zitat von dog:
> im Protokoll eine STP Fehler aus.

Sehr präzise.

Aber wahrscheinlich solltest du auf dem 3com einfach mal STP deaktivieren oder auf die selbe Variante wie am HP einstellen...

Leider stand im Protokoll auch nicht mehr.

Vielen Dank euch beiden. Das hat jetzt geklappt, lag an den unterschiedlichen STP Protokollen.
Bitte warten ..
Mitglied: MichaZ
26.01.2015 um 17:40 Uhr
Hallo zusammen!

Ist zwar schon ein etwas älterer Beitrag aber ich stehe aktuell vor einem
vergleichbaren Thema. Eine Sammlung an Geräten aus den 3Com und
HP Lager unterschiedlichen Typs die als Netzwerk zusammen arbeiten.
Da es sich um eine Produktivumgebung handelt ist es nicht immer möglich
nach "Versuch macht klug" zu arbeiten. Nun geht es darum VLANs zu
erstellen und ich lese schon seit Tage über die Vorgehensweisen.
Nun bin ich hier auf diesen Beitrag gestoßen und hätte da gleich eine Frage
dazu. Wie behandelt man die die Zusammenschaltung hinsichtlich VLAN1.
Stellt man das dann bei HP auch auf tagged damit es der 3Com Switch
annehmen kann? Die Tatsache mit dem STP musste ich schon "schmerzlich"
erfahren. Da es Geräte aus verschiedenen Epochen sind wird es sicher nicht
einfach flächendeckend VLAN zu verbreiten.

Viele Grüße
Micha
Bitte warten ..
Mitglied: aqui
26.01.2015, aktualisiert um 18:07 Uhr
Wie behandelt man die die Zusammenschaltung hinsichtlich VLAN1.
Der 802.1q Standard lässt beides zu. In der Regel haben aber alle Hersteller das VLAN 1 immer untagged auf einen Trunk bzw. tagged Uplink Port.
So macht es auch Billigheimer HP, Cisco und andere Hersteller wie auch ex 3Com.
Deine Aussage...
Stellt man das dann bei HP auch auf tagged damit es der 3Com Switch annehmen kann?
Ist also technischer Unsinn, denn das VLAN 1 kann man als Default VLAN gar nicht taggen auf diesen Plattformen ! In so fern ist diese Frage also vollkommen obsolet.
Bei beiden Herstellern wird auf tagged Uplinks das Default VLAN immer parallel untagged übertragen !
Die Tatsache mit dem STP musste ich schon "schmerzlich" erfahren.
Das geht leider allen so die ProCurve Schrott von HP kaufen !
Die, die es wenigstens verstehen kommen mit üblen Workarounds wenigstens etwas drumrum. Die die es nicht verstehen verzweifeln häufig.
Da es Geräte aus verschiedenen Epochen sind wird es sicher nicht einfach flächendeckend VLAN zu verbreiten.
Doch, das klappt wunderbar wenn man weiss was man macht und sich auf das kleinste, gemeinsame Vielfache einigt was diese Switches supporten.
Bei Spanning Tree ist das ein Global Span Verfahren zu verwenden, was eigentlich jeder x-beliebige Switch der STP kann supportet. Swicthes die besseres PVSTP oder PVRSTP oder auch die Cisco Variante PVRSTP+ supporten lassen sich immer auf ein Global Span Verfahren zwingen über das Setup und sprechen dann auch eine (STP) Sprache zusammen mit den antiken Brüdern.
Nicht schön, weil man so in die Steinzeit des Spanning Tree zurück muss (bei HP ist es bis heute so) aber immer noch besser als nix.
Wenn die Switches im Global Span Verfahren dann auch noch RSTP supporten umso besser.
Muss aber auch nicht zwingend sein, denn altes Standard Global STP und RSTP sind rückwärts kompatibel, passen sich also an.
Fazit: Auch mit alten HP und 3Com Gurken bekommt man sowas sauber und problemlos hin.
Man muss eben nur wissen was man macht
Bitte warten ..
Mitglied: MichaZ
26.01.2015 um 18:22 Uhr
Hallo aqui,

vielen Dank für die nüchternen aber der Tatsache entsprechenden Worte.
Also muss ich erst mal schauen das alle Geräte auf einem einfachen globalen
STP laufen?! Hatte bei einem ersten Versuch ein VLAN zu schalten gleich
den Effekt das die Anbindung via Linkaggregation zwischen zwei Geräten
weg war. Also speziell das VLAN1 was derzeit nur genutzt wird. Alle existierenden
Verbindungen laufen derzeit im LAG ohne LACP und kaum STP.
Bitte warten ..
Mitglied: aqui
26.01.2015, aktualisiert um 18:55 Uhr
vielen Dank für die nüchternen aber der Tatsache entsprechenden Worte.
Zahlen, Daten, Fakten !
Also muss ich erst mal schauen das alle Geräte auf einem einfachen globalen STP laufen?!
Ja, richtig !
Meist tun sie das weil HP und 3Com schlicht und einfach gar nichts anderes können. Sind halt sehr beschränkt die Teile..
Du kannst also davon ausgehen das das zu 98% schon der Fall ist wenn du STP oder RSTP aktiviert hast.
Wichtig ist das du kein MSTP im Mischbetrieb hast...das geht wieder nicht, da nicht kompatibel !
Hatte bei einem ersten Versuch ein VLAN zu schalten gleich den Effekt das die Anbindung via Linkaggregation zwischen zwei Geräten weg war.
Das kann natürlich passieren wenn STP aktiviert ist und dieser Link auf dem Switch mit der niedrigsten Bridge Priority liegt, der dann prompt in den Blocking Mode geht !
Dazu müsste man aber jetzt dein Netzwerk Design mal sehen und sehen wo du die beiden Root und Backup Root Bridges im STP definiert hast um so die Bridge Hierarchie zu checken.

In der Regel sind das immer die beiden Core Switches die man immer mit einer niedrigeren Bridge Priority modulo 4096 ausstattet.
Niemals darf man dies dem Automatismus überlassen, denn der wählt den Switch mit der niedrigsten Mac Adresse und das kann der billige NetGear beim Kollegen Piepenbrink auf dem Schreibtisch sein, was sehr fatal und tödlich wäre für das STP Redundanz Verhalten und dann sowas wie mit deinem LAG passiert !!

Also z.B. sollte die Root Bridge mit STP Prio 4096 und die Backup Root mit 8192 konfiguriert sein.
Bei Linkaggregation solltest du zwingend darauf achten das du zwischen unterschiedlichen Herstellern immer LACP basierte LAGs konfigurierst ! Besser keine statischen Links nehmen. Zu Endgeräten wie Servern usw. sollte LACP sowieso immer Pflicht sein !
802.3ad LAGs mit LACP können durch die Bank auch ältere antike Switches.
Verbindungen laufen derzeit im LAG ohne LACP
Nicht gut.....besser wenn immer möglich LACP verwenden !
Bitte warten ..
Mitglied: MichaZ
26.01.2015 um 20:01 Uhr
Naja ich arbeite seid einiger Zeit an der Dokumentation des ganzen Konstrukts
und bin daher noch bei der Bestandsaufnahme. Angefangen habe ich mit so Dingen
wie der Vergabe aussagekräftiger Namen und dem Eintragen der oder des NTP-Server(s).
Als zentraler Kontenpunkt ist ein Stack aus 2x 3Com 5500G-EI im Einsatz. An diesem
hängen vom HP A5120 bis hin zum SuperStack 3 4828G verschienden Kästen aus
dem Hause nun HP. An LACP habe ich mich aus versucht aber da gibt es leider auch
Unterschiede in den unterstützten Modis. Wenn ich auf dem 5500G LACP auf "dynamic"
stelle und es in der LAG vom A5120 mit konfiguriere ist der Link weg. Aber mit der Info
das STP nicht gleich STP ist und MSTP (was der HP kann) sich alles noch ganz anders
verhält, muss ich erst mal die Einstellungen der Ports und LAGs durchgehen.
Bitte warten ..
Mitglied: aqui
27.01.2015 um 17:43 Uhr
Ein bischen Grundlagen zur LAG Konfiguration findest du auch hier:
http://www.administrator.de/wissen/netzwerk-management-server-mit-raspb ...
Dort findest du auch ein paar Beispiele wie es auf dem HP zu lösen ist.
Dynamic sollte man immer machen, denn das ist die LACP Variante und die ist standartisiert über alle Hersteller auch bei antiken Modellen.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Switche und Hubs
Switch-Tausch 3com durch HP (3)

Frage von NoobOne zum Thema Switche und Hubs ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Windows Netzwerk
USB-Gerät ins Netzwerk (Domäne) einbinden (4)

Frage von griss0r zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...