Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

3ware 9650SE, SuperMicro Board, Kernelmodul erkenn Controller nicht

Frage Linux

Mitglied: AxelErnst

AxelErnst (Level 1) - Jetzt verbinden

13.03.2007, aktualisiert 14.03.2007, 8896 Aufrufe, 1 Kommentar

3w-9xxx liefert nach laden des modules keine Ergebnisse, es kein controller vorhanden

Hallo,

ich quäle mich, einen 3ware 9650SE mit dem 3w-9xxx modul anzusteuern. Der Controller ist im Supermicro-Board PDSME+ installiert, das Raid vorbereitet, laut Biosstartmeldung wird das Bios des Controllers erfolgreich registriert. Ich habe mehrere Distries und das von 3ware gelieferte module probiert. Nach modprobe 3w-9xxx wird zwar das modul geladen, aber das war's. Es gibt außer der erfolgreichen Lademeldung keine weitere Aktivität, folglich ist der Controller oder seine Platte (Raid1-verbund) nicht ansprechbar.

Hat dies schan einmal jemand erlebt? Nach den gängigen Methoden und Anleitungen sollte doch das Laden des Modules reichen? Gibt es wie bei (USB) Modulen Parameter, die man mit übergeben kann?

Einzig auffällig fand ich lspci, das den Controller nennt, allerdings als unknown device 1004 klassifiziert.

Habe die letzten zwei Tage mit dem Thema zugebracht und bin nach etlichen Suchorgien für jeden Denkanstoß dankbar.

Axel.
Mitglied: AxelErnst
14.03.2007 um 09:20 Uhr
Hallo Mitleser,

das Problem konnte gelöst werden. Das Problem besteht darin, dass 3ware zwar SuSE 10.1 als supportet einstuft, was aber nicht -wovon ich ausging- automaitsch für 10.2 gilt. Alle in den Kerneln < 2.6.19 enthaltenen 3w-9xxx Module unterstützen die 9xxx er Serien der Controller. Mit Ausnahme des hier verwendeten 9650SE. Per Zufall stieß ich auf der Herstellerseite auf diese Information. dort gibt es für den in SuSE 10.2 verwendeten 2.6.18 Kernel ein passendes Modul. Allerdings funktioniert die simple Installationsanleitung nicht wirklich. Diese besagt, kopiere auf Diskette und lade beim Installationsvorgang. Das klappt leider nicht, da das Setup keine vfat/fat Treiber lädt. Auch das Formatieren der Diskette mit ext2 bringt keinen Erfolg. Ich habe dies dann wie folgt gelöst:

- Treiber auf Diskette mit ext2-Format
- Installationsprogramm bis zum ersten Dialog laufen lassen.
- Auf eine freie Konsole wechseln.
- fd0 einhängen, mittels insmod direkt den Treiber laden
- Installation forstsetzen.
- Der nach Installation folgende Reboot scheitert natürlich wegen des nicht enthaltenen Moduls.
- Aktuelle Knoppix booten (kommt mit 2.6.19 ! kann also direkt den Controller ansprechen)
- Partitionen mounten.
- chroot in den eigentlichen / Mountpoint
- Modul von Diskette in den Kernelpfad kopieren, dabei das Default-Modul überschreiben.
- Dann unbedingt mkinitrd laufen lassen, denn sonst kann das System nie starten. Die Parameter für das bootimage sind bereits durch Yast korrekt eingestellt.
- Neustart.

Läuft.

Ich habe dies hier so ausführlich erläutert, damit es auch anderen hilt. Ich hoffe der Artikel ist jetzt nicht zu lang.

Gruß Axel.

P.S. Der Hersteller hatte sich binnen 8 Stunden gemeldet, allerdings nur eine telefonische Hilfe in England in Aussicht gestellt. Insofern zumindest ein + für die grundsätzliche Bereitschaft für den Support.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Festplatten, SSD, Raid
gelöst Defekten 3Ware Controller Tauschen (5)

Frage von Koseb586 zum Thema Festplatten, SSD, Raid ...

Windows Server
gelöst Domain Controller abgeschossen - benötige Hilfe - EILT (3)

Frage von Philzip zum Thema Windows Server ...

Firewall
PfSense auf soekris-Board installieren (2)

Link von Kuemmel zum Thema Firewall ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...