Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

50 Prozent Packet loss zwischen HP und Alcatel Switch

Frage Netzwerke LAN, WAN, Wireless

Mitglied: Resolv

Resolv (Level 1) - Jetzt verbinden

13.11.2012 um 09:06 Uhr, 3409 Aufrufe, 16 Kommentare

Hallo Leute,

bin neu hier und hoffe mir kann jemand weiterhelfen. Ich habe bei mir im Labor einen Switch welcher als Core fungiert (HP 2620-48G) L2 auf welchem eine Fortinet Firewall hängt die das Routing zwischen den VLANs durchführt. Jetzt habe ich einen Alcatel S6250-24 L2 an diesen HP Switch angeschlossen, VLANs konfiguriert und die Uplinks 802.1q getaggt. Das gleiche habe ich natürlich auch auf dem HP Switch durchgeführt für den Uplink zwischen den beiden.

Pinge in nun vom Alcatel Switch via Console das Gateway habe ich 50% Packet loss.

-> ping 10.114.82.1
PING 10.114.82.1: 56 data bytes
64 bytes from 10.114.82.1: icmp_seq=0. time=9. ms
T
64 bytes from 10.114.82.1: icmp_seq=2. time=1. ms
T
64 bytes from 10.114.82.1: icmp_seq=4. time=1. ms
T
----10.114.82.1 PING Statistics----
6 packets transmitted, 3 packets received, 50.00% packet loss
round-trip (ms) min/avg/max = 1/3/9

Vom HP Switch aus kann ich das GW ohne Packet los pingen. Es ist für mich recht schwierieg das Problem einzugrenzen da dieses mal besteht und wiederum 10sec später geht der ping auf das GW reibungslos.

GW ist 10.114.82.1 (FW)
Alcatel hat 10.114.82.200
HP hat 10.114.82.20

Beste Grüße
Christian
Mitglied: dog
13.11.2012 um 09:35 Uhr
Hast du evtl. bei einem der Switche Auto Negotiation ausgeschaltet?
Wenn du mehrere Kabel benutzt hast du auf beiden den selben STP-Standard konfiguriert?
Bitte warten ..
Mitglied: MrNetman
13.11.2012, aktualisiert um 09:36 Uhr
Hi Christian,

Normalerweise wird der Ping nicht 6 mal gesendet. (jeder 2. bekommt eine Antwort)
Die Switche sind ja im selben Netz und hoffentlcih VLAN. Von daher müssten sie sich direkt ohne Router sehen.
Warum also das Gateway pingen?
Außerdem müssen Switche nicht 100ig auf Pings antworten. das ist nicht ihr Job. Und Firewalls haben erst recht ncihts mit pings am Hut. Es sollte für die Alarmmeldung 50% Paketverlust schon eine andere Messmethode eingesetzt werden. iperf oder netI/O

Gruß
Netman
Bitte warten ..
Mitglied: Resolv
13.11.2012, aktualisiert um 09:43 Uhr
ich sehe mir das alles mal an uns melde mich wieder. ich bin nicht so der 100% networker

edit:
hab das jetzt tortzdem nochmal mit ping versucht und kann vom alcatel den hp nicht pingen, von hp jedoch den alcatel. irgendwas ist das faul. ich schau mir das wie beschrieben nochmals genauer an.
Bitte warten ..
Mitglied: Resolv
13.11.2012 um 10:20 Uhr
Also ich hab mir das jetzt mal mit iperf und netI/0 angesehen. Unabhängig davon habe ich ein Problem mit der Netzwerkkommunikation zwischen den beiden switches. Ich hab mal einen Pink vom HP abgesetzt

HP# ping 10.114.82.200
10.114.82.200 is alive, time = 25 ms
HP# ping 10.114.82.200
Target did not respond.
HP# ping 10.114.82.200
10.114.82.200 is alive, time = 1 ms

Also da haut ja prinzipiell mal was nicht hin. Mit iperf und netI/0 kann den Durchsatz messen was ich jetzt so auch versucht habe aber das löst mein Problem nicht wenn der Switch nicht erreichbar ist bzw nicht reagiert. Ich muss mit dem Switch via SNMP sprechen können um ein Produkt zu testen und da ist mir aufgefallen das er teilweise nicht reagiert da er einfach nicht erreichbar ist.
Bitte warten ..
Mitglied: MrNetman
13.11.2012 um 10:39 Uhr
Ping ist keine Aufgabe des Switches.
SNMP ist eine gute Sache für den Switch.
Wenn die Last zu groß wird, dann werden nach und nach andere Funktionen depriorisiert. (Ping, HTTP, SNMP)
Also nimm open SNMP und prüfe ob der Switch auf SNMP reagiert.
Bitte warten ..
Mitglied: Resolv
13.11.2012 um 10:47 Uhr
Hallo Dog,

auto neogotiation ist auf beiden switches aktiviert und auf auto. ich verwende nur einen Port als Uplink
Bitte warten ..
Mitglied: Resolv
13.11.2012 um 10:48 Uhr
werde ich gleich versuchen. danke vorab mal
Bitte warten ..
Mitglied: Resolv
13.11.2012 um 10:59 Uhr
Switch reagiert gundsätzlich auf SNMP. Er ist jedoch teilweise nicht erreichbar, bedeutet er reagiert dann wieder nicht auf SNMP anfragen. Auf dem Switch hängt kein Endgerät der hat im Moment nix zu tun.
Bitte warten ..
Mitglied: aqui
13.11.2012, aktualisiert um 11:03 Uhr
Du solltest das testweise mal auf einen festen Speed und Duplex Wert setzen auf beiden Seiten !
Nochwas wichtiges:
WAS für eine Art Spanning Tree fährst du auf den Switches. In der Regel ist das bei Alcatel per Default aktiviert ?
Die HP Gurken können KEIN Per VLAN STP (PVSTP) sofern der Alcatel sowas aktiviert hat !!
Dann kann es zu solch merkwürdigen Effekten kommen.
Die HP Billigteile können nur Single Span und MSTP. Sofern du keine Redundanz im Netz hast solltest du ggf. zum Testen erstmal auf STP verzichten und das deaktivieren um da nicht weitere Probleme zu schaffen.
Desweiteren solltest du noch checken wie Alcatel mit dem default VLAN 1 auf tagged Uplinks verfährt ?
HP überträgt das Default VLAN auf einem Tagged Link immer parallel untagged. Du musst zwingend darauf achten das der Alcatel das auch macht. (Pingcheck)
Desweiteren sollte klar sein das du keinerlei Layer 3 Interfaces auf den Switches in diesen VLANs konfiguriert haben darfst sofern die FW die einzige Routing Instanz ist oder sein soll zw. diesen VLANs !!
Machst du das nicht hast du über die Switches einen Backdoor Router (Parallel Router) der auch solche Effekte auslösen kann !
Generell funktioniert eine 802.1q Uplink Kopplung mit HP und Alcatel absolut fehlerfrei wenn man die obigen Bedingungen beachtet !
Bitte warten ..
Mitglied: Resolv
13.11.2012 um 11:41 Uhr
Hallo aqui!

>>aWAS für eine Art Spanning Tree fährst du auf den Switches. In der Regel ist das bei Alcatel per Default aktiviert ?
Die HP Gurken können KEIN Per VLAN STP (PVSTP) sofern der Alcatel sowas aktiviert hat !!
Dann kann es zu solch merkwürdigen Effekten kommen.

Das war die Lösung! Auf den Alcatel ist per Default am VLAN STP aktivert (Jetzt weis ich warum ich Cisco so liebe!!!). Ich hab das jetzt deaktivert und siehe da auf einmal habe ich bei Ping auf das GW 10.114.82.1 Antwortzeiten von 1ms und keine Timeout´s mehr.

-> vlan 82 stp disable


Vielen Vielen Dank!
Bitte warten ..
Mitglied: aqui
15.11.2012, aktualisiert um 15:43 Uhr
Das hat nichts mit Cisco lieben zu tun, denn die machen das auch !! Die unterschiedlichen STP Derivate sollte man als Netzwerker eigentlich kennen ?!
Per default ist bei allen Cisco Switches Spanning Tree aktiviert und sogar noch deren proprietäres PVSTP+ was mit keinem anderen kompatibel ist (sofern man es nicht umkonfiguriert)
Du liebst also genau das falsche Ende...aber nundenn !
Gut wenns jetzt klappt
Bitte warten ..
Mitglied: HanSolo
25.02.2013 um 12:21 Uhr
Auch wenns was spät ist.
Hatte ein ähnliches Problem, lag tatsächlich am STP.
Die Alcatel Switche laufen im Modus 1x1
Änder das auf flat mit
>bridge mode flat
>bridge protocol rstp
Bitte warten ..
Mitglied: aqui
25.02.2013 um 12:24 Uhr
Was ist denn ein "Modus 1x1" im Spanning Tree ???
Bitte warten ..
Mitglied: HanSolo
27.02.2013 um 12:15 Uhr
Ein eigenes Alcatel Lucent STP Protokol 1x1 ( per VLAN). Wird nur vom AOS(OS auf dem Switch) unterstützt und ist per default aktiviert.
Wenn du nur AOS Switche hast kein Problem. Hast du aber verschiedene Hersteller im Netz, musst du es umstellen auf flat Modus.
Bitte warten ..
Mitglied: aqui
28.02.2013, aktualisiert um 18:39 Uhr
Das ist nicht "eigen" sondern nennt sich "PVST" oder wenn es mit Cisco BPDU Paketen arbeitet "PVST+". (Per Vlan Spanning Tree)
Das können andere Hersteller auch ! Außer Billichheimer HP natürlich, da darfs ja für die Masse nix kosten !
Das ist also Unsinn was du da sagst und zeigt das du, sorry, nicht wirklich STP verstanden hast !
Das was du als "flat" bezeichnest ist das sog. "Single Span Verfahren"
Billighersteller wie HP implemntieren das weil es einfach ist aber kontraproduktiv, denn es hat lediglich einen STP Prozess für alle VLANs. Reisst der ein VLAN runter reisst er alle VLANs runter.
Bei HP darfs ja nix kosten deshalb gehts da nur billig mit Singel Span !
Kein verantwortungsvoller Netzwerker macht das heutzutage noch so.
Glücklicherweise sind die HP Switches nicht totaler Schrott wenn auch 90% von ihnen das ist sondern sie können wenigstens noch MSTP !
Alcatel supportet auch MSTP (ein weltweiter Standard) was dann kompatibel ist und auch sinnvollerweise mehrere STP Instanzen pro VLAN zulässt !
Wenigstens das sollte man nutzen und niemals auf Single Span umstellen.
Wie gesagt: STP verstehen ist hierbei die halbe Miete !
Bitte warten ..
Mitglied: HanSolo
04.03.2013, aktualisiert um 10:16 Uhr
Mit dem was du sagst hast du recht und ich muss auch zugeben das ich spantree nur grob verstehe.

Wollte nur mitteilen, das die Alcatel Lucent Switche im Spantree Modus 1x1 stehen per default und dieser ist nicht kompatibel mit dem Cisco PVST.
In meinem Fall lief alles erst vernüftig wo wir Rstp im Flat Modus(BPDU im default VLAN) genutzt haben. Dies wurde von Hersteller empfohlen und danach lief es ohne probleme stabil im Kombination mit einem Cisco Switch und mit einem Alcatel Lucent LS6200 ( der nicht mit dem AOS Betriebsystem arbeitet, ähnlich der Cisco Oberfläsche)Haben seit dem schon mehrere Switche verbaut und schalten hier direkt den MOdus 1x1 ab und haben damit kein Problem.
Man sollte natürlich ein einheitliches Protokoll wählen, oft heißt es aber einfach, stell den Switch dort neu auf für neue Ports und nichts ist über das bisherige Netz bekannt. Kann nur empfehlen mal auf Flat umzuschalten und mal nachschauen ob der STP Root Bridge Timer hoch läuft und nicht ständig wechselt.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Switche und Hubs
gelöst HP Procurve Switch 2650 J4899B Hängt, keine Verbindung möglich (7)

Frage von duke1212 zum Thema Switche und Hubs ...

Netzwerkprotokolle
gelöst Problem bei VLAN Trunk mit LACP zwischen HP und Cisco (11)

Frage von markuswo zum Thema Netzwerkprotokolle ...

Netzwerkmanagement
gelöst HP 1920 24G Switch QOS-Problem bei Portzuweisung mit DHCP Relay (2)

Frage von farbschmelz zum Thema Netzwerkmanagement ...

LAN, WAN, Wireless
gelöst Kein DHCP-Relay am Sub-Switch HP (20)

Frage von westberliner zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (12)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...