Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

504 Need to authenticate first, Quelle MSExchangeTransport, ID 7004

Frage Microsoft Exchange Server

Mitglied: Alphaman

Alphaman (Level 1) - Jetzt verbinden

14.02.2007, aktualisiert 17.02.2007, 4450 Aufrufe, 4 Kommentare

Hi Leute,

ich hab ein kleines Problem was ich einfach nicht geloest bekomme. Ein Kunde von uns versendet seine eMails direkt an die SMTP Server und nicht über einen Relay SMTP Server... Wenn er uns eine Mail schicken will dann erscheind immer eine Fehlermeldung im Ereichnisprotokoll. Quelle: MSExchangeTransport, Event ID 7004.

Im Ereignisprotokoll steht:

Dies ist ein Protokoll des SMTP-Protokolls für den virtuellen Server mit ID 1, Verbindung #9. Der Client unter 'xxx.xxx.xxx.xxx' hat einen 'xexch50'-Befehl gesendet, worauf der SMTP-Server mit '504 Need to authenticate first ' geantwortet hat. Der vollständige gesendete Befehl lautete 'xexch50 1020 2'. Hierdurch wird die Verbindung wahrscheinlich fehlschlagen.

Im SMTPSVC1 Logfile steht:

2007-02-14 10:13:18 xxx.xxx.xxx.xxx OutboundConnectionResponse SMTPSVC1 THESERVER- 25 - - 220+Domain1.de+Microsoft+ESMTP+MAIL+Service,+Version:+6.0.3790.1830+ready+at++Wed,+14+Feb+2007+11:13:18++0100+ 0 0 113 0 16172 SMTP - - - -
2007-02-14 10:13:18 xxx.xxx.xxx.xxx OutboundConnectionCommand SMTPSVC1 THESERVER- 25 EHLO - Domain2.com 0 0 4 0 16172 SMTP - - - -
2007-02-14 10:13:18 xxx.xxx.xxx.xxx OutboundConnectionResponse SMTPSVC1 THESERVER- 25 - - 250-Domain1.de+Hello+[217.7.203.253] 0 0 39 0 16203 SMTP - - - -
2007-02-14 10:13:18 xxx.xxx.xxx.xxx OutboundConnectionCommand SMTPSVC1 THESERVER- 25 MAIL - FROM:<gs320@Domain2.de>+AUTH=<> 0 0 4 0 16203 SMTP - - - -
2007-02-14 10:13:18 xxx.xxx.xxx.xxx OutboundConnectionResponse SMTPSVC1 THESERVER- 25 - - 250+2.1.0+gs320@Domain2.de....Sender+OK 0 0 39 0 16234 SMTP - - - -
2007-02-14 10:13:18 xxx.xxx.xxx.xxx OutboundConnectionCommand SMTPSVC1 THESERVER- 25 RCPT - TO:<servicedesk@Domain1.de> 0 0 4 0 16234 SMTP - - - -
2007-02-14 10:13:18 124.106.208.41 missvalley.com SMTPSVC1 THESERVER192.168.0.1 0 QUIT - missvalley.com 240 7453 101 3279 5937 SMTP - - - -
2007-02-14 10:13:18 xxx.xxx.xxx.xxx OutboundConnectionResponse SMTPSVC1 THESERVER- 25 - - 250+2.1.5+servicedesk@Domain1.de+ 0 0 36 0 16453 SMTP - - - -
2007-02-14 10:13:18 xxx.xxx.xxx.xxx OutboundConnectionCommand SMTPSVC1 THESERVER- 25 XEXCH50 - 1020+2 0 0 7 0 16453 SMTP - - - -
2007-02-14 10:13:26 xxx.xxx.xxx.xxx OutboundConnectionResponse SMTPSVC1 THESERVER- 25 - - 504+Need+to+authenticate+first 0 0 30 0 24094 SMTP - - - -
2007-02-14 10:13:26 xxx.xxx.xxx.xxx OutboundConnectionCommand SMTPSVC1 THESERVER- 25 BDAT - 30218+LAST 0 0 4 0 24094 SMTP - - - -
2007-02-14 10:13:29 xxx.xxx.xxx.xxx OutboundConnectionResponse SMTPSVC1 THESERVER- 25 - - 250+2.6.0++<SERVERDomain27JRIXp00000011@Domain2.com>+Queued+mail+for+delivery 0 0 77 0 27422 SMTP - - - -
2007-02-14 10:13:29 xxx.xxx.xxx.xxx OutboundConnectionCommand SMTPSVC1 THESERVER- 25 QUIT - - 0 0 4 0 27437 SMTP - - - -
2007-02-14 10:13:29 xxx.xxx.xxx.xxx OutboundConnectionResponse SMTPSVC1 THESERVER- 25 - - 221+2.0.0+Domain1.de+Service+closing+transmission+channel 0 0 60 0 27453 SMTP - - - -


Kann mir evtl jemand helfen. Ich hab bei Microsoft und eventid nachgeschaut, bin aber leider nicht schlau draus geworden.

Gruß,
Alphaman
Mitglied: Hosch
14.02.2007 um 11:31 Uhr
liegt wahrscheinlich daran, daß der Name der Exchange-Domain nicht im DNS des Internets aufgelöst werden kann. Die meisten SMTP-Server im Internet unterstützen kein Relaying(mehr) und machen dann dicht.
Also lass die Mails über einen Smarthost rausgehen, dann sollte es funktioneren.
Bitte warten ..
Mitglied: Alphaman
14.02.2007 um 13:52 Uhr
meinst du evtl die domain die der server dann trägt z.B. gmx.local oder meinst du gmx.de.

Bei uns und beim Kunden haben wir .local am laufen, aber die Domain unter der die eMail rausgeht gibt es im internet. Hat natuerlich nicht die IP des Servers da Webseite und Mail unterschiedliche Proviter sind.

Das komische ist das wir es nicht zulassen. Wenn er uns eine eMail direkt schicken will dann bekommt wir beide diese Fehlermeldung. Wir verschicken unsere eMails über einen Smarthost.

Evtl. noch eine idee wie man das Problem beseitigen kann. Evtl. was wir einstellen muessen damit wir es annehmen ;) Ich hab schonmal geschaut ob an dem ESMTP Befehl ELHO hängt aber das ist es nicht. Ich habe auf HELO umgestellt aber trotzdem hatte er mir immernoch mit ELHO gesendet ;(
Bitte warten ..
Mitglied: Hosch
14.02.2007 um 22:48 Uhr
Ich kann jetzt nicht ganz zuordnen, was Du da geschrieben hast von wegen mit "nicht zulassen".
Aber noch mal kurz zum Verständnis. Steht Dein Mailserver im internen Firmennetz und trägt dann auch noch .local geht es nicht. Grund:
1. .local ist keine registrierte Internet-Domain(der server meldet sich dann ja beim jeweiligen Mailserver im Internet mit z.B. "helo server.firma.local").
2. Selbst wenn der server sich mit "helo server.firma.de" meldet, prüft der andere Mailserver über Befragung des MX-Records im DNS-Systems nach, ob die IP auch mit der registrierten übereinstimmt. Ist das nicht die Gleiche, macht der dicht.

Also bleiben zwei Möglichkeiten:
1. Du läßt Deinen Server via dyndns(oder ähnlichem) beim Mailprovider als MX eintragen oder
2. Du läßt alle ausgehenden Mails über einen Smarthost laufen, und trägst bei dem Benutzernamen und Passwort die für eines Deiner externen Mailkonten ein.
Bitte warten ..
Mitglied: Donnerwetter
17.02.2007 um 05:35 Uhr
Hallo,

wenn ich das hier richtig verstanden habe, dann sendet Ihr vom SMTP der Exchange per DNS-Auflösung direkt an die Empfänger Domains.
Stimmts, oder hab ich recht?

Was die Kollegen weiter oben meinten ist, dass Du den SMTP-Connector des Exchange Servers
auf den SMTP-Relay Server Eures ISP verweisen lassen sollst.
Dieser SMTP-Relay kann aus dem Internet mit einem eindeutigen Namen aufgelöst werden
und von ihm gesendete Mails werden dann auch korrekt angenommen.

Habt Ihr eventuell auch noch einen DSL Zugang mit wechselnder IP?
Dann wollen noch weniger Empfänger mit euch arbeiten.

MfG

Donnerwetter
Bitte warten ..
Ähnliche Inhalte
Datenbanken
gelöst SQL - nur Daten mit niedrigster ID ausgeben (1)

Frage von winscheil zum Thema Datenbanken ...

Windows Server
gelöst Ereignisanzeige ID 55 NTFS Fehler welche Platte (4)

Frage von Fruehling2017 zum Thema Windows Server ...

Exchange Server
MSExchange Assistants Warnung ID 9045 (1)

Frage von Mazenauer zum Thema Exchange Server ...

JavaScript
gelöst How to send request to get location id (2)

Frage von thankusomuch zum Thema JavaScript ...

Neue Wissensbeiträge
Batch & Shell

Batch - ein paar Basics die man kennen sollte

Tipp von Pedant zum Thema Batch & Shell ...

Microsoft

Restrictor: Profi-Schutz für jedes Window

(6)

Tipp von AlFalcone zum Thema Microsoft ...

Batch & Shell

Batch zum Zurücksetzen eines lokalen Profils

Tipp von Mr.Error zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Windows Server
gelöst Benutzer lässt sich nur an einem Clientcomputer anmelden (15)

Frage von Ammann zum Thema Windows Server ...

Batch & Shell
gelöst Gruppenzugehörigkeit von AD Usern ermitteln - die Perfektion fehlt (11)

Frage von Stefan007 zum Thema Batch & Shell ...

LAN, WAN, Wireless
gelöst Netzwerk in 2 Teile trennen (11)

Frage von pattex zum Thema LAN, WAN, Wireless ...