Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

70-persistent-net.rules nicht vorhanden

Frage Linux Debian

Mitglied: Wild-Wolf

Wild-Wolf (Level 1) - Jetzt verbinden

27.03.2013, aktualisiert 15:02 Uhr, 8245 Aufrufe, 9 Kommentare

Hallo zusammen.

Habe ein Problem egal mit der 70-persistent-net.rules.
Habe unter VM Workstation squeeze und Wheezy installiert allerdings fehlt bei beiden die 70-persistent-net.rules

/lib/udev/write_net_rules all_interfaces sagt immer:
missing $INTERFACE

Wie kann ich das Problem lösen?
Mitglied: 64748
27.03.2013 um 17:26 Uhr
Hallo,

hast Du überall nachgesehen? also in /etc/udev/rules.d/ und in /lib/udev/rules.d/ die Regeln beider Verzeichnisse werden von udev verarbeitet, jedoch die im /etc/ Verzeichnis mit höherer Priorität.

Normalerweise wird die 70-persistent-net.rules bei der Installation angelegt. Du kannst die Datei aber auch selbst anlegen, hier als Beispiel meine, die kannst Du ja anpassen.
# PCI device 0x168c:/sys/devices/pci0000:00/0000:00:04.0/0000:02:00.0 (ath9k) 
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="f0:7b:cb:2e:cd:3e", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0" 
 
# PCI device 0x11ab:/sys/devices/pci0000:00/0000:00:06.0/0000:04:00.0 (sky2) 
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:24:54:6e:93:49", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
Markus
Bitte warten ..
Mitglied: orcape
27.03.2013 um 21:52 Uhr
Hi Wild-Wolf,

hast Du Debian mit der Netinstall als VM installiert ?
Hab das mal nachgestellt, die Datei fehlt bei mir ebenfalls.
Ursache ist wohl die Tatsache, das Du eine Virtuelle Netzwerkkarte hast und Debian bei der Installation in der VM noch nicht mal nach einer IP fragt.
Funktionieren tut das NW ohne Probleme und ohne...
70-persistent-net.rules
Gruß orcape
Bitte warten ..
Mitglied: Wild-Wolf
28.03.2013 um 11:32 Uhr
Hi @orcape.

Genau so siehts aus. Kann man dieses irgendwie umgehen? (Außer selbst anlegen?)
Zumal komischerweise die eth´s nicht automatisch starten und ich die immer über ifup ethx starten muss....

@64748, danke für die INfo
Bitte warten ..
Mitglied: 64748
28.03.2013 um 12:01 Uhr
Zitat von Wild-Wolf:
Hi @orcape.

Genau so siehts aus. Kann man dieses irgendwie umgehen? (Außer selbst anlegen?)
Zumal komischerweise die eth´s nicht automatisch starten und ich die immer über ifup ethx starten muss....
Die traurige Wahrheit ist, dass die Interfaces von udev gestartet werden. Daher die udev-rules. Das heist, dass es kein Zufall ist, dass Du ifup manuell ausführen musst.

Du kannst mit dmesg und lspci die Daten der Karte rausfinden (sollte bei einer VM ähnlich laufen wie mit richtiger Hardware).
lspci -k | grep -iA3 ether
sollte Dir Daten über den Adapter anzeigen. Dann versuchst Du mal den mit dmesg zu finden. Z.B. ebenfalls mit grep
demsg | grep -iA10 ether
Dann trägst Du die Daten in die 70-persistent-net.rules ein und liest die Regeln neu ein
udevadm control --reload
Und guckst mal was passiert. Zur Not kannst Du den ifup-Befehl und ggf. den DHCP-Client-Dienst mit in die udev-rule packen.

Markus
Bitte warten ..
Mitglied: Wild-Wolf
02.04.2013 um 11:29 Uhr
@64748 ich habe das jetzt mal getestet (siehe screen) allerdings passiert beim dmesg nix.
http://s7.directupload.net/images/130402/l6e8umpm.jpg
Bitte warten ..
Mitglied: 64748
02.04.2013, aktualisiert um 12:07 Uhr
Hallo,
Zitat von Wild-Wolf:
@64748 ich habe das jetzt mal getestet (siehe screen) allerdings passiert beim dmesg nix.
dmesg liegt unter /sbin/dmesg, wenn das Kommando dmesg keine Ausgabe hat, versuch mal /sbin/dmesg. Wenn allerdings nur der String "ether" nicht gefunden wird, dann musst Du mal die Ausgabe in einer Textdatei speichern und dann im Editor suchen.
/sbin/dmesg > /tmp/dmesg.txt


Markus
Bitte warten ..
Mitglied: Wild-Wolf
02.04.2013 um 12:02 Uhr
Hofe das stimmt so?:
http://s14.directupload.net/images/130402/2jpex7kr.jpg
weiß net wo ich den sys-Pfad herbekomme

  1. PCI device 0x2000:/sys/devices/pci0000:00/0000:00:04.0/0000:02:01.0 (pcnet32 )

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0c:29:64:7c:e4", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"



  1. PCI device 0x2080:/sys/devices/pci0000:00/0000:00:06.0/0000:02:02.0 (pcnet32 )

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0c:29:64:7c:ee", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"


  1. PCI device 0x2400:/sys/devices/pci0000:00/0000:00:06.0/0000:02:03.0 (pcnet32 )

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0c:29:64:7c:f8", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth2"
Bitte warten ..
Mitglied: 64748
02.04.2013, aktualisiert um 12:11 Uhr
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="pcnet32", ATTR{address}=="MAC-Adresse", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
So in etwa, die Mac-Adresse des Interfaces musst Du noch einsetzen.

Es gibt dieses Tutorial, aber es ist veraltet, die Syntax hat sich verändert, aber zum Verständnis der Zusammenhänge sollte es noch reichen.

Markus
Bitte warten ..
Mitglied: Wild-Wolf
02.04.2013 um 12:24 Uhr
Danke ich schau mal
Bitte warten ..
Ähnliche Inhalte
Sicherheits-Tools
Desinfect 2017 persistent auf USB-Stick
Beitrag von 9 Kommentare

Frage von sklaim zum Thema Sicherheits-Tools

Windows Netzwerk
Net use persistent no
Beitrag von 2 Kommentare

Frage von Malgain zum Thema Windows Netzwerk

Windows Netzwerk
70 GB große Datei über das Netzwerk von einem Server zum anderen kopieren
Beitrag von 23 Kommentare

Frage von Rene1976 zum Thema Windows Netzwerk

Windows Update
Server hat seinen Status seit 70 Tagen nicht bei WSUS gemeldet
Beitrag von 2 Kommentare

Frage von fox14ch zum Thema Windows Update

Neue Wissensbeiträge
Vmware

VMware Desktopprodukte sind verwundbar

Beitrag von

Information von Penny.Cilin zum Thema Vmware

Datenschutz

Session-Replay: Viele beliebte Webseiten zeichnen jegliche Texteingabe auf

Beitrag von

Information von Penny.Cilin zum Thema Datenschutz

Sicherheit

Zufällige Speicherzuweisung: Windows-Bug hebelt Sicherheitsmechanismus ASLR aus

Beitrag von

Information von Penny.Cilin zum Thema Sicherheit

Multimedia

Raspberry Pi als Digital-Signage-Computer

Beitrag von 1 Kommentar

Information von BassFishFox zum Thema Multimedia

Heiß diskutierte Inhalte
Visual Studio
Vb.net-Tool zum Erzeugen einer Outlook-E-Mail
Beitrag von 24 Kommentare

Frage von ahstax zum Thema Visual Studio

Windows Server
RDP macht Server schneller???
Beitrag von 16 Kommentare

Frage von JaniDJ zum Thema Windows Server

Windows Netzwerk
Netzwerk Neustrukturierung
Beitrag von 16 Kommentare

Frage von IT-Dreamer zum Thema Windows Netzwerk

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Beitrag von 15 Kommentare

Frage von Akcent zum Thema Windows 10