Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Server 2003, Sicherheitseinstellungen müssen immer wieder von Hand gesetzt werden

Frage Microsoft Windows Server

Mitglied: driftar

driftar (Level 1) - Jetzt verbinden

07.12.2009 um 16:16 Uhr, 5300 Aufrufe

Windows Server 2003 Standard, Sicherheitseinstellungen eines Ordners funktionieren nicht dauerhaft. Bestimmte Sicherheitsgruppen müssen entfernt und erneut hinzugefügt werden. Anschliessend funktionieren die Sicherheitseinstellungen wieder.

Hallo Community!

Dank Eurer Hilfe bin ich hier auf den Seiten immer wieder mal auf Lösungen und Lösungsansätze gestossen welche mir sehr geholfen haben.

Ich hoffe nun dass jemand von Euch mir auch bei einem konkreten Problem helfen kann. Ich mühe mich nun schon seit einigen Monaten rum mit dem Problem, habe viele Tipps und Hinweise gelesen, habe Scripts erstellt. Alles ohne Erfolg.

Systembeschreibung
Wir setzen einen Webserver auf Basis von Windows Server 2003 Standard. Nachfolgend einige Erläuterungen zum System an sich:

- Windows Server 2003 Std.
- IIS 6 am laufen
- keine Webseite, lediglich Webdienste am laufen

Auf dem Webserver läuft eine Datenbank welche wöchentlich Dateien in den Ordner "C:\inentpub\wwwroot\Export" exportiert (Unterordner vom IIS Verzeichnis).

Diese Dateien (es handelt sich um verschlüsselte Textfiles) sollten dann von Computern runtergeladen werden. Auf den Computern läuft eine Verwaltungssoftware welche diese Daten runterlädt und in die Software importiert.

Problembeschreibung
Auf dem Ordner Export braucht der Netzwerkdienst zwingend die Sicherheitseinstellung Vollzugriff. Ich weiss, und alle Admins wohl auch, dass Vollzugriff schon alleine beim Lesen schmerzt. Andere Sicherheitseinstellungen funktionieren jedoch schlicht und einfach nicht.

Wenn ich die Sicherheitseinstellungen manuell setze, also Netzwerkdienst hinzufügen, Vollzugriff, vererben auf Unterordner und Dateien, dann läuft der Download bei den Computern. Es kommt nun immer wieder mal vor dass der Download jedoch nicht klappt. Ich nehme dann den Netzwerkdienst aus den Sicherheitseinstellungen raus, klicke auf Übernehmen. Dann füge ich den Netzwerkdienst wieder in den Sicherheitseinstellungen des Ordners hinzu, gebe ihm Vollzugriff. Und ab jetzt klappt auch der Download der Textfiles wieder.

Weitere Informationen
Ich habe versucht das ganze per Script zu automatisieren. Mit cacls.exe klappt das auch recht gut, zumindest wenn ich das Script schrittweise durchlaufen lasse kann ich mitverfolgen dass die oben erwähnten Schritte funktionieren. Netzwerkdienst raus, Netzwerkdienst rein. Das Script läuft alle zwei Stunden damit möglichst der Download immer verfügbar ist... Nur das Problem ist dass der Download der Files trotzdem nicht klappt. Somit muss ich immer von Hand die Schritte durchführen.

Script
cacls C:\Inetpub\wwwroot\Export\*.* /E /R NETZWERKDIENST => Sicherheitseinstellungen von Netzwerkdienst auf allen untergeordneten Dateien entfernen
cacls C:\Inetpub\wwwroot\Export /E /R NETZWERKDIENST => Sicherheitseinstellungen von Netzwerkdienst auf Ordner Export entfernen

cacls C:\Inetpub\wwwroot\Export /E /P NETZWERKDIENST:F => Sicherheitseinstellungen von Netzwerkdienst auf Ordner Export hinzufügen (:F = Vollzugriff)
cacls C:\Inetpub\wwwroot\Export\*.* /E /P NETZWERKDIENST:F => Sicherheitseinstellungen von Netzwerkdienst auf allen untergeordneten Dateien hinzufügen (:F = Vollzugriff)

Frage
Nun kommen wir zur Quizfrage... Wer kennt dieses Problem und deren Ursache und Lösung? Wer hat mir einen Tipp wie ich das anders bewerkstelligen kann? Damits vielleicht ohne Vollzugriff verlässlich klappt?

Ich danke Euch im Voraus und freue mich auf interessante Vorschläge.

Liebe Grüsse
euer driftar
Neuester Wissensbeitrag
Sicherheits-Tools

Wenn das eine Schlangelöl das andere als Malware beschimpft

(5)

Erfahrungsbericht von Lochkartenstanzer zum Thema Sicherheits-Tools ...

Ähnliche Inhalte
Windows Server
gelöst Migration Windows Server 2003 auf 2012 "offline" möglich? (7)

Frage von Christtian zum Thema Windows Server ...

Windows Installation
gelöst Windows Server 2003 Installation schlägt fehl (21)

Frage von CubeTea zum Thema Windows Installation ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2013 neu aufsetzten, da alte VM defekt (48)

Frage von ThunderbirdOP zum Thema Exchange Server ...

Webentwicklung
Einfaches Suchfeld auf Indexseite (19)

Frage von Moddry zum Thema Webentwicklung ...

Netzwerkgrundlagen
Netzwerk aus zwei Segmenten verhält sich merkwürdig (14)

Frage von AndyAh zum Thema Netzwerkgrundlagen ...

CSS
Bräuchte Unterstützung bei einem Floating-DIV-Layout (9)

Frage von Codehunter zum Thema CSS ...