Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Abfrage der CPU-Auslastung per Batch bringt zusätzliche Leerzeile?

Frage Entwicklung Batch & Shell

Mitglied: WiSch

WiSch (Level 1) - Jetzt verbinden

06.05.2009, aktualisiert 14:12 Uhr, 12279 Aufrufe, 5 Kommentare

Ich möchte per Batch-Datei die CPU-Auslastung überprüfen.
Dazu habe ich hier folgenden Beitrag gefunden: http://www.administrator.de/index.php?content=80351

Der letzte Kommentar funktioniert auch, bringt bei mir aber mehr als das gewünschte Ergebnis...

Hier mein Code
FOR /F "tokens=1,2 skip=1 delims= " %%i IN ('"WMIC CPU GET LoadPercentage, DeviceID"') DO ( 
IF %%j LSS 90 echo ------- %date% %time% - Prozessor %%i hat %%j %%% Auslastung  
IF %%j GEQ 90 echo PROBLEM %date% %time% - Prozessor %%i hat %%j %%% Auslastung  
)
Als Ergebnis bekomme ich aber nicht eine, sondern zwei Zeilen:
------- 06.05.2009 14:04:44,72 - Prozessor CPU0 hat 0 % Auslastung   
------- 06.05.2009 14:04:44,72 - Prozessor  
 hat  % Auslastung
Das System hat nur eine CPU, daran dürfte es also nicht liegen...

Wenn ich meinen Code so abändere
FOR /F "tokens=1,2 skip=1 delims= " %%i IN ('"WMIC CPU GET LoadPercentage, DeviceID"') DO ( 
echo -------  %date% %time% - Prozessor %%i hat %%j %%% Auslastung  
)
bekomme ich trotzdem die obige Ausgabe, also an einer falschen if-Abfrage kann es auch nicht liegen!?


Wie unterdrücke ich die sinnfreie zweite Zeile?

Danke.
Mitglied: LotPings
06.05.2009 um 15:42 Uhr
Wmic schmeisst leider eigentlich immer Unicode mit BOM raus, das erschwert die Verarbeitung und deine get Parameter dürfen kein Leerzeichen zwischen dem komma und Parameter haben.

HTH

Gruß
LotPings
Bitte warten ..
Mitglied: paulepank
06.05.2009 um 16:41 Uhr
Hallo AVEHilfe,

vorweg:

1.Lösungen für XP müssen nicht zwangsläufig unter Vista oder schlimmeres laufen. Deine zitierte Lösung war für XP.
2. Blindes abtippen des Codes macht das Kraut nicht fett.
3. Es sollte immer das BS angegeben werden unter der die Batch laufen soll.

Hier ein Workaround für Vista (läuft auch unter XP)
01.
WMIC CPU GET LoadPercentage,DeviceID >cpu.txt 
02.
FOR /F "tokens=1,2 skip=1" %%i IN ('type cpu.txt') DO (  
03.
IF %%j LSS 90 echo ------- %date% %time% - Prozessor %%i hat %%j %% Auslastung   
04.
IF %%j GEQ 90 echo PROBLEM %date% %time% - Prozessor %%i hat %%j %% Auslastung   
05.
)
cu paulepank
Bitte warten ..
Mitglied: WiSch
06.05.2009 um 22:21 Uhr
Hallo paulepank.

Es läuft... danke.

Zu 1. Schon klar... gerade Vista macht da ja gerne mal was anders.
Zu 2. Auch richtig, aber diverse Versuche haben mich nicht weiter gebracht und ganz blind bin ich ja auch nicht unterwegs...
Zu 3. Na dann will ich mal Besserung geloben...

Schicker wäre es natürlich wenn es nicht erst in eine externe Datei geschrieben würde.
Da haben aber bisher alle meine Versuche nicht zur gewünschten einzeiligen Ausgabe geführt... ;(
Bitte warten ..
Mitglied: paulepank
06.05.2009 um 22:54 Uhr
Zu 3. Na dann will ich mal Besserung geloben...
na dann fang mal gleich an, denn das gehört auch zu einem gelöstem Problem
Bitte warten ..
Mitglied: WiSch
06.05.2009 um 23:02 Uhr
Schlaumeier! :P

Vielleicht hat ja noch jemand die Lösung ohne externe Datei?
Wenn nicht, werde ich das morgen hier abschließen...

Gute Nacht.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows 7
gelöst Windows Update bei virtuellem Windows 7 - hohe CPU Auslastung und keine Reaktion (6)

Frage von IT-Alexander zum Thema Windows 7 ...

Microsoft
Server 2012 cpu Auslastung durchgehend bei 10 prozent (1)

Frage von thomasreischer zum Thema Microsoft ...

Netzwerkmanagement
gelöst Sophos UTM220 - Appliance CPU Auslastung LOG-Datei downloaden? (7)

Frage von 1410640014 zum Thema Netzwerkmanagement ...

Hyper-V
Verständnisfrage zu CPU Auslastung (5)

Frage von AndreasOC zum Thema Hyper-V ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...