Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Abfrage ob Datei vorhanden, geht bei mir nicht

Frage Entwicklung KiXtart

Mitglied: TheQuestion

TheQuestion (Level 1) - Jetzt verbinden

26.09.2007, aktualisiert 27.09.2007, 7731 Aufrufe, 5 Kommentare

Guten morgen,

ich habe folgendes Problem und zwar habe ich ein Script geschrieben was aber irgentwie nicht funktioniert.
Da ich aber noch recht neu bin in Kixtart komme ich leider nicht weiter.
Das Script soll abfragen ob 3 bestimmte Dateien in einem bestimmten Ordner vorhanden sind,
wenn ja=> soll das Script sich selbst beenden (funktioniert nicht?!?!)
wenn nur Ordner=> dann kopiere die Dateien vom Quellpfad (funktioniert)
wenn kein Ordner + keine Datien=> lege Ordner an und kopeire die Dateien (funktioniert)
Jedoch kopiert das Script eigentlich immer?!?! Egal ob Daten drin sind oder nicht es legt immer nen neuen Ordner an (überschreibt den alten) und kopiert die Dateien.
Kann mir jemand sagen wo der fehler ist?
Script folgt:


d84818a4463de97215ddd5c19cb054e0-kix - Klicke auf das Bild, um es zu vergrößern

Danke schonmal

TheQuestion
Mitglied: 51705
26.09.2007 um 21:50 Uhr
Dein Script kopiert immer, sobald eine der Dateien oder gar der Ordner fehlt, es selektiert nicht.
Bitte warten ..
Mitglied: Biber
26.09.2007 um 22:32 Uhr
Na hömma, TheQuestion,
  • wenn die Variable $zielordner = "C:\KIX\testordner" ist
  • und die Variable $quelldateia = "C:\KIX\testa.txt" ist,

was erhoffst Du Dir von der Abfrage :
IF EXIST ("$zielordner\$quelldateia")
-bzw.-
IF EXIST ("C:\KIX\testordner\C:\KIX\testa.txt")
??!???!?
Was würdest Du denn antworten, wenn Dich jemand fragt, ob Du eine Datei dieses Namens in letzter Zeit gesehen hast?

Grüße
Biber
Bitte warten ..
Mitglied: 51705
26.09.2007 um 22:40 Uhr
Du hast den Finger in die offene Wunde gelegt, die ich übersehen habe...
Bitte warten ..
Mitglied: Biber
26.09.2007 um 22:47 Uhr
@51705
Du hast den Finger in die offene Wunde gelegt, die ich übersehen habe...
Kein Problem, in die Wunde passen Deine Finger auch noch alle rein...

Grüße
Biber
Bitte warten ..
Mitglied: TheQuestion
27.09.2007 um 14:06 Uhr
Ok ok lasse ja schon die Finger von KIX

Habe die Lösung dann auch noch hinbekommen, habt aber recht das war echt eine besch***ne Abfrage.

Habe dann noch einen Quellordner hinzugefügt und die Abfrage korrigiert dann ging das ganze auch. Trotzdem Danke

MfG
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Ordnerabfrage ob neue Dateien vorhanden (1)

Frage von Bigibob zum Thema Batch & Shell ...

Batch & Shell
gelöst Problem mit der Prüfung, ob Dateien vorhanden sind (9)

Frage von jan999 zum Thema Batch & Shell ...

Sonstige Systeme
gelöst Active Directory Abfragen konfigurieren oder andere erstllen als vorhanden (3)

Frage von SnvRCalle zum Thema Sonstige Systeme ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Internet
gelöst Jeden morgen Internet-Probleme (56)

Frage von pjrtvly zum Thema Internet ...

Server-Hardware
HP DL380 G7: Booten vom USB via USB 3.1-PCI-e Karte möglich? (24)

Frage von Paderman zum Thema Server-Hardware ...

LAN, WAN, Wireless
gelöst IP Adressen - Modem - Switch - Accesspoint (22)

Frage von teuferl82 zum Thema LAN, WAN, Wireless ...

Windows 7
Bluesreens unternehmensweit (22)

Frage von SYS64738 zum Thema Windows 7 ...