Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Oder Abfrage für Reporting Services funktioniert nicht

Frage Entwicklung Datenbanken

Mitglied: Thorsten72

Thorsten72 (Level 1) - Jetzt verbinden

27.09.2010 um 15:20 Uhr, 2959 Aufrufe, 1 Kommentar

Liebe Gleichgesinnten,

ich hoffe, dass sich jemand mit den Reporting Services 2005 auskennt.

Folgende Problematik:

Wir erstellen Reports mit den Reporting Services 2005.

Werden bei einem Report mehrere Parameter abgefragt, die mit einer UND Verknüpfung erstellt sind, sieht das bei der Abfrage wie folgt aus:

http://<SERVERNAME>/ReportServer/Pages/ReportViewer.aspx?/<REPORTNAME>&servername=<SERVERNAME>&user=<USER>&env=<ENV>&rs:ClearSession=true&rs:Command=Render&rc:Parameters=false&rc:LinkTarget=_top&rc:JavaScript=True&where=<DATUM1>%3D%5B;2010-09-27T23:59:59%5D%26<DATUM2>%3D%5B;2010-09-27T23:59:59%5D&rs:Format=HTML4.0

Kurze Erklärung: Hier wird ein Datumsbereich <DATUM1> von bis UND ein Datumsbereich2 <DATUM2> von bis abgefragt.

Das UND wird in der Abfrage mit einem & und damit per %26 Zeichen dargestellt.

Wie kann ich diese Abfrage als ODER Abfrage darstellen? Ich habe schon alle möglichen Zeichen || (%7C) oder auch ^ (%5E) probiert. Selbst das Wort OR funktioniert nicht.

Ich hoffe, es kann mit jemand einen Tipp geben.

Besten Dank im Voraus,

Thorsten.
Mitglied: Antos
27.09.2010 um 16:34 Uhr
Hallo Thorsten72,

falls es da eine Lösung gibt bin ich auch brennend interessiert! Ich habe auch noch keine Möglichkeit gefunden, Nicht so schön aber machbar ist das mit dem Zeichen "in" ala:
...where=DATUM%3Din[DATUM1]%26DATUM%3Din[DATUM2]...
Also alle Datensätze mit Datum IN [DATUM1] und alle Datensätze IN [DATUM2] anzeigen.
mfg
Antos
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst SQL Reporting Services - Vergeben von Berechtigungen (3)

Frage von Sachellen zum Thema Windows Server ...

C und C++
gelöst IF Abfrage funktioniert nicht mehr (2)

Frage von pablovic zum Thema C und C ...

Router & Routing
Transparenter Proxy funktioniert nicht? (1)

Frage von mrserious73 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...