Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Abmeldescript

Frage Microsoft Windows Netzwerk

Mitglied: fabi2803

fabi2803 (Level 1) - Jetzt verbinden

31.03.2010 um 16:40 Uhr, 9379 Aufrufe, 11 Kommentare

Hallo,

Ich habe es bereits geschafft, ein Anmeldescript so einzubinden, dass es beim Anmelden ausgeführt wird. Natürlich habe ich dieses Script auch bei dem Benutzer unter Profil / Anmeldescript eingetragen. Das funktioniert auch so weit.

Ich möchte aber jetzt ein Abmeldescript erstellen. Leider funktioniert es nicht, wenn ich es nur in der Gruppenrichtlinienverwaltung unter Loginscript (selber erstellt) / bearbeiten / Benutzerkonfiguration / Windows-Einstellungen / Scripts (Anmelden/Abmelden) / Anmelden eintrage. Bei der Active Directory-Bentzer und -Computer /Benutzer finde ich nirgens ein Feld wo ich dieses Script eintragen könnte.

Wo muss dieses Abmeldescript (Batch Datei) eingetragen werden, damit es beim Abmelden des Benutzers ausgeführt wird?

Danke im voraus für eure Hilfe!
Mitglied: Edi.Pfisterer
31.03.2010 um 16:47 Uhr
Hallo!
Deine Gruppenrichtlinienverwaltung teilt sich in computer- und Benutzerverwaltung

Je nachdem, wann Dein Script ablaufen soll und für wen trägst Du es entsprechend als Abmeldescript ein.
im Detail:
Benutzerkonfigruation/Windows-Einstellungen/Skripts/Abmelden

Unter AD Computer und Benutzer wirst du NIEE eine Gruppenrichtlinie sehen, sondern ausschliesslich in der Gruppenrichtlinienverwaltungskonsole..

Ich sehe Dein Problem leider nicht, versuch nochmal, etwas Klarheit in Deine Frage zu bringen...
weil:
Ich möchte aber jetzt ein Abmeldescript erstellen. Leider funktioniert es nicht, wenn ich es nur in der Gruppenrichtlinienverwaltung unter Loginscript (selber erstellt) / bearbeiten / Benutzerkonfiguration /
Windows-Einstellungen / Scripts (Anmelden/Abmelden) / Anmelden eintrage
gibt ja keinen Sinn!
ABmeldeskript bei Abmelden, ANmeldeskript bei Anmelden!
NUR: so, wie Du das hier schreibst, ist es sinnfreies Kauderwelsch...
Sorry!

lg
Bitte warten ..
Mitglied: fabi2803
31.03.2010 um 17:41 Uhr
Hallo,

Irgendwie habe ich das ganze etwas vertauscht!

Für das Anmeldescript gibt es ja zwei Möglichkeiten:

1. Dem Benutzer auf dem Reiter Profil zuteilen

2. In der Gruppenrichtlinienverwaltung ein neues Gruppenrichtlinienobjekt erstellen und in der Benutzerkonfiguration "Anmelden" anklicken und optimieren.

Weg zwei funktioniert leider nicht. Deshalb verwende ich Weg 1.

Ich möchte, dass beim Abmelden von einem bestimmten Benutzer ein Script ausgeführt wird.

Kann man dies über Weg 1 realisieren? Oder muss man es mit Weg 2 angehen? Wenn ja, wie?

Danke im voraus!
Bitte warten ..
Mitglied: DerWoWusste
31.03.2010 um 17:48 Uhr
Hi.

Du musst Weg zwei gehen, Weg 1 gibt es nicht für Abmeldeskripte.
Dein Fehler könnte sein, dass Du dieses Skript nicht dem fraglichen Benutzerobjekt (d.h. der diesem Benutzer übergeordneten OU) zugeordnet hast, sondern stattdessen dem Computerobjekt.
Sollte das nicht der Fehler sein, führ einmal als fraglicher Benutzer den Befehl rsop.msc aus und lass Dir anzeigen, ob das Skript greifen SOLLTE. Wenn es dort nicht auftaucht, führ als Benutzer gpresult aus und schau, ob die fragliche Policy mit dem Skript ausgeführt werden müsste.
Bitte warten ..
Mitglied: Edi.Pfisterer
31.03.2010 um 17:50 Uhr
Hola!
DAS ist mal eine vernünftige Frage, die eine vernünftige Antwort mit sich bringt....
(hoffentlich zumindest...):

Dem Benutzer ein Abmeldeskript zuzuordnen im Profil geht nicht! (ausserdem: vergiss das! wie willst Du denn da eine vernünftige Verwaltung für mehr als 2 User hinbekommen....?

Die Frage muss lauten:
Warum funktioniert es bei Dir über die Gruppenrichtlinie nicht?
Meine Anwort (ich rate einfach mal, habe aber sehr wahrscheinlich recht...):
Du versuchst, dieses Gruppenrichtlinienobjekt in einer Organisationseinheit einzurichten, in der es keine Benutzer gibt!

btw:
Gruppenrichtlinienobjekte funktionieren weder in der voreingestellten OU Computers und Benutzer, dh, Du musst zuerst eine eigene Organisationseinheit einrichten, anschliessend die Benutzer dorthin verschieben und dann wirds auch laufen

lg und gutes gelingen
Edi

[edit: ich tippe zu laaaaanggggsssaaaaammmmm
SCHNORCH ]
Bitte warten ..
Mitglied: DerWoWusste
31.03.2010 um 17:53 Uhr
@urobe73:
...in der voreingestellten OU Computers und Benutzer...
...weil das gar keine OUs sind, sondern Container, auf die bekanntlicherweise keine GPOs gelinkt werden können.
Bitte warten ..
Mitglied: fabi2803
31.03.2010 um 19:33 Uhr
Hallo,

Wenn ich mich auf meinem Server Computer anmelde, dann greift das Anmeldeskript!
Ich musste es auf einem anderen Computer wieder entfernen damit ich mich bei meinem Server wieder anmelden konnte!

Wenn ich rsop.msc eingeben greifen die Einstellungen, jedoch ist bei Benutzerkonfiguration ein kleines gelbes Dreieck.
Wo kann ich den Benutzer einer OU zuordnen? Ich glaube nämlich, dass das Skript einem Computerobjekt zugeordnet ist!

Danke im voraus für die weitere hilfe!

edit: Wenn ich gpresult ausführe kommt bei angewendete Gruppenrichtlinienobjekte folgende Meldung:

Die folgenden Gruppenrichtlinie werden nicht angewendet, da sie gerausgefiltert wurden.

Loginskript
Filterung: Nicht angewendet (Leer)
Bitte warten ..
Mitglied: Edi.Pfisterer
31.03.2010 um 20:19 Uhr
@DerWoWusste:
bekanntlich
würde ich in diesem Fall wohl eher nicht verwenden

Hallo Fabi!
Mir scheint, Du zäumst das Pferd doch etwas von hinten auf...

Verschaff Dir mal einen Überblick, wie Gruppenrichtlinien grundsätzlich arbeiten....
dann kannst Du dich mit diesen Skript herumschlagen.

Nur noch soviel:
Organisationseinheiten musst Du in AD Computer und Benutzer einrichten.
Diese siehst Du dann auch in der Gruppenrichtlinienverwaltung.

Weiters kannst Du dann noch die jeweilige Richtlinie für alle in der OU befindlichen Objekte (Benutzer oder Computer) laufen lassen oder filtern, dh einer Gruppe / einzelnen Objekten zuweisen.

Such mal im Web, da finden sich sicher unzählige Seiten, mit denen man einen guten Überblick über die Materie gewinnt, bevor Du dich an die Details heranwagst...

lg
Bitte warten ..
Mitglied: fabi2803
01.04.2010 um 12:10 Uhr
Hallo,

Ich habe jetzt eine neue Organisationseinheit erstellt und die Benutzer in diese verschoben, und das Gruppenrichtlinienobjekt "Loginskript" mit dieser Organisationseinheit verknüpft. Die Einstellungen habe ich natürlich auch vorgenommen.

Wenn ich mich bei meinem Server Computer z.B. mit dem Benutzernamen "Test" anmelde (liegt in dieser Organisationseinheit), dann wird alles so ausgeführt, wie es in der .bat Datei steht. Der Server Computer übernimmt also alles sofort.
Der Client aber macht nichts anders als zuvor! Bei gpresult wird nicht mehr "herausgefiltert" angezeigt.

Wo liegt hier der Fehler? Gibt es hier eine Wartezeit über 1 Stunde? Oder muss ich bei meinem Client noch etwas verknüpfen?

Danke im voraus für eure weiteren Antworten!
Bitte warten ..
Mitglied: DerWoWusste
01.04.2010 um 13:07 Uhr
Sorg dafür, dass Du die Grundregel "GPOs mit Usereinstellungen wirken nur auf User - nicht auf Computer" verstehst. Ob Server oder Client ist Wurst, sofern der selbe Benutzer angemeldet wird, muss das Logonskript bei beiden laufen.
Bitte warten ..
Mitglied: Edi.Pfisterer
01.04.2010 um 13:11 Uhr
Ich wiederhole mich nur ungern, aber:
lies dich mal in das thema ein, was Du da versuchst, hat wirklich wenig sinn, da dir der überblick gänzlich zu fehlen scheint...
(sorry für die harten Worte).

also:
trotzdem ein Versuch einer Antwort:
1.) Server Computer gibt es nicht! entweder Client oder Server (der Vollständigkeit noch Memberserver), für irgendetwas musst Du dich entscheiden.
1a) Gruppenrichtlinien wirken nur auf Clients, die Mitglied in deiner Domäne sind (vielleicht scheitert es ja hier schon bei Dir...)
2.) es muss sinnvollerweise LOGOFFSKRIPT heissen
3.) benutzereinstellungen wirken auf benutzer in einer OU, computereinstellungen wirken auf computer in einer OU
4.) es gibt keine wartezeiten! mit gpupdate /force kann man gruppenrichtlinien sofort erneueren, nicht erst beim nächsten reboot bzw. anmeldevorgang

gutes gelingen
Bitte warten ..
Mitglied: fabi2803
02.04.2010 um 10:15 Uhr
Hallo,

Als ich den Test gpresult am Client ausführte, kam die eindeutige Meldung, dass das Gruppenrichtlinienobjekt angewendet wird.
Danach dachte ich mir, ich probiers noch einmal mit rsop.msc am Client. Und da fiel mir der Fehler auf, dass ein Windows Verzeichnis angegeben war. Es wurde auch nur am Server ausgeführt, weil der Client die Datei nicht finden konnte, wenn sie sich auf der Festplatte im Windows Verzeichnis des Servers befand!
Die Batch Datei selbst befand sich aber im Netlogon Verzeichnis und der Pfad wurde immer abgeändert. Vielleicht dadurch, dass ich nicht durch Windowsnetzwerke / Mydomain / server / Netlogon gegangen bin, sodern gleich in der Netzwerkumgebung auf Netlogon klickte!

Trotzdem vielen Dank für eure Hilfe!
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (24)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Erkennung und -Abwehr
Spam mit eigener Domain (12)

Frage von NoobOne zum Thema Erkennung und -Abwehr ...