Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Access 2003, Datensatz wird zerstört nach setzen v. Hyperlink (japanische Schriftzeichen)

Frage Entwicklung Datenbanken

Mitglied: Claude

Claude (Level 1) - Jetzt verbinden

19.05.2008, aktualisiert 11.06.2008, 13002 Aufrufe, 9 Kommentare

Problem war bei Access97 nicht vorhanden. Erst nach der Konvertierung nach Access2003 ist dieses Verhalten aufgekommen (aber nicht bei jedem Datensatz)

Bei einer Access2003 Datenbank (User benutzen die Runtime) haben wir das Problem, dass nach dem Setzen eines Hyperlink der betroffene Datensatz plötzlich zerstört wird, und die Felder mit japanische(?) Schriftzeichen belegt werden, siehe Bild (oberster Datensatz). Danach stürzt Access ab.
Das Setzen der Hyperlinks wird durch eine Klassenmodul "FileOpen" (API-Funktionen) ausgeführt. Benutze ich auch in andere Access97 UND 2003 Datenbanken. Ich denke nicht, dass das der Grund des Problems ist.

0dee74a6fe475be2bd34a524a8d20bad-080514_rekla_datenbank_japanisch_und_fehlermeldung - Klicke auf das Bild, um es zu vergrößern

88dd309b060bc33468a2a989849467cb-080514_rekla_datenbank_japanisch_und_fehlermeldung3 - Klicke auf das Bild, um es zu vergrößern

Hatte jemand ein ähnliches Problem? Wie würde dies gelöst?

Weitere Hinweise: Die Access-Runtime liegt auf 6 CITRIX-Server (Windows 2000 Server). Auf diesen 6 Server liegt auch noch die Access Runtime97, da noch nicht alle Datenbanken konvertiert sind. Als Office Version ist 2003 installiert.

Vielen Dank für Hinweise.

Hier noch ein Bild vom Hyperlink in der Tabelle:
27fbb2ca69c9189ca579f6a88aae2540-administratoren_de_3 - Klicke auf das Bild, um es zu vergrößern

Weitere Hinweise:
- Nach diesem Vorkommen lässt sich der Datensatz nur noch mühsam löschen (diverse Fehlermeldung)
- Gelinkt wurde in diesem Beispiel auf ein "normales" HTML-Dokument. Die Länge des Verzeichnisses inkl. Dateiname übersteigt nicht 255 Zeichen:
P:\95\Presswerk\VT000159_987 C7_Seitenw aussen li\04_Qualitaet\04-05_Kundenreklamationen\2008_2009\0447_V03554\CR.htm

Mit freundlichen Grüßen
claude
Mitglied: SvenGuenter
21.05.2008 um 16:51 Uhr
Du hast nicht nur da ein Problem wenn du weiter rechts schaust siehst du das Neckersulm auch mit einerm Steuerzeichen versichen wird. Es scheint das im html dokument welches du wohl auswertest irgendwelche steuerzeichen sind die dir dein Programm aushebeln. Schaue dir mal genau das Dokument an ob da irgendwelche Ungereimtheiten drin auftauchen.


Gruß

Sven
Bitte warten ..
Mitglied: Claude
21.05.2008 um 17:08 Uhr
Hallo Sven,

Ja klar, es werden mehere Felder zerschossen (ca 10 Felder). Werde mal das HTML durchsuchen. Die gleichen HTML-Dokumenten haben wir aber in Access97 schon verlinkt. Haben kein Schaden angerichtet.
Danke Mal. Melde mich wieder.

Gruss
claude
Bitte warten ..
Mitglied: Claude
21.05.2008 um 17:12 Uhr
Hallo, hiermal den Quelltext des HTML-Dokuments. Ich kann nichts besonderes erkennen (kein Javascript oder so, ..... ausser die auskommentierte URL, die auf ein JSScript verweist):

<!DOCTYPE HTML PUBLIC " -W3CDTD HTML 4.0 Transitiona lEN">
<!-- saved from url=(0061)https:
extra.EineFirma.com/portal/cr/crprintable.jsp -->
<HTML><HEAD><TITLE>CR</TITLE>
<META http-equiv=Content-Type content="text/html; charset=iso-8859-1"><LINK
href="CR-Dateien/style.css" type=text/css rel=StyleSheet>
<META http-equiv=pragma content=no-cache>
<META http-equiv=expires content="Wed, 26 Feb 1997 08:21:57 GMT">
<META content="MSHTML 6.00.2800.1505" name=GENERATOR></HEAD>
<BODY bottomMargin=0 leftMargin=0 topMargin=0 rightMargin=0 marginheight="0"
marginwidth="0"><BR>
<TABLE class=rborder cellSpacing=0 cellPadding=0 width=645 align=center
border=0>
<TBODY>
<TR>
<TD colSpan=5><!-- outer table -->
<TABLE cellSpacing=1 width="100%" border=0>
<TBODY>
<TR>
<TD vAlign=top>KundeName<BR>P.O. Box<BR>Land PLZ
Ort<BR><BR>
</TD><!--
<td valign="top" align="left">&nbsp;<h1>Quality Complaint Report&nbsp;Nr:&nbsp;820071</h1>&nbsp;Bemerkung
-->
...
usw...
...
<TR>
<TD vAlign=top align=left width="100%"
colSpan=4>&nbsp;</TD></TR></TBODY></TABLE><!-- outer table end --></TD></TR></TBODY></TABLE></BODY></HTML>
Bitte warten ..
Mitglied: Claude
21.05.2008 um 17:24 Uhr
Hallo Sven,
Wir werten das Dokument nicht aus, sondern verknüpfen es nur via Hyperlink.
Gruss
claude
Bitte warten ..
Mitglied: Claude
03.06.2008 um 17:57 Uhr
Hallo da draussen.....
Hat wirklich niemand eine Idee?
Gruss
claude
Bitte warten ..
Mitglied: SvenGuenter
09.06.2008 um 12:50 Uhr
Sorry für die späte anwort.
Also folgendes. Nur damit ich das richtig sehe.

Ihr habt irgendwo auf Servern htmldokumente, welche Ihr auslest und in die Datenbank übernehmt. Sehe ich das so richtig?

Wenn ja ist es foglendermaßen das die Mitarbeiter aus Neckersulm sich nicht an die Dateivorgaben halten. Dies solltest du mal prüfen. Dein Programm kann nur einen gewissen Datensatz lesen.

Eine Info hätte ich noch an Dich. Sprich Valmet drauf an, ob ihr den Transfer nicht als xml file machen könnte. Das machen wir hier auch und wir sind auch Automotive Supplier ;o)

Mit einem xmlfile hast du nicht so diese formatprobleme und ausserdem einen Standard der heutzutage eigentlich nur noch genutzt werden sollte.

Gruß

Sven


-----------edit
vielleicht solltest du in Zukunft Namen und Firmendaten rausnehmen oder ändern, da sowas in die Hose gehen kann .

Gruß

Sven
Bitte warten ..
Mitglied: Claude
09.06.2008 um 12:57 Uhr
Hallo Sven,

Wir lesen von diesem Dokument keinerlei Daten ein: Es wird NUR ein Hyperlink auf das HTML-Dokument gesetzt, sonst nichts. Es Erfolgt daher auch kein Transfer.
Theoretisch gibt's daher keine Berührung zwischen dem Inhalt der Datei und der Datenbank.

Gruss
claude
Bitte warten ..
Mitglied: SvenGuenter
11.06.2008 um 15:11 Uhr
Wie kommen denn deine Daten in die mdb hinein? und poste mal bitte den hyperlink wie der aussieht.

gruß

sven
Bitte warten ..
Mitglied: Claude
11.06.2008 um 16:35 Uhr
Hallo Sven,
Das wüsste ich auch ganz gern!!!!!.
Du weisst ja selber was User alles hinkriegen. Mittlerweile vermute ich sogar, dass versucht wurde irgenwie die Datei einzufügen. Ist auch bisher nicht mehr passiert.
Oben habe ich ein Bild von einem Hyperlink aus der gleichen Tabelle abgebildet. Leider habe ich die Tabelle mit dem defekten Datensatz nicht mehr....

Mit freundlichen Grüßen
claude

PS: Ich denke wir werden es nicht herausfinden, ... ausser es ist jemand da draussen, der auch so ein Fall hatte. Dann können Parallelen gezogen werden (Betriebsystem, SPack, MDAC, usw...)
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Datenbanken
gelöst Datensatz hinzufügen, nicht überschreiben Access (19)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Datenbanken
gelöst Access mit VBA vorgefertigte Texte an Datensatz anfügen (4)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Datenbanken
gelöst Datensatz mit 2 Felder anfügen Access (2)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Batch & Shell
CMD cURL Access Token parsen (2)

Frage von maddig zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...