Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Access 2010 auf Server 2012 sehr langsam

Frage Microsoft Microsoft Office

Mitglied: spiky123

spiky123 (Level 1) - Jetzt verbinden

18.02.2014 um 14:11 Uhr, 3705 Aufrufe, 2 Kommentare

Hallo Zusammen,
ich habe vor kurzem eine Server-Umstellung von 2003 auf 2012 vorgenommen. Auf dem neuen Server wurde auch die Access 2010 32-bit installiert. Die Hauptanwendung ist eine Access-basierende Gießerei-Software (Gussinfo von SD). Vor der Umstellung lief die Anwendung unter Access 2000 relativ geschmeidig. Auf dem neuen Server unter Access 2010 läuft die Anwendung grottenlangsam.
Die Access-DB wurde vom Software-Anbieter nicht konvertiert.

Konfiguration:

Intel Server 2 x XEON E5-2420 CPU je 6 Kerne
64MB RAM
4 SAS-Festplatten im RAID 5-Verbund

Die Netzwerkverbindung spielt keine Rolle da ich die Anwendung direkt am Server gestartet habe. Das Festplatten-System scheidet als Problem auch aus, da ich es testweise durch eine schnelle SSD ersetzt habe und die gleichen Antwortzeiten erhielt. Ich vermute, dass das Access die Prozessoren nicht richtig ausnutzt. Kann man irgendwo einstellen, dass Access alle Prozessorkerne benutzt? Wie lässt sich die Performance erhöhen?

Vielen Dank im voraus und schöne Grüße aus Essen
Ralf
Mitglied: colinardo
18.02.2014, aktualisiert um 14:45 Uhr
Hallo Ralf,
64MB RAM
das ist wohl ein Typo, sonst würde bei mir glatt die Glühbirne durchbrennen
Versuch mal das Problem durch Verwendung des ProcessMonitor ausfindig zu machen, vielleicht kannst du damit den oder die Störenfriede ausfindig machen.
Liegt die DB auf einem Netzlaufwerk ?
Die Access-DB wurde vom Software-Anbieter nicht konvertiert.
Was sagt den der Hersteller zu deiner Konfiguration, hast du das ganze auch schon mal z.B. Testweise in einer VM getestet ob es dort auch auftritt ?

Grüße Uwe
Bitte warten ..
Mitglied: Pjordorf
18.02.2014 um 17:47 Uhr
Hallo,

Zitat von spiky123:
ich habe vor kurzem eine Server-Umstellung von 2003 auf 2012 vorgenommen
Dann weisst du ja sicherlich auch was du alles damit geändert hast, oder? Server 2012 ist doch ein klein wenig anders als ein Server 2003

eine Access-basierende Gießerei-Software (Gussinfo von SD).
Unterstützt der Hersteller deine Variante so?

Anwendung unter Access 2000 relativ geschmeidig.
?!?. Wie meinen?

Auf dem neuen Server unter Access 2010 läuft die Anwendung grottenlangsam.
Und du willst jetzt den Knopf gesagt bekommen mit dem das Universum explodiert?

Die Access-DB wurde vom Software-Anbieter nicht konvertiert.
?!?. Was müssen wir uns unter dieser Aussage vorstellen? Läuft jetzt deine alte MDB Datei ohne Änderung oder konvertierung direkt 1:1 mit Access 2010 (32 Bit oder 64 Bit?) auf einen Server 2012R2? (Ob jetzt mit oder ohne R2 ist eigentlich wurscht).
IPv6 Deaktiviert?
IPv6 Aktiviert?
IPv6 Adressen angepasst?
IPv6 fähige Router bzw. Switche oder andere Kompontenten welche in dein uns unbekanntes Szenario laufen sollen muss und tut?
IPv4 Deaktiviert?
IPv4 Aktiviert?
WINS ersetzt bzw. neu installiert bzw. deinstalliert bzw. Einstellungen angepasst?
DNS auch alles geändert bzw. angepasst bzw. eingestellt wie beim WINS?
NETBIOS Namen alle auf FQDNs umgestellt welche vielleicht in deiner Aceess 2000 MDB genutzt werden?
Freigabename welche in deiner Access 2000 MDB noch genutzt werden angepasst bzw. korrigiert?
IP Adressen ebenso angepasst was deine Access 2000 MDB betrifft?
Wennn Namensauflösung (DNS und NETBIOS weil deine Access 2000 MDB) sowie IPv4 und IPv6 nicht das problem darstellen, prüfen ob alle Abhängigkeiten eingebundenen Module und DLL's deiner Access 2000 MDB vorhanden sind und genutzt werden können. Etliche DLLs werden nicht unter einem Server 2012 (R2) auch nur Ansatzweise laufen wollen.....

Und wenn du keinen Quellcode deiner Access 2000 MDB hast, bleibt dir nur abzuwarten und zu glauben was dein Hersteller der Applikation dir sagt....

64MB RAM
Halte ich auch für einen Vertuppser ähhh Vertippser...

Die Netzwerkverbindung spielt keine Rolle da ich die Anwendung direkt am Server gestartet habe.
Na, wenn du dich da mal nicht täuscht. Dir scheint nicht bewusst zu sein was alles auf einen Server 20xx von einen Netz und dessen Adapter abhängig ist und was passiert oder besser gesagt was eben nicht passiert wenn keine IP dem System mitgegeben werden kann....

Das Festplatten-System scheidet
Na, dann bleibt ja nur noch dein RAM mit 64 MB oder die Zwei CPUs als Fehlerquelle übrig....

vermute, dass das Access die Prozessoren nicht richtig ausnutzt.
Access 2000 bestimmt nicht.

dass Access alle Prozessorkerne benutzt?
Gut das diese Schalter schon von MS so unter der Hube eingebaut wurden das auch ein Tuning Feak da nicht dran kommt....

Wie lässt sich die Performance erhöhen?
Zum System die passende Umgebung und darin die passende Software passend zum System...

Gruß,
Peter
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Access 2010 Kommastelle wird falsch angezeigt

Frage von tdkcbundi zum Thema Microsoft Office ...

KVM
HDD IO sehr langsam auf Server (6)

Frage von itschloegl zum Thema KVM ...

Hyper-V
Server 2016 und Server 2012 (1)

Frage von KellogsFR zum Thema Hyper-V ...

Datenbanken
gelöst Access 2010 Filter zurücksetzen (6)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Neue Wissensbeiträge
Sicherheit

How I hacked hundreds of companies through their helpdesk

Information von SeaStorm zum Thema Sicherheit ...

Erkennung und -Abwehr

Ccleaner-Angriff war nur auf große Unternehmen gemünzt

(10)

Information von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Sicherheit

Eventuell neue Lücke in Intels ME

Information von sabines zum Thema Sicherheit ...

Heiß diskutierte Inhalte
Humor (lol)
Freidach Beitrag (36)

Frage von Penny.Cilin zum Thema Humor (lol) ...

Windows 7
SSD - Win7 Lags (19)

Frage von ph5555 zum Thema Windows 7 ...