Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Access-Ausdruck: ungewünschte Leerzeichen bei str()

Frage Entwicklung Datenbanken

Mitglied: stoperror

stoperror (Level 1) - Jetzt verbinden

19.05.2005, aktualisiert 20.05.2005, 7003 Aufrufe, 5 Kommentare

Habe ich das im Feld einer Abfrage eingefügt (damit soll ein Feld mit Namen Url befüllt werden)
Ausdr2: "http://blubber.de/mainframe.jsp?gid=;+Str"([content.gebaeude_id])+"&rid="+Str([content.raum_id])+"&aid="+Str([content.angebots_id])

Dann kommt im Feld selbst:

http://blubber.de/mainframe.jsp?gid= 1&rid= 2&aid= 3

Also jedesmal vor der Zahl ein Leerzeichen. Wie krieg ich das weg? Danke schonmal im Voraus.
Mitglied: Atti58
19.05.2005 um 15:56 Uhr
... versuch's mal mit "LTrim", "RTrim" oder einfach "Trim"

Gruß

Atti
Bitte warten ..
Mitglied: stoperror
20.05.2005 um 12:28 Uhr
Das mit Trim funktioniert auch nicht.

Glätten("http://www.blubber.de/mainframe.jsp?gid=" & Str([tabelle.id])+"&rid=" & Str([tabelle2.id]) & "&aid=" & Str([tabelle3.id]))

Liefert (Leerzeichen = _ )

http://www.blubber.de/mainframe.jsp?gid=_id1

Auch der Testausdruck:
Ausdr4: "text" & Str(1) & "Hallo"

liefert text_1Hallo

Das scheint dann wohl an der str() - Funktion zu liegen...
Allerdings bekomme ich auch durch Klammern danach und Glätten um den Gesamtausdruck das Leerzeichen immer noch nicht weg.

Weiss jemand eine Lösung?

Es handelt sich um Access 2003
Bitte warten ..
Mitglied: Atti58
20.05.2005 um 12:52 Uhr
... das liegt daran, dass die erste Position für ein "+" oder "-" reseviert wird ... Verwende einfach diesen Ausdruck:

"http://blubber.de/mainframe.jsp?gid=;+Format"([content.gebaeude_id])+"&rid="+Format([content.raum_id])+"&aid="+Format([content.content_id])

... dann geht's ,

Gruß

Atti
Bitte warten ..
Mitglied: Atti58
20.05.2005 um 12:58 Uhr
... übrigens geht es mit "Trim" auch, man muss halt nur wissen, wo man das ansetzen muss ...

"http://blubber.de/mainframe.jsp?gid=;+Trim(Str"([content.gebaeude_id]))+"&rid="+Trim(Str([content.raum_id]))+"&aid="+Trim(Str([content.content_id]))

Gruß

Atti
Bitte warten ..
Mitglied: stoperror
20.05.2005 um 13:07 Uhr
Danke. Du bist mein Held )))!!
Bitte warten ..
Neuester Wissensbeitrag
Exchange Server

WSUS bietet CU22 für Exchange 2007 SP3 nicht an. EOL Exchange 2007

Tipp von DerWoWusste zum Thema Exchange Server ...

Ähnliche Inhalte
Datenbanken
gelöst Access 2010 Filter zurücksetzen (6)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Microsoft Office
gelöst Nach Office 2010 SP2 Update - Kein Sharepoint export zu Access möglich (1)

Frage von paddl82 zum Thema Microsoft Office ...

LAN, WAN, Wireless
Access Point (VLAN, Multi-SSID) legt Netzwerk lahm (6)

Frage von humbeldi zum Thema LAN, WAN, Wireless ...

Datenbanken
gelöst Access 2010 SQL Tabellen Datensätze einfügen (6)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Heiß diskutierte Inhalte
Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (17)

Frage von Driphex zum Thema Exchange Server ...

Batch & Shell
gelöst Batch xls nach aktuellem Datum auslesen und email senden (14)

Frage von michi-ffm zum Thema Batch & Shell ...

Backup
Datensicherung ARCHIV (12)

Frage von fautec56 zum Thema Backup ...