Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Access Bericht öffnen mit Paramaterübergabe

Frage Microsoft Microsoft Office

Mitglied: crack24

crack24 (Level 2) - Jetzt verbinden

13.05.2013 um 08:56 Uhr, 8425 Aufrufe, 5 Kommentare

Hallo,

ich habe eine Access 2003 DB von meinem Vorgänger, die ich bearbeite möchte.

Ich möchte einen Button erstellen, der mir auf Knopfdruck einen Bericht in der Vorschau anzeigt. Ich habe mal so angefangen

Private Sub Befehl26_Click()
DoCmd.OpenReport "Angebot Fax Frz", acViewPreview, , "AID= """ & Formulare!Angebot!AID & """"
End Sub

Es soll dann die ID des Angebots an den Bericht übergeben werden, damit genau dieser Datensatz angezeigt wird. Der Druckbutton ist nicht im Formular Angebot sondern in einem anderen Formular.

Ich bekomme beim Klick auf den Button immer die Fehlermeldung "Laufzeitfehler 424 - Objekt erforderlich". Irgendwas stimmt da mit der Where-Klausel nicht oder?

Gruß,
Oliver
Mitglied: SlainteMhath
13.05.2013 um 09:26 Uhr
Moin,

sieht eigentlich korrekt aus. Geht denn der Bericht auf, wenn du manuell den Filter direkt in den Bericht einträgst oder dem darunterliegenden Query einträgst?

lg,
Slainte
Bitte warten ..
Mitglied: crack24
13.05.2013 um 10:00 Uhr
Ich habe den Filter jetzt mal direkt in den Bericht eingetragen. Unter Eigenschaften-Filter: [AID]=[Formulare]![Angebot]![AID]

Wenn ich dann auf den Button klicke, fragt er noch einen Wert für ein Feld ab und dann sieht es so aus als ob der Bericht auf geht und direkt wieder zu geht. Das kann ich mir irgendwie nicht erklären.
Bitte warten ..
Mitglied: SlainteMhath
13.05.2013 um 10:04 Uhr
...fragt er noch einen Wert für ein Feld ab...
Das ist wohl das Problem. Evtl. Tippfehler? Oder ein Feld aus einem geshclossenen Formular?

Hast Du ActiveX Steuerelemente auf dem Report? Barcodes o.ä.? Evtl. wird hier eines nicht mir einem Wert gefüllt.
Bitte warten ..
Mitglied: crack24
13.05.2013 um 10:21 Uhr
Ich habe das Feld was noch abgefragt wurde gelöscht. Hat sich nichts geändert.

ActiveX oder Barcodes habe ich keine drauf. Der Bericht wurde vorher per Makro geöffnet, damit klappt auch alles. Aber weil Makros nicht mag wollte ich das Öffnen über VBA machen.

Im deutschen Access muß ich noch [Formulare]![Angebot]![AID] schreiben und nicht [Forms]![Angebot]![AID]? Oder kann man beides? Macht allerdings auch keinen Unterschied wenn ich das ändere.
Bitte warten ..
Mitglied: crack24
13.05.2013 um 13:59 Uhr
Jetzt hab ich es. Hochkomma war falsch, weil der Datentyp AutoWert ist und nicht Text.

So gehts jetzt
Private Sub Befehl26_Click()
DoCmd.OpenReport "Angebot Fax Frz", acViewPreview, , "[AID]= " & Nz(Forms!Angebot.AID, 0)
End Sub
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Access Problem beim Bericht erstellen (1)

Frage von terpeberi zum Thema Microsoft Office ...

Datenbanken
Access 2010 Sortierung im Bericht funktioniert nicht

Frage von Dr.Cornwallis zum Thema Datenbanken ...

SAN, NAS, DAS
gelöst Access Datenbank auf einer (Synology) NAS? (4)

Frage von garack zum Thema SAN, NAS, DAS ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
CNC Maschinen verlieren Netzwerkverbindung (kurioser Fehler) (22)

Frage von NoHopeNoFear zum Thema LAN, WAN, Wireless ...

Web Development
Aktuellen Mitarbeiter auf Homepage anzeigen (13)

Frage von alemanne21 zum Thema Web Development ...

Windows Server
solved Parameter Übergabe Terminal Server (9)

Frage von ThomasKern zum Thema Windows Server ...

Batch & Shell
Anfängerfragen - Powershell - Mailboxvertretung im Pulk einrichten (8)

Frage von Yoshimitsu zum Thema Batch & Shell ...