Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Access Bericht öffnen mit Paramaterübergabe

Frage Microsoft Microsoft Office

Mitglied: crack24

crack24 (Level 2) - Jetzt verbinden

13.05.2013 um 08:56 Uhr, 7856 Aufrufe, 5 Kommentare

Hallo,

ich habe eine Access 2003 DB von meinem Vorgänger, die ich bearbeite möchte.

Ich möchte einen Button erstellen, der mir auf Knopfdruck einen Bericht in der Vorschau anzeigt. Ich habe mal so angefangen

Private Sub Befehl26_Click()
DoCmd.OpenReport "Angebot Fax Frz", acViewPreview, , "AID= """ & Formulare!Angebot!AID & """"
End Sub

Es soll dann die ID des Angebots an den Bericht übergeben werden, damit genau dieser Datensatz angezeigt wird. Der Druckbutton ist nicht im Formular Angebot sondern in einem anderen Formular.

Ich bekomme beim Klick auf den Button immer die Fehlermeldung "Laufzeitfehler 424 - Objekt erforderlich". Irgendwas stimmt da mit der Where-Klausel nicht oder?

Gruß,
Oliver
Mitglied: SlainteMhath
13.05.2013 um 09:26 Uhr
Moin,

sieht eigentlich korrekt aus. Geht denn der Bericht auf, wenn du manuell den Filter direkt in den Bericht einträgst oder dem darunterliegenden Query einträgst?

lg,
Slainte
Bitte warten ..
Mitglied: crack24
13.05.2013 um 10:00 Uhr
Ich habe den Filter jetzt mal direkt in den Bericht eingetragen. Unter Eigenschaften-Filter: [AID]=[Formulare]![Angebot]![AID]

Wenn ich dann auf den Button klicke, fragt er noch einen Wert für ein Feld ab und dann sieht es so aus als ob der Bericht auf geht und direkt wieder zu geht. Das kann ich mir irgendwie nicht erklären.
Bitte warten ..
Mitglied: SlainteMhath
13.05.2013 um 10:04 Uhr
...fragt er noch einen Wert für ein Feld ab...
Das ist wohl das Problem. Evtl. Tippfehler? Oder ein Feld aus einem geshclossenen Formular?

Hast Du ActiveX Steuerelemente auf dem Report? Barcodes o.ä.? Evtl. wird hier eines nicht mir einem Wert gefüllt.
Bitte warten ..
Mitglied: crack24
13.05.2013 um 10:21 Uhr
Ich habe das Feld was noch abgefragt wurde gelöscht. Hat sich nichts geändert.

ActiveX oder Barcodes habe ich keine drauf. Der Bericht wurde vorher per Makro geöffnet, damit klappt auch alles. Aber weil Makros nicht mag wollte ich das Öffnen über VBA machen.

Im deutschen Access muß ich noch [Formulare]![Angebot]![AID] schreiben und nicht [Forms]![Angebot]![AID]? Oder kann man beides? Macht allerdings auch keinen Unterschied wenn ich das ändere.
Bitte warten ..
Mitglied: crack24
13.05.2013 um 13:59 Uhr
Jetzt hab ich es. Hochkomma war falsch, weil der Datentyp AutoWert ist und nicht Text.

So gehts jetzt
Private Sub Befehl26_Click()
DoCmd.OpenReport "Angebot Fax Frz", acViewPreview, , "[AID]= " & Nz(Forms!Angebot.AID, 0)
End Sub
Bitte warten ..
Ähnliche Inhalte
Datenbanken
Access 2010 Sortierung im Bericht funktioniert nicht

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Microsoft Office
Access Problem beim Bericht erstellen (1)

Frage von terpeberi zum Thema Microsoft Office ...

Windows Server
Sharepoint - öffnen im Windows Explorer geht nicht (5)

Frage von DerWoWusste zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows 7
gelöst BOOTMGR is missing (auch nach bootrec -RebuildBcd) (21)

Frage von Mipronimo zum Thema Windows 7 ...

Router & Routing
Tipps für Router (ca. 100 clients, VPN) (20)

Frage von oel-auge zum Thema Router & Routing ...

Windows Userverwaltung
Windows Freigabe: Zugriff auf alle Ordner trotz Sicherheitseinstellungen (18)

Frage von Pandreas zum Thema Windows Userverwaltung ...

Exchange Server
gelöst MS Exchange 2016 - Basicconfig Fragen (16)

Frage von maddig zum Thema Exchange Server ...