Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Access Fehlermeldung

Frage Microsoft Microsoft Office

Mitglied: severinbuob

severinbuob (Level 1) - Jetzt verbinden

13.07.2006, aktualisiert 17.07.2006, 19509 Aufrufe, 3 Kommentare

Hallo zusammen

Ich habe folgendes Problem... Wenn ich in meinem Formular ein Datensatz lösche, dann passiert folgendes. Es öffnet sich eine Messagebox in der steht "Der Suchschlüssel wurde in keinem Datensatz gefunden".

333b17af7e06105d3e8ba65165aee9ee-screenshot028 - Klicke auf das Bild, um es zu vergrößern



Wenn ich den Code debugge passiert folgendes:

7c013c87256590d29a2fc3cb5474c294-screenshot029 - Klicke auf das Bild, um es zu vergrößern



Wie kann ich diesen Fehler vermeiden?

Danke schon im voraus für eure Unterstützung!



Gruss
Severin
Mitglied: 25110
14.07.2006 um 10:47 Uhr
Das liegt vermutlich nicht am Code.

Der Suchschlüssel wurde in keinem Datensatz gefunden = Fehler 3709

Beschreibung:
Tritt auf, wenn eine ISAM SEEK ausgeführt wird und sich keine übereinstimmenden Werte im Index befinden.

Bedeutet, dass der Datensatz auf den zugegriffen wird korrumpiert ist. Versuch mal die Datenbank zu Komprimieren/Reparieren. Wenn das nicht hilft, die entsprechenden Tabellen in eine neue leere Datenbank importieren, Original-Tabellen löschen und aus der Neuen Datenbank wieder importieren.

Vorher die Original-DB sichern.

mfg
Bitte warten ..
Mitglied: severinbuob
17.07.2006 um 14:34 Uhr
Vielen Dank für deinen Tipp, hat super funktioniert!

Ich habe einfach alle Tabellen nochmals erstellt.
Aber woher könnte dieser Fehler kommen?

gruss
Severin
Bitte warten ..
Mitglied: 25110
17.07.2006 um 14:46 Uhr
Hallo,

ein Grund könnte die Definition der Primärschlüssel in den Tabellen sein.
Sollte man immer mit dem Typ AutoWert erstellen.

Oder Datenbank nicht sauber geschlossen.

mfg
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Microsoft Office
gelöst Access 2016 installieren bei bestehenden Home and Business 2016 (4)

Frage von Huibuh2010 zum Thema Microsoft Office ...

Datenbanken
gelöst Access 2010 Filter zurücksetzen (6)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Microsoft Office
gelöst Nach Office 2010 SP2 Update - Kein Sharepoint export zu Access möglich (1)

Frage von paddl82 zum Thema Microsoft Office ...

LAN, WAN, Wireless
Access Point (VLAN, Multi-SSID) legt Netzwerk lahm (8)

Frage von humbeldi zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (18)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Grafikkarten & Monitore
Neue Graifkkarte - kein Bild (10)

Frage von bestelitt zum Thema Grafikkarten & Monitore ...

Linux
gelöst Boot failed: not a bootable disk (10)

Frage von Fleckmen zum Thema Linux ...

Multimedia & Zubehör
gelöst Iphone 6 prob (8)

Frage von jensgebken zum Thema Multimedia & Zubehör ...