Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Access Formular - seltsame Datenstzduplikation bei Verwendung einer Abfrage

Frage Microsoft Microsoft Office

Mitglied: microstorm

microstorm (Level 1) - Jetzt verbinden

28.06.2007, aktualisiert 23:19 Uhr, 3136 Aufrufe, 4 Kommentare

Hallo,

hatte ein seltsames Problem mit Access.
Zur Nutzung verschiedener Tabellen in einem Formular wurde eine Abfrage erstellt und deren Felder für die Steuerelemente des Formulares verwendet.

Bei Nutzung des Formulares kam es dann zu einer seltsamen Erscheinung. Die in der Abfrage befindlichen Datensätze haben sich automatisch in Ihrer Gesamtheit Dupliziert und zwar so oft, wie Felder zur Verfügung stehen.

Kann jemand die Problematik beschreiben?

Vielen Dank im voraus.
Mitglied: jato11
28.06.2007 um 09:01 Uhr
Hallo Microstorm,
das Problem habe ich auch manchmal, dann ist die Abfrage noch nicht ganz richtig.
Achte auf die richtigen Verknüpfungseigenschaften.
Ich bruache meistens der Punkt 2 : "Beinhaltet alle Datensätze aus Tabelle1 und nur die
Datensätze aus Tabelle2, bei denen die Inhalte der Verknüpften Felder gleich sind.
Oder es kann auch an einem Unterformular liegen, wo unterschiedliche Daten enthalten sind.

Hast Du das Problem auch in der Abfrage (Datenblattansicht)

Viele Grüße
Torsten
Bitte warten ..
Mitglied: microstorm
28.06.2007 um 16:26 Uhr
Hallo Torsten,

ich habe das Problem gelöst.

Hintergrund ist die fehlende Beziehung zwischen den verwendeten Tabellen. Es muß definitiv eine feste "Verdrahtung" der Tabellen erfolgen.

Trotzdem vielen Dank für die schnelle Antwort!

Viele Grüße


Mirko
Bitte warten ..
Mitglied: jato11
28.06.2007 um 21:22 Uhr
Die Beziehung kannst Du auch innerhalb der Abfrage herstellen. Finde ich übersichtlicher

Viele Grüße
Torsten
Bitte warten ..
Mitglied: microstorm
28.06.2007 um 23:19 Uhr
...oder natürlich so...
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst Probleme beim Aufrug von Google Maps aus einem MS-ACCESS 2013 Formular (9)

Frage von CADastrophe zum Thema Microsoft Office ...

Datenbanken
gelöst Access 2010 Abfrage erster Werktag (10)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Neue Wissensbeiträge
Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Router & Routing

PfSense auf Supermicro Intel Xeon D-15x8 SoC Bare Bone

Tipp von Dobby zum Thema Router & Routing ...

Windows Server

Exchange 2010 auf Windows Server 2016 und AD

(2)

Tipp von Herbrich19 zum Thema Windows Server ...

KVM

How to: Libvirt Port forwarding

(2)

Anleitung von fundave3 zum Thema KVM ...

Heiß diskutierte Inhalte
Router & Routing
über Vmware auf eine FritzBox mit IPv6 per VPN (17)

Frage von Zockervogel zum Thema Router & Routing ...

Basic
Programmierung von Windows Programmen (8)

Frage von Ghost108 zum Thema Basic ...