Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Access Problem mit Autowert

Frage Microsoft Microsoft Office

Mitglied: etnobommel1989

etnobommel1989 (Level 1) - Jetzt verbinden

20.05.2010 um 11:34 Uhr, 4678 Aufrufe, 4 Kommentare

Tabelle: Mitarbeiter
---> Mitarbeiter_ID(Autowert), Name(Text), Vorname(Text), Kostenstelle(Zahl)

Hey Leute,

mein Problem ist nun, wenn ich einen Mitarbeiter lösche ist die vergebene Mitarbeiter_ID weg und wird nicht mehr neu vergeben. Gibt es eine Möglichkeit, dass wenn ich einen neuen Mitarbeiter anlegen will zuerst ein Autowert vergeben wird, der zwischendrin frei ist und erst dann wieder neue Nummern vergeben werden wenn alle Lücken ausgefüllt sind.
Geht sowas überhaupt zu realisieren?? Wenn nicht würde ich mich auch freuen wenn einer der es weiß sagt das es nicht funktioniert.


Danke
Mitglied: SlainteMhath
20.05.2010 um 11:37 Uhr
Moin,

nein geht nicht. Der Autowert zählt stur nach oben. Wenn Du sowas möchtest musst Du dir das selber programmieren.

lg,
Slainte
Bitte warten ..
Mitglied: etnobommel1989
20.05.2010 um 11:40 Uhr
Vielen Dank für die fixe Antwort

wie meinsten des mit selber programmieren??
Per VBA Code ???
Bitte warten ..
Mitglied: SlainteMhath
20.05.2010 um 11:47 Uhr
Per VBA Code ???
Ja, genau - Und gleich eins vorweg: das ganze ist in einer Mehrbenutzerdatenbank nicht ganz trivial - nein ich poste Dir dazu keinen Code
Bitte warten ..
Mitglied: etnobommel1989
20.05.2010 um 12:18 Uhr
Na ja gut okay. Hab ich auch nicht erwartet aber trotzdem danke!!
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Access Problem beim Bericht erstellen (1)

Frage von terpeberi zum Thema Microsoft Office ...

Batch & Shell
gelöst Dateinamen mit Batch-Datei ändern - Problem (9)

Frage von fffffuuuuuuuhhhh zum Thema Batch & Shell ...

Debian
Squid Proxyserver - HTTPS Problem (1)

Frage von Cartman zum Thema Debian ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...