Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Access XP - Sqlite Neue Daten werden nicht gleich angezeigt

Frage Microsoft Microsoft Office

Mitglied: AndyAh

AndyAh (Level 2) - Jetzt verbinden

28.11.2013 um 09:39 Uhr, 1860 Aufrufe, 1 Kommentar

Hi NG,

ich habe mit Access XP in Verbindung mit SQLite folgendes Problem:

SQLite Datenbank als ODBC-Verknüpfung (SQLite3 Treiber).
Neu eingegebene Daten werden als #GELÖSCHT angezeigt. Beim erneuten öffnen der Tabelle sind alle Daten wieder da.

Der Primäre Schlüssel ist ein Autowert als Integer, alle Anderen sind Testfelder.

Wo liegt mein Problem?

Gruß
Andy
Mitglied: colinardo
28.11.2013 um 21:45 Uhr
Hallo Andy,
das ist ein generelles Problem bei der Verwendung des SQLite ODBC Treibers und Access in Verbindung mit AutoWert-Feldern. Es scheint das es hier beim Wechsel zu einem neuen Datensatz ein Timing-Problem gibt, so dass beim Update des vorhergehenden Datensatzes noch kein AutoWert von Access generiert wurde, und daraufhin der ODBC-Treiber dieses Verhalten zeigt:

Abhilfe bringt das Vermeiden von AutoWert Feldern. Alternativ eine VBA-Prozedur das die Tabelle regelmäßig mit .Refresh aktualisiert.

Grüße Uwe
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Access 2010 Kommastelle wird falsch angezeigt

Frage von tdkcbundi zum Thema Microsoft Office ...

Microsoft Office
Automatischer Datenimport aus csv Datei in Access DB - Wo zu ändern? (1)

Frage von Mejestic12 zum Thema Microsoft Office ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Systemdateien
gelöst NTFS und die Defragmentierung (29)

Frage von WinLiCLI zum Thema Windows Systemdateien ...

Server-Hardware
Treiber für Server gesucht (15)

Frage von MeisterFuchs zum Thema Server-Hardware ...