Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Active Directory, Powershell cmdlet new-user, IIS, Single Sign On im Intranetportal: funktioniert nicht nach Skript, nur noch manuellem Anlegen von Benutzern

Frage Microsoft Windows Userverwaltung

Mitglied: Viprex

Viprex (Level 1) - Jetzt verbinden

01.08.2013, aktualisiert 11:48 Uhr, 2526 Aufrufe, 1 Kommentar

Hallo zusammen,

ich habe mir ein Powershellskript gebaut, welches Active Directory User in einer 2012'er Domäne anlegt.
Hier der relevante Codeschnipsel (das gesamte Skript ist riesig). Pfade und Variablen für hier eingekürzt bzw. anonymisiert:
01.
new-aduser -name "Test, Benutzer" -samaccountname "B.Test" -UserPrincipalName "b.test@domain.local" -AccountPassword (ConvertTo-SecureString -AsPlainText "meinPasswort" -Force)  -DisplayName "Test, Benutzer" -GivenName "Benutzer" -Surname "Test" -path "OU=Users,DC=domain,DC=local"
Ich lege also eine Reihe von Benutzern an und weise diesen zusätzlich einige Berechtigungsgruppen zu.

Jetzt ist es so, dass unser Intranetportal (Basierend auf Intrexx von United Planet) ein Single Sign On mittels des IIS7 durchführt. Dies funktioniert problemlos, wenn ich Benutzer manuell über die Active Directory GUI anlege.


Problem
Wenn ich Benutzer mittels Skript anlege, wird der Benutzer im Portal nicht mittels Single Sign On angemeldet.

Die (manuelle) Lösung ist, ein per Skript angelegten Benutzer über die AD GUI zu öffnen, jeweils den Benutzeranmeldenamen zu ändern (z. B. eine 2 hinten dran hängen), zu speichern und diese Änderung anschließend wieder rückgängig zu machen.

Hiernach kann sich auch der per Skript angelegte Benutzer normal über Single Sign On im Portal anmelden (lassen).


Was habe ich bisher probiert
Das Portal selbst bietet eine Batch Datei zum Debug eines Logins, welche allerdings für alle möglichen Kombinationen von Anmeldenamen ein Sucess ausgibt.

Ein Diff zweier Benutzer (einmal normal erzeugt, einmal per Skript) der Ausgabe von get-aduser ... properties * hat ergeben, dass natürlich einige Felder unterschiedlich sind, nicht aber solche wie useraccountcontrol oder samaccountype. Außerdem sind alle Felder, die beim manuell erzeugten Benutzer gefüllt sind, auch beim per Skript erzeugten Benutzer gefüllt.

Gruppenmitgliedschaften stimmen ebenfalls überein und sind ausreichend vorhanden.

Ein einfaches Öffnen und Speichern des geskripteten Benutzers reicht nicht aus, man muss schon den Benutzeranmeldenamen ändern und dann speichern (anschließend natürlich wieder rückgängig machen).

Auch ein VBSkript, welches ich letztes Jahr geschrieben hatte, zeigte genau dieses Verhalten. Der Hersteller des Portals ist bisweilen auch ratlos, da die login debug Batchdatei ja ein erfolgreiches einloggen ausgibt.


Und was nun?
Ich habe leider keine weitere Idee, wo ich noch gucken kann oder was die GUI evtl. anders macht als mein Skript. Ich suche den Fehler zur Zeit auch nicht im Portal, sondern eher am IIS oder fehlenden Attribut Einträgen des AD Users.

Gibt es etwas, was ich prüfen kann, um hier einen Schritt weiter zu kommen?

Systemeckpunkte
Intranetportal basierend auf Intrexx von United Planet auf einem Windows Server 2008 R2, eine MS SQL 2008 DB und als Webserver dem IIS7 mit aktivierter Windows Authentifizierung
Active Direcory 2012
Powershell mit AD Erweiterung
Clients: Bunt gemischt, von Win XP bis Win 8 ist alles dabei. Browser: IE8 bis IE11, aber auch Firefox (kann auch das SSO wenn man es ihm sagt)
Alles im internen Netzwerk


Vielen Dank für eure Hilfe.

PPS: Leider kann ich nur ein Thema auswählen, obwohl hier gleich eine ganze Reihe von Themen betroffen sind (Powershell, Active Directory, IIS, Single Sign On). Falls jemand der Meinung ist, ich hätte in einem anderen Themenbereich mehr Erfolg, bitte ich um kurzen Hinweis.
Mitglied: Viprex
09.08.2013 um 16:29 Uhr
Hallo nochmal,

ich bin wirklich über jeden noch so kleinen Tipp und Hinweis dankbar, wo ich noch suchen sollte. Gibt es denn unter den knapp 500 Lesern dieses Beitrags niemanden, der irgendeinen Tipp für mich hat? Ich freue mich wirklich über Hilfe jeder Art zu diesem Thema!

Viele Grüße und vielen Dank im voraus für das Lesen und evtl. auch Beantworten dieses Beitrags.
Bitte warten ..
Neuester Wissensbeitrag
Windows Update

Windows Update-Suche nach Win7 Neuinstallation wieder schneller

(2)

Erfahrungsbericht von the-buccaneer zum Thema Windows Update ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Hyper-V
gelöst Reiner Hyper- V Server oder lieber Rolle (22)

Frage von Winuser zum Thema Hyper-V ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

SAN, NAS, DAS
gelöst Synology Version 6.1 Probleme (18)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...

Router & Routing
gelöst IP Kamera für drei unabhängige Netzwerke (16)

Frage von ProfessorZ zum Thema Router & Routing ...