Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Active Server Sync mit SSL und Windows Mobile 5.0

Frage Microsoft Exchange Server

Mitglied: hercules123

hercules123 (Level 1) - Jetzt verbinden

30.01.2006, aktualisiert 31.01.2006, 12181 Aufrufe, 7 Kommentare

Hallo,

bin neu in diesem Forum und möchte gerne mein kleines Problem schildern.

Ich betreibe einen SBS 2003 Server an fester IP und Domäne und nutze die Windows Mobile 5.0 Serversyncfunktionen.

Da ich mir nun ein echtes Zertifkat gekauft habe, möchte ich dieses auch beim synchronisieren benutzen.
Leider habe ich keine Ahnung, wie ich SSL für Active Sync einrichten muss.

Hier mal mein bisheriges Vorgehen:

-Erstellung des Anfoderungsprofils für ein Zertifikat
-Import und Installation dieses Zertifikats unter "Standardwebseite"
-Das Zertifikat wird in alle Virtuellen Verzeichnissen als gültig angezeigt

---Jetzt kommt bei Verzeichnissicherheit/SSL benutzen und 128BIT Verschlüsselung die Frage für welche Virtuellen Verzeichnisse man die Einstellungen benutzen will. Hier kommt mein erstes Problem, da ich nicht weiss wo genau SSL und 128BIT Verschlüsselung aktiv sein muss um mit SSL zu syncen.

-Im System Manager sind alle Mobile Access optionen aktiviert
-Unter Server/Protokolle/http/virtuelle HTTPServer ist Webform basierende Anmeldung aktiviert mit hoher Kompression.

-Auf dem MDA Vario ist Active-Sync-Exchange- Synchronisation aktiv und klappt auch perfekt OHNE SSL

Die Frage ist, wie stelle ich fest ob der PDA beim synchronisieren SSL nutzt? Wenn ich den Port 80 zumache, kommt "Warte auf Netzwerk" beim syncen. Müsste er da aber nicht den Port 443 benutzen und den 80er Port ausser Acht lassen?

Ich habe mich zu Tode gesucht im Netz nach Anleitungen für diese Themen, aber leider ohne Erfolg.

INteressant ist es für mich auch deswegen, weil ich auf dem Server den Port 80 eigendlich für Apache benötige, aber da Activesync nicht ohne Port 80 läuft, kann ich das im Moment nicht umsetzen.

Fragen über Fragen

Bin für jeden Tip sehr dankbar


Thomas
Mitglied: filippg
31.01.2006 um 00:46 Uhr
Die Frage ist, wie stelle ich fest ob der
PDA beim synchronisieren SSL nutzt?
Hallo, du könntest auf dem Server mal einen Sniffer installieren, z.B. Packetyzer. Ist auch sonst immer mal wieder ganz nützlich, um Fehlern auf dem Grund zu gehen. Der zeigt dir an, welches Protokoll verwendet wurde, und du erkennst es ja dann auch, wenn die Daten lesbar sind (zumindest die Header, die Nutzdaten werden wahrscheinlich nicht klartext sein).
Aber das mit Port 80 klingt schon ganz vernünftig, sprich: der sollte im Normal für HTTP (ohne SSL) verwendet werden, und dann kann nicht gleichzeitig auch SSL drüber laufen.

INteressant ist es für mich auch
deswegen, weil ich auf dem Server den Port
80 eigendlich für Apache benötige,
Apache lässt sich auch ganz einfach auf einem beliebigen anderen Port betreiben, kommt aber für dich nicht in Frage?

Filipp
Bitte warten ..
Mitglied: hercules123
31.01.2006 um 19:45 Uhr
Hallo,

Hallo, du könntest auf dem Server mal
einen Sniffer installieren, z.B. Packetyzer.

Ahja...den werde ich mal suchen

Aber das mit Port 80 klingt schon ganz
vernünftig, sprich: der sollte im
Normal für HTTP (ohne SSL) verwendet
werden, und dann kann nicht gleichzeitig
auch SSL drüber laufen.

Ja ich dachte auch, dass es hier nur ein entweder oder gibt. Bin mir nur nicht so sicher, ob der Kontakt mit dem Server nicht auf Port 80 aufgenommen wird und dann erst SSL verhandelt und auf Port 443 geswitcht wird

Apache lässt sich auch ganz einfach auf
einem beliebigen anderen Port betreiben,
kommt aber für dich nicht in Frage?

Generell ist mir der Port egal. Nur wird ja der Port 80 als Standard verwendet bei Webservern und wenn ich den ändere, müsste der Anwender ja die Portnummer zur URL mit angeben


Grüsse

Thomas
Bitte warten ..
Mitglied: filippg
31.01.2006 um 20:07 Uhr
Benutzt eigentlich das ServerSync den IIS? Dann müsstest du vielleicht da noch eine entsprechende Site konfigurieren.
Der bisherige Sync-Dienst müsste dann schon als Website eingerichtet sein, neben der Standardtwebsite. Richte für diese das Zertifikat ein, und stelle sie auf Port 443. Und wenns dann nicht geht solltest du nochmal deine Konfiguration auf dem MDA überprüfen, hier musst du SSL ja auch aktivieren.
Bitte warten ..
Mitglied: hercules123
31.01.2006 um 20:15 Uhr
ja, der Active-Server-Sync nutzt den IIS, indem ein vituelles Verzeichniss angelegt wird unter der Standardwebseite, dass den selben Namen trägt (ActiveServersync). Dieses ist mit dem Zertifikat versehen und mit SSL geschützt.

Auf dem PDA ist SSL aktiviert. Aber ich habe gerade mal das Tool runtergeladen und installiert. Dawird beim Connect des PDA´s der TCP Port 1236 genannt und der SSL Port 443.
Bitte warten ..
Mitglied: hercules123
31.01.2006 um 21:08 Uhr
Also dankPaketyzer sehe ich nun, dass SSL anscheinend geht. Es wird mir in Form von Source Port und Destination Port angezeigt!!

Aktiviere ich SSL auf dem Activesyncserver und auf dem MDA sieht es so aus

1235 -> HTTPS 443

Deaktiviere ich SSL auf beiden Seiten, sieht es so aus:

1235 -> HTTP 80

Was aber auffällt, ist das der ausgehende Port (hier 1235) sich immer ändert und hochzählt mit jedem Versuch!?

Es sieht irgendwie so aus, als würde der MDA auf beliebiegen Ports 12** rufen und dann vom Server auf 443 umgelenkt!? Das kann ja aber nicht sein, da meine Firewall diese Ports zu hat.

Aber, das eigendliche Problem ist das ich auch bei aktiviertem SSL den Port 80 nicht ändern darf!! Der MDAS meldet dann sofort einen Syncfehler oder ein "warte auf Netzwerk".

Wenn ich aber mit einem Browser direkt https://meinedomönde.de eingebe, funktioniert der Aufruf auch ohne den Port 80!
Nur die automatische Umlenkung auf Port 443 bei Eingabe von http:/ statt https: klappt dann nicht mehr, was ja aber logisch erscheint.

Bin leider immer noch ratlos...scheinbar connectet der MDA nicht direkt auf 443 den Server sondern auf 80...trotz aktiviertem SSL auf beiden Seiten.

GRÜEBEL
Bitte warten ..
Mitglied: filippg
31.01.2006 um 21:40 Uhr
Was aber auffällt, ist das der
ausgehende Port (hier 1235) sich immer
ändert und hochzählt mit jedem
Versuch!?
Das ist normal und in Ordnung. Der abgehende Port ist beliebig (d.h. sollte über 1024 liegen), gebraucht wird lediglich ein fester Port beim Empfänger (Server) zur Adressierung. Es wird ja dann bei jedem Paket mitgeteilt, wohin die Antwort zu gehen hat.



Aber, das eigendliche Problem ist das ich
auch bei aktiviertem SSL den Port 80 nicht
ändern darf!! Der MDAS meldet dann
sofort einen Syncfehler oder ein "warte
auf Netzwerk".
Sniffe hier nochmal mit, dann muss ja der MDA irgendwie erst an 80 rufen, was aber auch seltsam wäre (evtl. wird er von dort weitergeleitet). Aber versuche mal, das Paket, das von MDA an Port 80 geht zu fangen.
Und dann: vielleicht kannst du bei dem MDA einen Zielport angeben? Dort musst du ja auch irgendwo die Server-URL angeben, und evlt kannst du hier einfach einen Port mit anhängen (http://www.meinserver.de:80). Funktioniert nicht immer, aber manchmal.


Wenn der Apache auf Port 80 _ganz_ wichtig ist, dann kann man auch versuchen, diesen quasi als Proxy zu nutzen, so dass der MDA auf Port 80 an den Apache anfragt, dieser die Anfrage als vom MDA erkennt (-> ist ja ein bestimmtes virtuelles Verzeichnis) und Anfrage an den IIS weiterleitet (und ebenso andersrum dessen Antwort). Aber das ist keine schöne Lösung, da muss es schon sehr dringend sein.

Filipp
Bitte warten ..
Mitglied: hercules123
31.01.2006 um 22:03 Uhr
Ersteinmal danke für deine Hilfe

Also ich kann beim sniffen nur diesen besagten Aufuf entdecken, der an Port 443 geht.
Ich bin mir zwischenzeitlich auch sehr siche, dass SSL Sync geht, denn wenn ich das Zertifikat ändere auf dem IIS, dann kommt sofort eine Fehlermeldung beim syncen.

Ich vermute irgendwie, dass der MDA auf Port 443 connectet und dann intern im IIS weiter geleitet wid auf Port80!

Und genau hier entsteht das Problem. Wenn ich das richtig verstehe, arbeitet der Activesync mit dem OWA! Aber meine Hoffnung das eine Aktivierung von SSL beim OWA hilft funktionierte auch nicht.

Leider versteht der MDA diese Angabe nicht. Das hatte ich schon versucht. Auch mit IP angabe nicht
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
gelöst NTP Server auf einem Windows Server 2008 R2 DC standardmäßig schon drauf? (11)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Microsoft Excange Server 2007 auf Windows Server 2003 Installieren? (9)

Frage von Herbrich19 zum Thema Exchange Server ...

Windows Server
gelöst WSUS auf Server 2008 R2: Windows 10 wird als Vista angezeigt (2)

Frage von honeybee zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (27)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (20)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...