Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

ADM Template - IE XMLHTTP - Policy wird nicht angezeigt

Frage Microsoft

Mitglied: Viprex

Viprex (Level 1) - Jetzt verbinden

29.04.2010, aktualisiert 30.04.2010, 5785 Aufrufe, 1 Kommentar

Hallo,

ich habe erfolglos probiert, mein 1. eigenes ADM Template zu erstellen. Ziel ist es, die Einstellung "Original-XMLHTTP-Unterstützung aktivieren" im Internet Explorer (mindestens vorhanden ab Version 6) zu aktivieren. Dazu habe ich mir u.g. Template geschrieben. Das Template lässt sich bei mir Fehlerfrei importieren. Die Kategorien werden auch angezeigt, so wie ich es erwarte (Internet Explorer Internetsystemsteuerung - Seite Erweitert). Allerdings wird der Policy Eintrag nicht angezeigt. Ich habe das Template in einer komplett leeren GPO hinzugefügt (also alle anderen Vorlagen habe ich testweise entfernt).

Kann mir jemand sagen, was ich falsch mache? Vielen lieben Dank für die Hilfe.

01.
; ADM Template Creation/Modifying Date:29.04.2010 17:15 
02.
; ADM Template Author: Viprex 
03.
; Enable/Disable XMLHTTP Internet Explorer 
04.
 
05.
CLASS USER 
06.
	CATEGORY !!InternetExplorer 
07.
		CATEGORY !!EnableTabs 
08.
			CATEGORY !!AdvancedPage 
09.
			 
10.
				 
11.
				POLICY !!XMLHTTP 
12.
					EXPLAIN !!EnableXMLHTTP_Hlp 
13.
					KEYNAME "Software\Microsoft\Internet Explorer\Main" 
14.
					PART !!XMLHTTP CHECKBOX 
15.
					    VALUENAME "XMLHTTP" 
16.
						VALUEON NUMERIC 1 
17.
						VALUEOFF NUMERIC 0 
18.
				    END PART  
19.
				END POLICY ;XMLHTTP 
20.
				 
21.
			END CATEGORY ;AdvancedPage 
22.
		END CATEGORY ;EnableTabs 
23.
	END CATEGORY ;InternetExplorer 
24.
 
25.
[strings] 
26.
InternetExplorer="Internet Explorer" 
27.
EnableTabs="Internetsystemsteuerung" 
28.
AdvancedPage="Seite "Erweitert"" 
29.
XMLHTTP="Enable XMLHTTP" 
30.
EnableXMLHTTP_Hlp="Eintrag Original-XMLHTTP-Unterstützung aktivieren im Internet Explorer aktivieren"
Warum die ganzen Kategorien: Damit der Eintrag auch wenn ich die inetres.adm nutze an der richtigen Stelle erscheint (so zumindest die Absicht).
Ich könnte das ganze auch als reg Eintrag oder als Batch Datei lösen, möchte ich aber nicht

Regigstry:
01.
Windows Registry Editor Version 5.00 
02.
 
03.
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main] 
04.
"XMLHTTP"=dword:00000001
Batch Datei (und dann als Start/Anmeldeskript):
01.
REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /v XMLHTTP /t REG_DWORD /d 00000001 /f
Edit: Ich habe bis jetzt herausgefunden, dass es am mittleren Teil zwischen Policy Anfang und Ende liegen muss. Ich habe testweise mal den Teil aus einem funktionierenden Skript eingefügt, da taucht die Policy direkt auf.
Mitglied: Viprex
30.04.2010 um 15:39 Uhr
Ok, ich bin mittlerweile soweit das ich Depp heraus gefunden habe, dass die Policy zwar existiert, aber rausgefiltert wird, da unter Ansicht - Filterung der Haken bei "Nur vollständig verwaltbare Richtlinieneinstellungen anzeigen" gesetzt war. Nehme ich den Haken raus, dann taucht die Policy auf, allerdings mit einem Hinweis, dass "diese Registrierungseinstellung nicht in einem Richtlinienschlüsse gespeichert wird und daher Vorrang erhält. ...". Klar, es handelt sich ja auch um eine "unechte" Richtilinie, die nicht in einen der Policy Zweige in der Registry schreibt, sondern in einen Zweig, den der Benutzer selbst manipulieren kann (die Änderung ist natürlich nach Erneutem Greifen der Richtilinie wieder weg).

Soviel dazu. Ich wünschte, ich hätte auch mal eine AD Schulung erhalten. Wenn man sich alles selber beibringt bleiben solche Feinheiten eben auf der Strecke.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Microsoft
gelöst Lokale Intranet Site im IE wird nicht über GPO hinzugefügt (1)

Frage von Hanuta zum Thema Microsoft ...

Windows 10
Partitonen werden nicht angezeigt (3)

Frage von Alex.Sp zum Thema Windows 10 ...

Windows Server
gelöst GPO wird übernommen aber nicht angezeigt (11)

Frage von stefts zum Thema Windows Server ...

Heiß diskutierte Inhalte
Hardware
Laptop ins Salzwasser gefallen (18)

Frage von Marcel94 zum Thema Hardware ...

Hardware
Lenovo Yoga 500 über angeschlossene USB Tastatur booten (13)

Frage von thomasreischer zum Thema Hardware ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (13)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Viren und Trojaner
Wie werde ich den Mist "fanli90" wieder los? (12)

Frage von Taumel zum Thema Viren und Trojaner ...