Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Aus administrativer Kommandozeile Explorer aufrufen geht nicht mehr

Frage Microsoft Windows Systemdateien

Mitglied: el3ment

el3ment (Level 1) - Jetzt verbinden

11.12.2009 um 15:59 Uhr, 5846 Aufrufe, 7 Kommentare

Hallo,

wenn man bei einem User nur schnell etwas kleines installieren will was auf einem Netzwerkpfad liegt wo der User keinen Zugriff hat, habe ich mir immer schnell eine administrative Kommandozeile geöffnet (runas /user:domäne\benutzer cmd) und dann daraus den Explorer geöffnet, das Explorerfenster läuft dann unter dem jeweiligen administratorkonto und man kann so bequem an alle Netzwerkpfade und das installieren was man brauch.

Das ging bisher immer super auf jedem Rechner, doch nach und nach geht es jetzt bei immer mehr Rechnern nicht mehr..... Vermute das es an einem Sicherheitspatch von Microsoft liegt, habe auch schon mit "Filemon" geschaut was in dem Moment im Hintergrund abläuft und ob etwas geblockt wird oder Ähnliches, jedoch ist auch da nichts zu sehen.

Kennt jemand einen Workaround für dieses Problem oder noch besser, die Ursache und eine Lösung ?
Mitglied: 60730
11.12.2009 um 16:20 Uhr
Servus,

nach und nach geht es jetzt bei immer mehr Rechnern nicht mehr....

Wenn die Rechner unterschiedliche Patchstände haben - dann ist das schon das zweite "kosmische" - das ich aus deiner Frage lese...

1) Mein Firmenmopped hat nen Platten und ich erledige sowas mit einer Softwareverteilung.
(weil die nicht jeder hat - gibts für Lau auch PSexec)
2) die unterschiedlichen Patchlevel

Da gibts kein Workaround - sondern einen zu schmiedenden Plan - der sich mit dem Einsatz von WSUS & PSexec befaßt.
Von daher - einen neuen Vorsatz fürs nächste Jahr hast du dann schonmal.
Und der nächste Vorsatz - gerne in diesem Jahr umzusetzen wäre, Ross und Reiter beim Namen nennen - wenn du eine Frage hast

Gruß
Bitte warten ..
Mitglied: DerWoWusste
13.12.2009 um 15:27 Uhr
Hi.
Läuft ein Prozess explorer.exe, so kannst Du keinen zweiten als Administrator starten - das war schon immer so, ich kann mir nicht wirklich erklären, wie das bei Dir je funktioniert haben kann. Aufgrund dessen war es gängige Praxis, einen Internet Explorer mit Adminrechten zu starten und diesen als Dateibrowser zu gebrauchen. Dies geht seit IE Version 7 nicht mehr - der IE kann nicht mehr Dateibrowsen, er müsste dazu zum explorer.exe-Prozess werden.

Entweder, Du nutzt einen alternativen Dateiexplorer, oder Du meldest Dich um, oder Du machst zwei Schritte: Netzlaufwerk verbinden als Administrator und ein weiteres Mal runas auf dem Setup.
Bitte warten ..
Mitglied: el3ment
13.12.2009 um 22:17 Uhr
Danke für eure Antworten.

@Timo
Das wäre ein Lösungsweg, jedoch relativ aufwendig. Ich habe nicht wirklich die Zeit für so ein "kleines Problem" so viel Zeit zu investieren.
Es geht ja im Endeffekt "nur" um die Bequemlichkeit sich nicht erst als Admin anzumelden um auf Netzwerkpfade zuzugreifen die kein normaler User aufrufen darf.

@DerWoWusste
Ich habe mich vielleicht etwas unglücklich ausgedrückt, es geht mir nicht darum, den Internet Explorer mit administrativen Rechten auszuführen sondern den Windows Explorer. Am IE 7 kann es nicht liegen, denn ich habe auch viele Rechner wo es mit dem IE 7 noch funktioniert.
Ach ja, es geht mit ja nicht nur um Installationen, die kann man ja wie du schon sagst auch per "Run as" starten außer MSI Pakete, primär geht es um Netzwerkpfade wo kein normaler User Zugriff hat.


Ich habe gehofft bzw. ich hoffe noch das jemand weiss woran dies genau liegt. Meine Vermutung ist immer noch ein Sicherheitsupdate.
Bitte warten ..
Mitglied: DerWoWusste
13.12.2009 um 22:31 Uhr
es geht mir nicht darum...
Das hatte ich auch nicht so verstanden. Du willst den explorer und nicht den IE nutzen.
Wie gehst Du denn vor? cmd mit Adminrechten auf und dann den originalen (schwachen) Explorerprozess killen und dann einen neuen lostreten mit Adminrechten? Das geht immer.
Was auch geht ist
runas /user:domainNetbiosname\administrator "explorer /separate"

Mit Sicherheitsupdates hat dies nichts zu tun, es geht beides weiterhin bei mir auf xp.
Bitte warten ..
Mitglied: el3ment
13.12.2009 um 22:39 Uhr
Mich hat es verwirrt du das Thema IE 7 angeschnitten hast, deswegen dachte ich das du mich falsch verstanden hast.

Vorgehen:

Ein normaler User ist angemeldet
- runas /user:domäne\benutzer cmd
- in administrativer cmd dann nur [explorer] eintippen und dann öffnet sich ein Explorer Fenster welches im administrativen Kontext läuft, darüber kann ich dann an alle netzwerkpfade welche nur für die Administratoren freigegeben sind

Den Prozess explorer muss man dazu nicht beenden!

runas /user:domainNetbiosname\administrator "explorer /separate"

Der Parameter seperate klingt ganz interessant, werde ich morgen gleich mal testen!

Mit Sicherheitsupdates hat dies nichts zu tun, es geht beides weiterhin bei mir auf xp.

Aber woran könnte es dann liegen?
Bitte warten ..
Mitglied: DerWoWusste
13.12.2009 um 22:53 Uhr
Es wird vermutlich daran liegen, dass Du auf einigen Rechnern in den Ordneroptionen eingestellt hast, "Launch folder windows in a separate process" (hab gerade nur ein englisches xp hier) und auf einigen nicht. Auf denen wo nicht, muss man den Schalter separate benutzen, auf den anderen ist er nicht nötig.
Bitte warten ..
Mitglied: el3ment
13.12.2009 um 23:35 Uhr
Das hat mich jetzt nicht mehr losgelassen also hab ich nochmal fix per VPN ne VM angeschmissen und geschaut.

Und siehe da, es funktioniert mit dem Parameter seperate! Der Hacken ist bei den betroffenen PCs nicht gesetzt, komisch ist nur, wenn ich den Hacken setze funktioniert es nicht, auch wenn ich sage "für alle übernehmen", auch ein neustart hat nichts gebracht aber wenn ich den explorer mit dem Parameter aufrufe funktioniert es, also liegt es defintiv daran, dass reicht vollkommen aus!

SUPER, vielen vielen Dank !!!!


Wundert mich trotzdem etwas wie es jetzt plötzlich zu der Änderung bei einigen Rechnern kommt..... hmm.
Bitte warten ..
Ähnliche Inhalte
Monitoring
Smartmontools - Aufruf per Kommandozeile - Übergabe an Zabbix
gelöst Frage von KnorkatorMonitoring4 Kommentare

Hallo zusammen, ich möchte Smartmontools nutzen um SMART Werte an Zabbix zu übermitteln. Es gibt dafür fertige Templates/Anleitungen welche ...

Windows 7
Netzwerkvervindungen mit runas aufrufen, ncpa.cpol geht nicht
Frage von sammy65Windows 718 Kommentare

Hallo miteinander, ich muss an meinen 100 Windows7 Clients die alle beschränkte lokale Rechte haben immer wieder Wartungsarbeiten vornehmen. ...

Webbrowser
Intranetseite per SSL aufrufen . ohne Zertifikat . mit dem Internet Explorer ?
gelöst Frage von donnyS73lbWebbrowser4 Kommentare

Hallo zusammen, ich versuche, eine Intranetseite aufzurufen, per SSL. Wir haben aber für die Site kein Zertifikat. Beim FF ...

Windows 7
Aufruf einer Anwendung im Internet Explorer 11 mit ausgeblendeter URL
gelöst Frage von karlosWindows 718 Kommentare

Unter Win7 SP1 64bit wird eine, im lokalem Netz befindliche Anwendung, im Webbrowser aufgerufen. Der Internet Explorer 11 ist ...

Neue Wissensbeiträge
Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 5 StundenWindows 101 Kommentar

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 6 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner2 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 1 TagRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Brainstorming, einfachste Option 1 getrenntes LAN (mit WAN zugang)
Frage von 132954LAN, WAN, Wireless13 Kommentare

Hi, folgendes: Wir bekommen eine Glasfaser Leitung, Und das sollte Optional so aussehen: Ein Modem/Router für das WAN, ein ...

Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen12 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...