Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Agere ET-131x PCI-E Treiber Problem unter Debian Etch 4.0 (Kernel 2.6.20.12)

Frage Linux Debian

Mitglied: TiTux

TiTux (Level 2) - Jetzt verbinden

04.06.2007, aktualisiert 05.06.2007, 4773 Aufrufe, 2 Kommentare

Hallo,

ich habe ein LG-LW25 Subnotebook. Dort ist als Netzwerkkarte eine Agere ET-131x PCI-E verbaut.
Im aktuellen Kernel gibt es noch keinen Support für diese Karte. Derzeit habe ich einen 2.6.20.12 Kernel
am laufen. Auf dieser Seite gibt es ein How-to,
nachdem ich vorgehen wollte.

Auf sourceforge.net gibt es den aktuellen Treiber dazu.
Hier meine Vorgehensweise:

1. Den neusten Treiber von sourceforge runtergeladen

2. Das File hierher entpackt: /usr/src/linux/drivers/net/et131x-1.2.3

3. make ausgeführt (es kamen ein paar Fehlermeldungen und er beendete
mit make: *** [modules] Fehler 2

4. Danach hatte ich eine et131x.o Datei die ich kopierte und et131x.ko
nannte. (Aus einem anderen Forum rausgelesen, die Datei ist für den 2.6 Kernel)

5. Dann ein make modules_install ausgeführt

6. Die Meldung sah gut aus:
INSTALL /usr/src/linux-2.6.20.12/drivers/net/et131x-1.2.3/et131x.ko
DEPMOD 2.6.20.12
make[1]: Leaving directory '/usr/src/linux-2.6.20.12'

7. Habe dann ein depmod -a ausgeführt

8. Jetzt wollte ich mit modprobe laden

9. Wenn ich modprobe et131x.ko eingebe, erhalte ich diese Meldung:
FATAL: Module et131x.ko not found.

10. Gebe ich modprobe et131x ein, kommt folendes:
No module found in object
FATAL: Error inserting et131x (/lib/modules/2.6.20.12/extra/et131x.ko):
Invalid module format

Jetzt weiss ich nicht, woran es genau scheitert. Bin für jede Hilfe dankbar,
mache mit diesem Problem schon länger rum.

Gruß
Rainer
Mitglied: 16568
05.06.2007 um 14:36 Uhr
Jetzt weiss ich nicht, woran es genau
scheitert. Bin für jede Hilfe dankbar,
mache mit diesem Problem schon länger
rum.

Das is ja nicht Dein Ernst, oder?

3. make ausgeführt (es kamen ein paar
Fehlermeldungen und er beendete
mit make: *** [modules] Fehler 2

Ja, da würde ich dann doch glatt da mal gucken, was da so schief gelaufen ist...


Lonesome Walker
Bitte warten ..
Mitglied: TiTux
05.06.2007 um 16:52 Uhr
Das Problem ist, dass ich nicht die ganze Ausgabe von make in eine Text-Datei bekomme.
Habs mit make 2> failure.txt z.B. probiert, dann schreibt er aber nur einen kleinen Teil
von der Fehlermeldung dort rein.
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Ubuntu
Problem mit MailServer unter Debian - Postfix, Dovecot (4)

Frage von Richard8 zum Thema Ubuntu ...

Hardware
gelöst PCI-Express-Adapterfrage (14)

Frage von DerWoWusste zum Thema Hardware ...

Exchange Server
gelöst Exchange 2013 Outlook 2013 Autodiscover Mailbox Problem (GUID) (4)

Frage von Systembastler zum Thema Exchange Server ...

SAN, NAS, DAS
gelöst Synolgy 1815+ - Rechte- und Richtlinien-Problem User-Ordner Home (3)

Frage von Nintox zum Thema SAN, NAS, DAS ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (32)

Frage von Maik82 zum Thema Linux Netzwerk ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (20)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Mac OS X
Mac kann nicht im LAN pingen alle anderen schon (14)

Frage von smartino zum Thema Mac OS X ...