Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Agnitum Outpost Firewall Pro crasht

Frage Sicherheit Firewall

Mitglied: Arti09

Arti09 (Level 1) - Jetzt verbinden

30.12.2007, aktualisiert 29.01.2009, 7278 Aufrufe, 13 Kommentare

Es geht um die Version Outpost Firewall Pro ver. 3.5.641.6214 (458). Es gibt zwar einen Eintrag für die Version 4.0, aber für meine Version gibt es leider keine Updates(oder habe bis jetzt keine gefunden).

Also es ist immer zufällig wann das System einfach neustartet, aber komischer Weise nicht bei Volllast. Nach diesem Crash(Neustart) kommt eine Fehlermeldungi von Outpost das es ein Treiberfehler war und ob ich halt diese Fehlermeldung an den Support schicken will. Habe ich auch oft getan aber bekam keine Antwort und sah auch keine updates auf der Homepage. Naja und manchmal nervt das halt, wenn ich gerade bei eBay bin oder so.
Es steht da, dass der Bericht in Memorydump gespeichert wurde und im feedback-Ordner von Outpost. Ich weis aber nich mehr was ich machen kann. Habe schon den Minidump-Ordner kontrolliert und beim Antivirus(Avira Antivir Personal Edition Classic) habe ich auch schon alles vom Outpost freigegeben. Arbeite mit Windows XP.
Vielleicht weis einer von euch wie man den Fehler beseitigt.

96ad13b4d4c68a90e4b5d7b1c71a6150-fehler_firewall - Klicke auf das Bild, um es zu vergrößern
Mitglied: gnarff
02.01.2008 um 20:08 Uhr
Die Fehlermeldung sagte es ja bereits, es handelt sich um einen Treiber-Schaden. Wenn Du wissen willst um welchen Treiber es sich dabei handelt, dann solltest Du einmal einen Blick in die Datei feedback.zip werfen, da steht alles drin...

saludos
gnarff
Bitte warten ..
Mitglied: Arti09
02.01.2008 um 22:41 Uhr
Also ja habe die feedback.zip Datei geöffnet und dort drinnen war wieder ne minidump Datei. Und die sieht beim öffnen etwas komisch aus. Gibt es da ne bestimte Stelle wo genau dieser Treiberfehler steht? Habe zwar schon einige Stellen rausgesucht, aber sind trotzdem einige . . .
Bitte warten ..
Mitglied: gnarff
03.01.2008 um 16:13 Uhr
Also ja habe die feedback.zip Datei
geöffnet und dort drinnen war wieder ne
minidump Datei. Und die sieht beim
öffnen etwas komisch aus. Gibt es da ne
bestimte Stelle wo genau dieser Treiberfehler
steht? Habe zwar schon einige Stellen
rausgesucht, aber sind trotzdem einige . . .
Du kannst meine EMail Adresse via PN anfordern und mir die *.zip-Datei zusenden, dann schaue ich mir das an...
saludos
gnarff
Bitte warten ..
Mitglied: manu1337
21.01.2009 um 18:23 Uhr
Hi,

Konnte das Problem bei der gelöst werden Arti? Ich habe leider genau das gleiche Problem. Erhalte in unregelmäßigen Abständen, scheinbar unabhängig von den ausgeführten Programmen, einen Bluescreen. Nach dem Neustart erhalte ich dann auch diese Fehlernachricht von Outpost. Hatte schon Kontakt mit dem Dell-Support und die meinten, nachdem sie diverse minidumps ausgewertet haben, dass das Problem meistens ein anderes war und das teilweise Outpost der Grund für den crash war. Konnte das Problem, aber bis heute nicht lösen

Die besagte feedback.zip Datei finde ich leider nicht.

Nutze Vista auf einem Dell Inspiron 1720.

Wäre sehr nett, wenn mir jemand weiterhelfen könnte.
Bitte warten ..
Mitglied: gnarff
21.01.2009 um 19:21 Uhr
Hallo manu,

bitte genau wiedergeben, welche Fehlermeldung auf dem Bluescreen ausgegeben wird. falls der Bluescreen nicht lange genug angezeigt wird, dann ueber die Systemsteuerung unter Starten und Wiederherstellen das Neustarten verbieten...

saludos
gnarff
Bitte warten ..
Mitglied: manu1337
22.01.2009 um 00:00 Uhr
Hallo gnarff,

Erstmal danke für die schnelle Antwort. Der Bluescreen war in der Tat immer viel zu schnell weg also hab ich den automatischen Neustart schon mal ausgestellt. Und nun abwarten und Tee trinken bis der Bluescreen wieder kommt? Er kommt halt manchmal 2 Tage hintereinander aber dann auch wieder mal mehrere Wochen gar nicht. Also sehr unregelmäßig.

Woran ich mich aber noch erinnern kann ist, dass ich mehrmals die Nachricht IRQL_NOT_LESS_OR_EQUAL und BAD_POOL_HEADER bekommen habe... Aber das kann wahrscheinlich vieles bedeuten oder?^^
Bitte warten ..
Mitglied: gnarff
22.01.2009 um 19:25 Uhr
Zitat von manu1337:
Woran ich mich aber noch erinnern kann ist, dass ich mehrmals die
Nachricht IRQL_NOT_LESS_OR_EQUAL und BAD_POOL_HEADER bekommen habe...
Aber das kann wahrscheinlich vieles bedeuten oder?^^
Was es genau bedeutet erfahren wir erst, wenn wir die genaue Fehlermeldung haben, aber das Problem laesst sich schon einigermassen einkreisen:
1. Bug Check 0xA: IRQL_NOT_LESS_OR_EQUAL
" The IRQL_NOT_LESS_OR_EQUAL bug check has a value of 0x0000000A. This indicates that Microsoft Windows or a kernel-mode driver accessed paged memory at DISPATCH_LEVEL or above."[...]

2. Bug Check 0x19: BAD_POOL_HEADER
"The BAD_POOL_HEADER bug check has a value of 0x00000019. This indicates that a pool header is corrupt."[...]

Warten wir also auf die Rueckkehr der Fehlermeldung...

Saludos
gnarff
Bitte warten ..
Mitglied: manu1337
22.01.2009 um 20:26 Uhr
Hi gnarff,

Nochmals danke für die schnelle Hilfe! Ich habe mir in der Zwischenzeit dieses WinDbg besorgt und den letzten Minidump ausgelesen. Da stand dann etwas von Unable to load image \SystemRoot\system32\ntkrnl.exe, Win32 error 0n2. Mir sagt das alles leider nichts ;) Vielleicht hat es ja auch nichts damit zu tun.

Falls es nichts hilft muss ich dann wohl wirklich warten... Ich meld mich dann wieder
Bitte warten ..
Mitglied: gnarff
22.01.2009 um 21:29 Uhr
Hallo manu,

ich kenne die Ausgaben durch WinDbg ziemlich gut und weiss, dass da nicht nur Unable to load image \SystemRoot\system32\ntkrnl.exe, Win32 error 0n2 stand.
Der komplette Report ist interessant, poste bitte die Ausgabe auch im verbose-Modus, also mittels analyze -v..

Wenn die Datei zu gross ist um hier gepostet zu werden, dann kannst du sie mir auch an meine Mailadresse schicken....

saludos
gnarff
Bitte warten ..
Mitglied: manu1337
23.01.2009 um 12:12 Uhr
Ich habe dir eine E-Mail mit der Minidump geschickt. Wenn ich in den verbose-Modus wechsel will der die Datei nicht mehr öffnen...
Bitte warten ..
Mitglied: gnarff
24.01.2009 um 01:53 Uhr
Hallo manu,

die Analyse deines minidump-Files hat folgendes ergeben:
01.
Microsoft (R) Windows Debugger Version 6.10.0003.233 X86 
02.
Copyright (c) Microsoft Corporation. All rights reserved. 
03.
 
04.
 
05.
Loading Dump File [C:\WINDOWS\Minidump\Minimanu.dmp] 
06.
Mini Kernel Dump File: Only registers and stack trace are available 
07.
 
08.
Symbol search path is: C:\WINDOWS\symbols 
09.
Executable search path is:  
10.
Unable to load image \SystemRoot\system32\ntkrnlpa.exe, Win32 error 0n2 
11.
*** WARNING: Unable to verify timestamp for ntkrnlpa.exe 
12.
Windows Server 2008/Windows Vista SP1 Kernel Version 6001 (Service Pack 1) MP (2 procs) Free x86 compatible 
13.
Product: WinNt, suite: TerminalServer SingleUserTS Personal 
14.
Machine Name: 
15.
Kernel base = 0x8424a000 PsLoadedModuleList = 0x84361c70 
16.
Debug session time: Wed Jan 21 10:48:55.272 2009 (GMT-6) 
17.
System Uptime: 0 days 3:26:47.622 
18.
Unable to load image \SystemRoot\system32\ntkrnlpa.exe, Win32 error 0n2 
19.
*** WARNING: Unable to verify timestamp for ntkrnlpa.exe 
20.
Loading Kernel Symbols 
21.
............................................................... 
22.
................................................................ 
23.
......................................... 
24.
Loading User Symbols 
25.
Loading unloaded module list 
26.
........ 
27.
******************************************************************************* 
28.
*                                                                             * 
29.
*                        Bugcheck Analysis                                    * 
30.
*                                                                             * 
31.
******************************************************************************* 
32.
 
33.
Use !analyze -v to get detailed debugging information. 
34.
 
35.
BugCheck C5, {0, 2, 1, 843371c3} 
36.
 
37.
Unable to load image \SystemRoot\system32\DRIVERS\HDAudBus.sys, Win32 error 0n2 
38.
*** WARNING: Unable to verify timestamp for HDAudBus.sys 
39.
Probably caused by : HDAudBus.sys ( HDAudBus!operator new+16 ) 
40.
 
41.
Followup: MachineOwner 
42.
--------- 
43.
 
44.
1: kd> !analyze -v 
45.
******************************************************************************* 
46.
*                                                                             * 
47.
*                        Bugcheck Analysis                                    * 
48.
*                                                                             * 
49.
******************************************************************************* 
50.
 
51.
DRIVER_CORRUPTED_EXPOOL (c5) 
52.
An attempt was made to access a pageable (or completely invalid) address at an 
53.
interrupt request level (IRQL) that is too high.  This is 
54.
caused by drivers that have corrupted the system pool.  Run the driver 
55.
verifier against any new (or suspect) drivers, and if that doesn't turn up 
56.
the culprit, then use gflags to enable special pool. 
57.
Arguments: 
58.
Arg1: 00000000, memory referenced 
59.
Arg2: 00000002, IRQL 
60.
Arg3: 00000001, value 0 = read operation, 1 = write operation 
61.
Arg4: 843371c3, address which referenced memory 
62.
 
63.
Debugging Details: 
64.
------------------ 
65.
 
66.
 
67.
BUGCHECK_STR:  0xC5_2 
68.
 
69.
CURRENT_IRQL:  0 
70.
 
71.
FAULTING_IP:  
72.
nt!NtSetInformationProcess+46f 
73.
843371c3 ??              ??? 
74.
 
75.
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT 
76.
 
77.
LAST_CONTROL_TRANSFER:  from 843371c3 to 842a4d24 
78.
 
79.
STACK_TEXT:   
80.
803ece34 843371c3 badb0d00 00000000 803ece54 nt!WmipCsrClientMessageServer+0x4e 
81.
803ecee0 843386e0 8434c6e0 00000001 89a6b000 nt!NtSetInformationProcess+0x46f 
82.
803ecf48 90efd01c 8729ccb0 00000000 803ecf78 nt!PspInitializeProcessSecurity+0x6a 
83.
803ecf58 90efe0d9 8729ccb0 89a6b000 89a6e864 HDAudBus!operator new+0x16 
84.
803ecf78 90f00bbc 803cd120 803ecfe0 803ecff4 HDAudBus!AzCreateChildDevice+0x6e9 
85.
803ecf88 84300450 89a6e864 89a6b000 00000000 HDAudBus!AzController::AllocateDmaBuffer+0x1c4 
86.
803ecff4 842fe935 b334cb28 00000000 00000000 nt!IopReleaseResources+0x4e 
87.
803ecff4 00000000 b334cb28 00000000 00000000 nt!IopSetupArbiterAndTranslators+0x43 
88.
 
89.
 
90.
STACK_COMMAND:  kb 
91.
 
92.
FOLLOWUP_IP:  
93.
HDAudBus!operator new+16 
94.
90efd01c ??              ??? 
95.
 
96.
SYMBOL_STACK_INDEX:  3 
97.
 
98.
SYMBOL_NAME:  HDAudBus!operator new+16 
99.
 
100.
FOLLOWUP_NAME:  MachineOwner 
101.
 
102.
MODULE_NAME: HDAudBus 
103.
 
104.
IMAGE_NAME:  HDAudBus.sys 
105.
 
106.
DEBUG_FLR_IMAGE_TIMESTAMP:  474ca5d1 
107.
 
108.
FAILURE_BUCKET_ID:  0xC5_2_HDAudBus!operator_new+16 
109.
 
110.
BUCKET_ID:  0xC5_2_HDAudBus!operator_new+16 
111.
 
112.
Followup: MachineOwner 
113.
--------- 
114.
 
115.
1: kd> lmvm HDAudBus 
116.
start    end        module name 
117.
90efc000 90f0e000   HDAudBus M (pdb symbols)          C:\WINDOWS\symbols\sys\HDAudBus.pdb 
118.
    Loaded symbol image file: HDAudBus.sys 
119.
    Image path: \SystemRoot\system32\DRIVERS\HDAudBus.sys 
120.
    Image name: HDAudBus.sys 
121.
    Timestamp:        Tue Nov 27 17:18:41 2007 (474CA5D1) 
122.
    CheckSum:         00014C8B 
123.
    ImageSize:        00012000 
124.
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Eine genauere Auskunft gab !analyze -v, naemlich:
01.
start    end        module name 
02.
90efc000 90f0e000   HDAudBus M (pdb symbols)          C:\WINDOWS\symbols\sys\HDAudBus.pdb 
03.
    Loaded symbol image file: HDAudBus.sys 
04.
    Image path: \SystemRoot\system32\DRIVERS\HDAudBus.sys 
05.
    Image name: HDAudBus.sys 
06.
    Timestamp:        Tue Nov 27 17:18:41 2007 (474CA5D1) 
07.
    CheckSum:         00014C8B 
08.
    ImageSize:        00012000 
09.
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Es liegt ein Treiberproblem vor und zwar ist HDAudBus.sys betroffen. Seltsam ist, dass dein Rechner als Terminalserver ausgewiesen wird.

Bitte benutze den Driver verifier und analysiere die betreffende Datei, wie dabei vorzugehen ist wird im Artikel Verwendung der Treiberüberprüfung zur Behandlung von Treiberproblemen in Windows (für fortgeschrittene Benutzer) beschrieben.
Der Driver verifier sollte sich im Ordner system32 befinden, zumindest unter XP und Windows Server, ansonsten einfach mal nach Verifier.exe suchen

Ich kann das leider nicht fuer dich machen, bitte poste das Ergebnis hier...

Saludos
gnarff
Bitte warten ..
Mitglied: manu1337
24.01.2009 um 12:24 Uhr
Hi gnarff,

Ich habe den Treiber ausgewählt und musste dann neustarten. Danach war der Treiber im verifier geladen und ich konnte "vorhandene Einstellungen" und "Informationen über verifizierte Treiber" einsehen.

Das steht bei Einstellungen: Einstellungen

Und das waren die Ergebnisse: 1 2

Die Werte haben jeweils etwas geschwankt.

In letzter Zeit sind mir noch andere Dinge aufgefallen: Nach dem booten laden die kleinen Symbole unten rechts in der Taskleiste manchmal nicht richtig. Und die Symbole, die geladen werden sind grau und lassen sich nicht anklicken. Das kommt aber nur selten vor (Größenordnung ca. 5% aller Starts). Wenn ich dann neustarte, ist meistens wieder alles normal. Außerdem kommt mir der Rechner etwas langsamer vor. Wenn ich hier z.B. etwas schreibe, hakt es sehr oft und der Text erscheint erst etwas später. Ich habe mittlerweile das Gefühl, dass mit meinen Treibern allgemein etwas nicht stimmt. Kann man die nicht alle ohne eine Vista Neuinstalltion irgendwie zurücksetzen?

Sag bescheid, falls du noch weitere Infos brauchst. Ich schaue hier ab und zu rein.

Edit: Links müssten jetzt funktionieren ;)
Bitte warten ..
Mitglied: manu1337
26.01.2009 um 19:23 Uhr
Hi gnarff,

Da bei mir tatsächlich ein Fehler mit einem alten Grafikkartentreiber vorlag (ich hatte mal einen falschen Grafikkartentreiber installiert) habe ich mich entschlossen meine Festplatte zu formatieren. Das zu beheben wäre einfach zu kompliziert gewesen.

Habe mir ein ordentliches Backup erstellt und los ging es. Das wunderbare bei Dell ist die Recovery Partition. Die Formatierung und Wiederherstellung zum Lieferzeitpunkt hat insgesamt nur 10 Minuten gedauert. Inklusive aller Vista Einstellungen etc. Das ist echt der Hammer. Bin gerade dabei den Schrott den ich nicht brauche runterzuwerfen (z.B. die ganzen Testversionen) und die Programme neu zu installieren. Hat alles super geklappt. Alles ist wieder schön schnell und funktioniert. Keine Probleme mehr.

Danke nochmal für deine Hilfe Ich wünsche eine schöne Woche.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Switche und Hubs
gelöst IP Cam außen am Haus Zugriff sichern über Firewall ACL (6)

Frage von TimMayer zum Thema Switche und Hubs ...

Firewall
Passende Firewall gesucht (7)

Frage von harald.schmidt zum Thema Firewall ...

Firewall
Sendefehler 2101 - Firewall die Ursache (3)

Frage von honeybee zum Thema Firewall ...

Router & Routing
The Router rumble: Ars DIY build Router/Firewall (2)

Link von Kuemmel zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...