Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ajax und Cache Probleme

Frage Entwicklung Webentwicklung

Mitglied: zoro17

zoro17 (Level 1) - Jetzt verbinden

29.12.2007 um 17:24 Uhr, 3222 Aufrufe

Hallo zusammen,
ich habe ein komisches Fehlerhalten im Zusammenspiel Ajax und Cache(?).
Meine Ausgangslage:
Ich habe eine HTML-Seite mit Javascript. Durch JS wird das XMLHttpRequestObject erzeugt. Das klappt in Firefox und auch im IE.

Mittels XMLHttpRequestObject rufe ich eine ASP-Datei auf dem Server auf. Der Aufruf enthält einen Parameter, dessen Wert
mit einem Zufallsgenerator bei jedem Aufruf geändert wird, d.h. der Aufruf der ASP-Datei ist durch den Zufallsgenerator nie identisch.

Die ASP-Datei gibt eine einfache HTML-Tabelle mit 2 Zeilen und 2 Spalten zurück. 3 von den 4 Zellen haben statische Ziffern, die
4. Zelle hat den Zufallsgeneratorwert.

Wenn ich die Werte per XMLHttpRequestObject abhole, kommen 3 statische und der dynamischer Wert an, so wie es sein soll.
Rufe ich das XMLHttpRequestObject nochmals auf, bleiden 3 Werte statisch, der 4 Wert hat sich wie gewünscht geändert.
Bisher alles ok.

Ich ändere auf dem Server die ASP-Datei, in dem ich die 3 statischen Ziffern ändere. Sonst nichts. Rufe ich das XMLHttpRequestObject
wieder auf der HTML auf, so bekomme ich die 3 alten und den neuen Zufallsgeneratorwert zurück.
Man hat den Eindruck, das ein Teil der Seite aus dem Cache kommt, der Rest wird neu generiert. Eigentlich quatsch, denke ich.

Die ASP-Seite enthält die ASP-Angaben:
Response.ExpiresAbsolute = now() - 1
Response.Expires= now - 1000
Response.AddHeader "Pragma","no-cache"
Response.AddHeader "cache-control", "no-store"

und die Header-Angaben:
<meta http-equiv="Pragma" content="no-cache">
<meta http-equiv="Cache-Control" content="no-cache">
<meta http-equiv="Expires" content="Thu, 01 Dec 1994 16:00:00 GMT">

Es dürfte so eigentlich nichts aus dem Cache des Servers kommen. Durch den Zufallsgeneratoraufruf auch nichts aus Client-Cache.

Kann mir jemand das Verhalten erklären? Hat jemand ähnliche Erfahrungen? Kann man's beheben?

Für ein Feedback wäre ich dankbar!
Guten Rutsch.
Neuester Wissensbeitrag
Ähnliche Inhalte
Exchange Server
Exchange 2016 Probleme mit einzelnem Postfach und Cache Mode (5)

Frage von MacgregS zum Thema Exchange Server ...

Windows Update
Immer wieder Probleme mit WSUS (W10 u W2k16 ) (4)

Frage von Leo-le zum Thema Windows Update ...

Netzwerke
gelöst PfSense: Probleme mit Wirksamkeit von Rules (8)

Frage von Fenris14 zum Thema Netzwerke ...

SAN, NAS, DAS
Fujitsu Q800 Probleme bei Domäneneinbindung

Frage von galnar zum Thema SAN, NAS, DAS ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (29)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Hardware
Laptop ins Salzwasser gefallen (18)

Frage von Marcel94 zum Thema Hardware ...

Hardware
Lenovo Yoga 500 über angeschlossene USB Tastatur booten (13)

Frage von thomasreischer zum Thema Hardware ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...