Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

ALIX 2D13 vr2 und ath0 down

Frage Netzwerke LAN, WAN, Wireless

Mitglied: orcape

orcape (Level 2) - Jetzt verbinden

11.01.2012 um 20:20 Uhr, 5847 Aufrufe, 4 Kommentare

Hi Leute,

ich habe mir Aqui´s (sicher durch jahrelange Erfahrung gebildete) Meinung über Netgear-Router zu Herzen genommen
und einen solchen gegen ein ALIX 2D13 mit Mini-PCI WLAN-Karte getauscht.
Ich glaube nach dem ersten Eindruck keine schlechte Wahl.

An dieser Stelle noch mal Dank an Aqui für seine Top-Anleitungen zu dem Thema.

Beim flashen der 4GB-Karte mit pfSense unter Win7 habe ich mir zwar die Zähne ausgebissen, unter Linux
gings dann aber problemlos durch.
Das Alix läuft mit pfSense als Router mit WAN- und LAN-Interface problemlos und ist nach meinem Empfinden schneller
als meine "Netgear Gurke" (Zitat Aqui).
Besorgt habe ich mir noch ein Nullmodemkabel und einen seriellem Boardanschluß für den PC.
Der Zugriff von Debian mit Minicom funktioniert problemlos und hat mir schon gute Dienste geleistet.
Sei es nur bei der Umstellung auf statische-IP´s im LAN, nach dem ich mich (selber schuld),
im Webinterface erst mal selber ausgesperrt habe und ich auch nicht erst die Rechner IP ändern wollte
um wieder Zugriff zu erhalten.
Der serielle Anschluß ist zwar nicht unbedingt notwendig, aber für meine Begriffe doch unverzichtbar,
wenn die Anwendung über die Homerouting Funktionen hinausgehen.

Nun zu meinem eigentlichen Problemchen.

Der Versuch, irgendwie OPT1 (DMZ) zu aktivieren war bisher leider nicht von Erfolg gekrönt.
Trotz entsprechender Einstellungen im pfSene-GUI (FW-Rules etc.)und Neustart der FW,
bleibt das OPT1-Interface auf down.
Bei ath0 kommt dann sogar noch eine Fehlermeldung.
Sind hier noch Änderungen an der BIOS-Einstellung notwendig ? Leider habe ich es auch noch nicht geschafft auf´s
BIOS zuzugreifen.
Ist wohl ein entfernen des Flash´s nötig, um per drücken der "s" Taste ins BIOS zu kommen ?
Sollte ich beim lesen von Aqui´s Anleitung etwas übersehen haben,
was mein Problem betrifft, so möge man mir verzeihen !

Hier mal die boot-logs des Alix....

http://pastebin.de/22185

Gruß und Danke !

orcape
Mitglied: aqui
13.01.2012 um 12:27 Uhr
Hallo Orcape
Mmmhhh flashen der CF Karten klppt einwandfrei unter Win 7 sowohl im 32 als auch im 64 Bit Version mit physdiskwrite. keine Ahnung was du da verzapft hast. Vielleicht den -u Parameter vergessen ?? Egal... zurück zu deinem Problem !
Wenn das Interface "ath0" schon erkannt wurde ist das schonmal gut. Sehr wichtig sind die Bootmessages am Terminal bezüglich der HW Erkennung.
Das OPT 1 Interface is ja das 3te LAN Interface, was du im Setup erstmal aktivieren musst. Ebenso das atho Interface was das WLAN Interface ist !
Ist das geschehen bei dir ?!

Deinen Bootmessages sind absolut korrekt und die WLAN mini PCI HW ist sauber erkannt:
vr0: <VIA VT6105M Rhine III 10/100BaseTX> port 0x1000-0x10ff mem 0xe0000000-0xe00000ff irq 10 at device 9.0 on pci0
vr0: Quirks: 0x2
vr0: Revision: 0x96
miibus0: <MII bus> on vr0
ukphy0: <Generic IEEE 802.3u media interface> PHY 1 on miibus0
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
vr0: [ITHREAD]
vr1: <VIA VT6105M Rhine III 10/100BaseTX> port 0x1400-0x14ff mem 0xe0040000-0xe00400ff irq 11 at device 10.0 on pci0
vr1: Quirks: 0x2
vr1: Revision: 0x96
miibus1: <MII bus> on vr1
ukphy1: <Generic IEEE 802.3u media interface> PHY 1 on miibus1
ukphy1: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
vr1: [ITHREAD]
vr2: <VIA VT6105M Rhine III 10/100BaseTX> port 0x1800-0x18ff mem 0xe0080000-0xe00800ff irq 15 at device 11.0 on pci0
vr2: Quirks: 0x2
vr2: Revision: 0x96
miibus2: <MII bus> on vr2
ukphy2: <Generic IEEE 802.3u media interface> PHY 1 on miibus2
ukphy2: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
vr2: [ITHREAD]
ath0: <Atheros 5413> mem 0xe00c0000-0xe00cffff irq 9 at device 12.0 on pci0
ath0: [ITHREAD]
ath0: AR5413 mac 10.5 RF5413 phy 6.1


Im Default werden aber erstmal nur 2 Interfaces aktiviert, das ist das LAN und das WAN Interface !
Das OPT1 (3ter Port) und OPT2 (WLAN) Interface musst du erst noch aktivieren !
  • Dazu gehst du ins Web Setup Menü und überspringst den Wizzard (wenn du willst) mit Klick auf "pfSense".
  • Dann wählst du oben Interface (assign)
  • Hier klickst du nun 2 mal auf das unten rechts liegende "+" Symbol !
  • Nun sollten dort alle deine Interfaces ala:
841dd7c325d0bff25ba233cc2d7ffb2a - Klicke auf das Bild, um es zu vergrößern
zu sehen sein !!
  • Nun wieder Interfaces klicken und z.B. OPT 2 wählen. Und den Haken bei enable Interface setzen und das Interface z.B. zur besseren Identifizierung von OPT2 in "WLAN" umbennen.
944922889566ad5bcd25b58bd2bbdc38 - Klicke auf das Bild, um es zu vergrößern
  • Fertisch bist du !

So einfach ist das und sollte bei dir auch einwandfrei funktionieren, da deinen HW ja problemlos erkannt wird !!
Am BIOS musst du nicht rumfummeln. Aktuell ist die Version 0.99h die auch bei dir auf dem Board sein sollte ?!
http://pcengines.ch/alix2.htm
Siehe Boot Meldung ! (Achtung kommt ggf. mit 19.200 Baud !)
Du kannst das BIOS ganz leicht updaten wenn du dir einen alte CF Flash Karte ab 64MB nimmst und dort ein FreeDos aufspielst.
Genaue Anleitung dazu findest du hier:
http://pcengines.ch/freedos.htm
Wie gesagt 0.99h sollte aber bei dir drauf sein !

P.S.: Bitte lass das mit externen Links und das auch noch mit Zwangswerbung. Hier gibt es die Möglichkeit Bilder hochzuladen über die "Bilder Upload" Funktion. Den Bilder URL kann man mit einem Rechtsklick cut and pasten und in sämtliche Texte bringen.
Terminal Meldungen so oder so per cut and paste, da sie ja nur Text sind. Im Zweifelsfall wenn formatiert bringt man das in die "code" "/code" brackets.
Bitte warten ..
Mitglied: orcape
13.01.2012 um 20:10 Uhr
Hi Aqui,

ich habe gestern Abend noch entschieden mir auch noch den 3. Flash-Speicher zu kaufen, was ich heute getan habe.

Nr.1 Kingsten 4G habe ich mit dem 4G img überhaupt nicht zum laufen gebracht. Ständig Fehlermeldung "Speicherplatz nicht ausreichend"
Zumindest bei pfSense, Monowall hat zwar keine Fehlermeldung gebracht, zum laufen habe ich das Board aber auch damit nicht
gebracht.

Nr.2 SanDisk 30MB/s 4G war dann kein Problem mit flashen, brachte aber die genannten Fehlermeldungen....

ad0: FAILURE - READ status=51<READY,DSC,ERROR> error=10<NID_NOT_FOUND> LBA=7813103
ad0: FAILURE - READ status=51<READY,DSC,ERROR> error=10<NID_NOT_FOUND> LBA=7813116

Laut pfSense-Page Speicherbedingt und kein Problem, leider bei mir aber doch.
Es ließ sich immer nur WAN,LAN und 1 zusätzliches Interface aktivieren. Wenn ich versucht habe das 4 Interface (miniPCI) einzurichten, war das zwar aktiviert, hat mir aber das 3. wieder überschrieben.

Nun habe ich eine NoNAME-CF 2G eingebaut und damit gab es wirklich Null-Probleme. Nicht beim flashen, keine Fehlermeldung beim booten und auf Anhieb lassen sich alle Interfaces problemlos auf up setzen.

Danke für Deine Bemühungen, tolles Teil, nun wirklich nicht mit Netgear zu vergleichen....
...und was das PS angeht, werde ich tun, Sorry.

Gruß orcape
Bitte warten ..
Mitglied: aqui
14.01.2012 um 13:17 Uhr
Du siehst für einen wirklichen "Killerwal" alles kein Thema
Ich verwende fast nur 2 GiG Karten, da 4 GiG in der ALIX Appliance rausgeschmissenes Geld ist, da man das gar nicht ausnutzt (Plugin Block). 4 GiG macht eigentlich nur Sinn wenn man das auf einen PC Plattform mit IDE-CF Adapter betreibt aber das ist wieder sinnfrei wegen des hohen Stromverbrauchs. Vermutlich ist mir das problem deshalb noch nicht über den Weg gelaufen. Check ich aber nochmal....
Gut wenn nun alles rennt wie es soll und du damit die grausliche NetGear Gurke ge"killert" hast
Bitte warten ..
Mitglied: orcape
14.01.2012 um 15:18 Uhr
Du siehst für einen wirklichen "Killerwal" alles kein Thema

Genau und damit ich meinem Nick die Ehre erweise, habe ich gleich 2 NetGear Gurken ge"killert".
Das Alix macht das schon.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Firewall
gelöst Alix 2D13 - 3 Netzwerkport geht nicht (2)

Frage von dan0ne zum Thema Firewall ...

Internet
Google Down: Google-Dienste in Zentraleuropa gestört (2)

Link von runasservice zum Thema Internet ...

Microsoft Office
gelöst Wiedergabe eines Drop-Down Menüs! (2)

Frage von Magnus32x1 zum Thema Microsoft Office ...

Router & Routing
gelöst VLAN Probleme mit Alix APU.1D und Switch (81)

Frage von dan0ne zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...