Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Alt Gr Taste will nicht unter XenServer bei Linux Gästen

Frage Virtualisierung Xenserver

Mitglied: TiTux

TiTux (Level 2) - Jetzt verbinden

19.10.2009, aktualisiert 09.04.2015, 8711 Aufrufe, 2 Kommentare

Hallo,

ich habe hier meinen XenServer und insgesamt 3 VMs darunter laufen.

2 x Debian und 1 x Windows Server 2008.

Unten beiden Linuxen wird meine "Alt Gr" Taste nicht weitergereicht,
so scheint es wohl. Unter Windows funktioniert sie. Ich kann also z.B.
kein Euro Zeichen oder die Pipe-Zeichen eingeben.

Im Xen Center habe ich unter den Optionen, so wie hier beschrieben,
http://www.bitadvisor.de/blog/?p=243#more-243
die Shortcuts auf die F-Tasten gelegt, brachte jedoch keinen Erfolg.

Danach bin ich die xsconsole vom Xen Server gegangen, dort ist unter
Keyboard und Timezone "German" angegeben, sollte also auch passen.

Bei der Clientinstallation der beiden Linuxe wurde definitiv deutsch als
Sprache und Keyboardlayout ausgewählt.

Woran kann das denn noch liegen?

Update: Der Bug besteht auch noch unter XenServer & Center 6.5
Lösung: "ALT GR" gedrückt halten, dann einmal kurz "STRG" drücken dann die Taste des gewünschten Zeichnen (also @, | oder \)


Gruß
TiTux
Mitglied: Reini82
02.07.2010 um 12:05 Uhr
Weiß der Beitrag ist schon älter aber hier ist mal eine Lösung

schnell hintereinander die Taste STRG + ALT GR + Sonderzeichen. Die Tasten müssen
aber wirklich schnell getippt werden, sonst klappt es nicht. Seltsame Variante, aber es geht.

Scheint nur bei Linux VM dass problem zu sein.

Gruß Reini
Bitte warten ..
Mitglied: Frank
09.04.2015, aktualisiert um 15:04 Uhr
Hi,

leider besteht der Bug auch noch nach fast 6 Jahren unter der aktuellen Version XenServer 6.5 & XenCenter 6.5 mit Linux VMs.

Aktuelle Lösung dazu:

"ALT GR" immer gedrückt halten, dann einmal zusätzlich kurz "STRG" drücken und dann noch die Taste des gewünschten Zeichnen (also q für @, < für | oder ß für \) drücken. Jetzt sollte das Sonderzeichen erscheinen. Wichtig: Dabei muss "ALT GR" immer gerückt bleiben.

Eine weitere Alternative ist:

ALT gedrückt lassen und im extra Zahlenblock rechts (number pad) die Nummern 6 und 4 tippen dann ALT loslassen. Jetzt erscheint das @ Zeichen.
Analog dazu: ALT gedrückt lassen und im extra Zahlenblock rechts die Nummern 1, 2 und 4 tippen dann ALT loslassen. Jetzt erscheint das | (pipe) Zeichen.

Gruß
Frank
Bitte warten ..
Ähnliche Inhalte
Hyper-V
Wechsel XenServer 6 auf Hyper-V 2016 (2)

Frage von Androxin zum Thema Hyper-V ...

Netzwerkgrundlagen
Linux VM als Gateway (5)

Frage von fundave3 zum Thema Netzwerkgrundlagen ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (16)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

CMS
Lokales Wordpress im LAN - wie aufsetzen? (16)

Frage von Static zum Thema CMS ...

LAN, WAN, Wireless
IP im privaten Netz nicht erreichbar (14)

Frage von guntis zum Thema LAN, WAN, Wireless ...

Windows Userverwaltung
gelöst Wie verfahrt Ihr mit den Windows-Benutzerkonten und -dateien von ausgeschiedenen Mitarbeitern? (14)

Frage von Bl0ckS1z3 zum Thema Windows Userverwaltung ...