Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Alter DFS Stamm zeigt Freigaben am Client nicht korrekt an. Neuer DFS Namespace allerdings schon

Frage Microsoft Windows Server

Mitglied: lipptown

lipptown (Level 1) - Jetzt verbinden

13.08.2011, aktualisiert 23:07 Uhr, 4939 Aufrufe, 3 Kommentare

Dies ist mein erster Post. Wenn ich was falsch gemacht habe, bitte nicht gleich den Kopf abreissen...;)

Hallo zusammen,

ich betreue derzeit IT technisch ein Berufskolleg mit derzeit zwei Standorten, ca 500 PC's und ca 7800 Benutzern (Laut AD wahrscheinlich aktuell eher weniger)
Die Standorte sind nur wenige Meter entfernt und über Wlan leitungsstabil miteinamder verbunden.
Die Schule nutzt Windows 2003 Server je Standort. Die Server sollen die Lehrer- und Schüler Profile und Homes nun über ein DFS bereitstellen. Dies wurde von einem vorherigen Dienstleister schon angefangen aber nicht zuende gebracht.

Wir aktualisierten die Server mit der R2 Erweiterung, um die neuen DFS-R bzw DFS-N Features nutzen zu können. Die Server sind soweit aktuell gepatcht.

Ausgangslage:
in allen Benutzerprofilen steht im AD Profil- und Home Pfad (LW-Buchstabe H: ) folgende Pfade:
\\<schuldomäne>\daten\profile\<benutzerart>\Manitory-Profile
\\<schuldomäne>\daten\homes\<benutzerart>\%username%

wobei <Benutzerart> für lehrer oder schüler steht

Im DFS ist der Namespace "daten" mit den Freigaben: "Homedaten" und "Profildaten". Im Dateisystem liegen die Daten unter:
e:\daten\homes\ bzw e:\daten\profile

Wenn jetzt ein Schüler oder Lehrer am XP Pro Client angemeldet wird, steht unter Netzlaufwerk H: nur "daten auf <Servername>" mit dem Inhalt der beiden Freigaben. In die Ordner "Homes" und "Profile" kommt jedoch man nicht. Zugriff verweigert.

Wir möchten nur ungern bei mehr als 7000 Benutzer die SharePfade im Benutzer anpassen, aber wir probierten das DFS komplett neu aufzubauen.
Wir wechselten den Namespace "daten" auf "DFS" und bauen die Freigaben wie oben beschrieben wieder auf.
also z.B.: \\domäne\DFS\homes\schüler\maxmuster

Der selbe account wurde wieder angemeldet, und siehe da, das home wurde korrekt gemapped.

Kann mir jmd sagen, warum das mit dem Stamm "Daten" nicht klappt?

Die Replikation im DFS wurde bis heute noch nicht konfiguriert.


Danke schon mal Vorab für alle Antworten.

Lipptown
Mitglied: redocomp
14.08.2011 um 09:35 Uhr
hi lippdown,

habt ihr denn überhaupt mal die bisherigen Berechtigungen für den "alten" Pfad geprüft...
Oder habt ihr einfach mal den entsprechenden User per Eingabe des Pfades im Explorer versucht zugreifen zu lassen?
Kommt dann auch Zugriff verweigert, dann könnte es an den Berechtigungen gelegen (liegen) haben.
Wie weit kommt ihr aus Usersicht bei der Pfadeingabe im Explorer \\domäne\dein\weiterer\pfad\ oder was vervollständigt der Explorer bzw. schlägt euch per Dropdown vor ?

Und jetzt bei dem neuen DFS habt ihr eben die Berechtigungen richtig gesetzt ...

Zusatzfrage: Arbeitet ihr mit ABE (Access Based Enumeration) oder auch Zugriffsbasierte Aufzählung für die Freigaben ?

redocomp
Bitte warten ..
Mitglied: lipptown
14.08.2011 um 14:16 Uhr
Hi redocomp,

ja, wir haben die Pfade beim User im Explorer eingetragen, um in die Tiefe der Verzeichniss Struktur zu browsen.
Wir kommen eben nur bis \\domäne\daten. Will man auf Homes oder Profile Ordner zugreifen (also quasi das DFSroot) kommt "zugriff verweigert".
Alle Freigaben sind mit "jeder" Vollzugriff berechtigt, bzw Admins voll, Benutzer lese uns schreib recht. So wie es im DFS Wizzard angeboten wird.

Beim aktuellen Stamm "DFS" ist die Berechtigung beigeblieben. Wie beschrieben, hierbei wird das Home korrekt beim User angezeigt und Bereichtigung ist auch korrekt.

Ich glaube nicht das wir ABE konfiguriert haben. Der User sieht auch andere Ordner, die er dann mit Zugriff verweigert nicht öffnen kann.

Beim googeln hab ich gelesen, das man WINS deaktivieren sollte bzw. den FQDN im DFS nutzen sollte. Das wollte ich morgen mal testen.
Mein Kollegen baut schon am Skript, die HOme und Profilpfade der Benutzer anzupassen. ;)

vielleicht hab ich morgen mehr Infos für euch.

so long


Lipptown
Bitte warten ..
Mitglied: redocomp
14.08.2011 um 15:11 Uhr
hi,

na dann bis morgen, viel Erfolg.
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows Server
gelöst Win10 Mail Client und Outlook Anywhere (7)

Frage von stolli zum Thema Windows Server ...

Batch & Shell
gelöst Batch mit Copy auf SBS2008 funktioniert nicht, auf Client geht es (9)

Frage von CyCOtt zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...