Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Anmeldescript bleibt stehen (W2k3-DC - Xp Clients)

Frage Microsoft Windows Server

Mitglied: chrisgurg

chrisgurg (Level 1) - Jetzt verbinden

15.02.2010, aktualisiert 10:13 Uhr, 4979 Aufrufe, 8 Kommentare

Hallo Admin-Kollegen,

ich bin mit meinem Latein am Ende und hoffe, ihr könnt mir helfen.

Umgebung / Ausgangspunkt:
Window Server 2003 Enterprise Server (SP2, aktuelle Updates)
Zwei DC's (Baugleiche Geräte)

Clients:
Windows XP SP3 Clients (aktuelle Updates dank WSUS)

Problem:
Wie schon in der Überschrift beschrieben, habe ich Probleme mit den Anmeldescripts ALLER Xp-User.
Nach dem Anmelden sollte ja normalerweise das Script für die Laufwerke durchlaufen.
Das Script wird nach dem Anmelden auch sofort ausgeführt, nur leider "hängt" es sich auf.
Man sieht dass er das erste Laufwerk verbinden will, nur hört er dann auf, das erste Laufwerk wird auch gar nicht verbunden.


Versuchte Lösungen:
- versch. Server ausprobiert (W2k, W2k3, W2k8) -> kein Erfolg
- GPO-Einstellungen (Beim Anmelden auf Netzwerk warten) -> kein Erfolg
- net time / andere Befehle ->kein Erfolg
- Rechte der Scripte angepasst -> kein Erfolg
- als Admin auführen lassen -> kein Erfolg
- versch. Benutzer -> kein Erfolg
- Antivirenclient (Server UND Client) kurzzeitig deaktiviert ->kein Erfolg

Sobald man das Script lokal auf den Rechner kopiert / per Hand vom Server ausführt, läuft das Script anstandslos durch und verbindet alle Laufwerke / Drucker / Zeit sync. / was auch immer man will.

Ich hoffe Ihr könnt einem mittlerweile verzweifelten Admin helfen...

Danke im Voraus,

CG.


PS: Was ich noch vergessen habe. Es passiert NUR bei den XP-Clients. Bei Vista / Windows7 laufen die Scripte ohne Probleme durch.
Mitglied: 60730
15.02.2010 um 10:46 Uhr
Moin

in solchen Fälle hilft es immer:

  • gings unter xp vorher
  • wurde was und wenn ja was geändert
  • wie sieht die Batch genau aus.

Gruß
Bitte warten ..
Mitglied: lykantroph
15.02.2010 um 10:49 Uhr
Servus,

Hast du eine simple Batchdatei geschrieben oder in VBS ?. Kannst mal das Skript hier posten?. Vielleicht spricht du in Skript gewisse Objekte so an das es unter XP nicht verstanden wird (Abwärtskompatibel)

lg

Florian
Bitte warten ..
Mitglied: chrisgurg
15.02.2010 um 11:02 Uhr
Also,

@TimoBeil:
1: sind neue DC's, sind die ersten XP-Clients in der Domäne. Aber bei gleichen Konfigurationen auf anderen DC's (z.B. Schulserver) klappt es.
2: es wurde nichts verändert.
3:
net use G: \\"servername"\"Freigabe"
net use B: \\"servename"\"Freigabe"

net time \\"servername" /set /yes

rundll32 printui.dll,PrintUIEntry /in /n \\"servername"\"Drucker"

Bei dem Script habe ich auch schon versucht, nur ein Laufwerk zu verbinden, haben das Net tim und Druckerverbindung herrausgenommen.
Also alle (meiner Kenntnis nach) Möglichkeiten ausprobiert.


@lykantroph
Ist eine ganz normale Batchdatei, kein VBS oder sonstiges.
Endung ist .bat.
Habe auch schon .cmd versucht.
-> gleiche Problem
Bitte warten ..
Mitglied: 60730
15.02.2010 um 11:23 Uhr
Moin,

das wird kompliziert...

Wenn da wirklich
01.
 G: \\"servername"\"Freigabe"
steht - dann nimm die " raus.

Ich behaupte mal - es liegt aber woanders.

  • Nimm mal die IP - statt des Namens.
  • führe Zeile für Zeile des Scriptes in einer Dosbox aus.

Ich vermute die Kisten sind geklaunt und kennen den DNS nicht
  • echo %logonserver%
  • echo %userdomain% - wenn das nur ein Name ohne Suffix ist dann
  • nslookup %userdomain%.suffix (loval/de was auch immer bei euch dias Domainsuffix ist) - ansonsten nur %userdomain%

Gruß
Bitte warten ..
Mitglied: chrisgurg
15.02.2010 um 11:44 Uhr
Moin,

natürlich stehen da keine " im Script

1: IP-Adresse benutzt -> kein Erfolg
2: Die einzelnen Zeilen in der Dos-Box auf dem Client funktionieren.
Das Script läuft auch ohne Probleme durch, wenn ich es per Hand vom Server ausführe oder wenn ich es lokal kopiere und ausführe.
Alles kein Problem. Nur beim Anmelden gibt es die Probleme.

DNS ist alle in Ordnung.
nslookup klappt ohne Probleme.
Es werden beiden DC's erkannt.

MfG
Bitte warten ..
Mitglied: 60730
15.02.2010 um 11:57 Uhr
na dann...

ist das "berühmte" warten auf das Netzwerk per GPO eingerichtet?
Bitte warten ..
Mitglied: chrisgurg
15.02.2010 um 12:03 Uhr
das war auch schon meine Idee.

Hat aber keine Besserung gebracht.
Bitte warten ..
Mitglied: 60730
15.02.2010 um 18:12 Uhr
Zitat von chrisgurg:
das war auch schon meine Idee.

Hat aber keine Besserung gebracht.

Bist du dir sicher?

gpresult

Mach doch spasseshalber mal ein

ping -n 30 localhost
als erste Zeile in das Loginskript

Wenn - das dauert aber - die nächsten zeilen abgearbeitet werden - dann liegts doch am nichtwarten auf das Netzwerk.

Denn wenn das Skript...
Das Script läuft auch ohne Probleme durch, wenn ich es per Hand vom Server ausführe oder wenn ich es lokal kopiere und ausführe.

kann es nur daran liegen...
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 7
(Netzwerk)Drucker druckt nur eine Seite und bleibt dann stehen (5)

Frage von harald.schmidt zum Thema Windows 7 ...

Windows 10
gelöst Windows 10-Upgrade bleibt bei 99 Prozent stehen (3)

Frage von achklein zum Thema Windows 10 ...

Windows Server
gelöst Windows Server 2012 bleibt beim Bootvorgang stehen (17)

Frage von Chrischer zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...