Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Anmeldescript wird fehlerhaft ausgeführt

Frage Microsoft Windows Userverwaltung

Mitglied: Fosco

Fosco (Level 1) - Jetzt verbinden

16.11.2006, aktualisiert 21.11.2006, 3671 Aufrufe, 3 Kommentare

Hallo zusammen...

Ich baue gerade ein Netzwerk für ein Vermittlungsinstitut auf. Dabei nutze ich ein Anmeldescript, mit dem ich Netzlaufwerke zuweise.

Diese sind abhängig von der Gruppenzugehörigkeit. Diese prüfe ich mittels dem Befehl ifmember ab. Zur Zeit ist zwar nur eine Gruppe aktiv, aber zwei weitere Gruppen und deren Laufwerke sind bereits eingerichtet.

Mein Script sieht wie folgt aus:

::Laufwerksmapping

net use m: /delete
net use n: /delete
net use o: /delete


ifmember Teilnehmer
if errorlevel 1 net use M: \\ifvc-fs\Allgemeines$

ifmember Verwaltung
if errorlevel 1 net use N: \\ifvc-fs\Verwaltung$

ifmember Coach-Gesamt
if errorlevel 1 net use o: \\ifvc-fs\Coaching$
Leider geschieht dabei folgendes:

Die Mitglieder der Gruppe "Teilnehmer" melden sich an. Dabei ist zu beobachten, das das Scipt abgearbeitet wird (in der Taskleiste ist das entsprechende Fenster zu sehen). Der Effekt ist allerdings dreigeteilt:

1. Fall
Der Teilnehmer bekommt gar kein Netzlaufwerk zugewiesen.

2. Fall
Der Teilnehmer bekommt das Laufwerk "Allgemeines$" zugewiesen.

3. Fall
Der Teilnehmer bekommt alle drei Laufwerke zugewiesen, kann aber den NTFS-Rechten entsprechend nur auf das Laufwerk "Allgemeines$" zugreifen. Der zugriff auf die beiden anderen Laufwerke werden (zurecht) verweigert.

Kann es sein, das der Errorlevel zwischen den "ifmember"-abfragen nicht zurückgesetzt wird?
Hab ich da etwas übersehen?

Wäre für Hilfe dankbar..

Gruß

Fosco
Mitglied: bastla
16.11.2006 um 15:28 Uhr
Hallo Fosco!

Vielleicht hilft dieses Thema (auch wegen des erwähnten alternativen Tools):
http://www.administrator.de/Gruppenzugeh%F6rigkeit_wird_von_IFMEMBER_se ...

HTH
bastla
Bitte warten ..
Mitglied: Biber
16.11.2006 um 16:19 Uhr
Moin Fosco,

willkommen im Forum.
Kann es sein, das der Errorlevel zwischen den "ifmember"-abfragen nicht zurückgesetzt wird?
Nein. Ich wäre der Letzte, der M$ in Schutz nimmt.
Und es ist schon hanebüchen (auf neudeutsch: strange) genug, dass ifmember.exe einen ErrorLevel von 1 zurückgibt, wenn der User ein Member ist. *kopfschüttel*
Aber zurück- bzw auf 0 gesetzt wird er wieder.

Hab ich da etwas übersehen?
Nein, ich erkenne auch keinen Grund.
Spiel bitte mal die "ifmember"-Abfragen am CMD-Prompt durch - unter der UserID, bei der es nicht klappt.
Gib bitte am Prompt ein
01.
>ifmember /v Teilnehmer || @echo istTeilnehmer 
02.
>ifmember/v Verwaltung || @echo istVerwaltung 
03.
>ifmember /v Coach-Gesamt || @echo istCoach

...und poste das Ergebnis.
Vielleicht kommt ja ein Errorlevel <>0 heraus, weil ifmember.exe gar nicht gefunden wird.

Gruß
Biber
Bitte warten ..
Mitglied: Fosco
21.11.2006 um 10:10 Uhr
Hallo...

erstmal danke euch beiden für die Tips. Sobald ich kann, werde ich da weitertesten, doch wird das noch etwas dauern, da ich nun erstmal ein Server-problem fixen muß. Dabei werde mir übrigens seit Montag die Freigaben aus dem Script immer weggehauen.

Aber sobald ich was neues weiß, melde ich mich.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...