Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Anmeldescript greift nur bei manchen Benutzern

Frage Microsoft Windows Netzwerk

Mitglied: Bl4ckJok3r

Bl4ckJok3r (Level 1) - Jetzt verbinden

18.06.2010 um 12:02 Uhr, 2817 Aufrufe, 2 Kommentare

Hallo zusammen!

ich habe mal wieder ein kleines Problem... Ich habe mir ein Anmeldescript gebaut und das möchte ich über eine GPO verteilen.
Die GPO greift zu 100% auf den entsprechenden Benutzern. Mit einem Testbenutzer, welcher kein Domäne-Administrator ist greift das Script auch einwandfrei.

Auf meinem Benutzer (Domäne-Admin) wird das Script anscheinend nicht ausgeführt. Die GPO greift jedoch.

Anfangs habe ich eine Sicherheitswarung erhalten wenn ich das Script ausgeführt habe. Dieses Problem habe ich mittlerweile auch beseitigt indem ich den Server aufdem das Script liegt in die Interneteinstellungen eingetragen habe.

Kann mir jemand bei dem Problem weiterhelfen?

Was ich deffinitiv sagen kann ist, dass das Script und die GPO zu 100% funktionieren.

Gruss
Dominik
Mitglied: agnw-sgnw
18.06.2010 um 13:22 Uhr
Hallo,

ich forsche schon länger an einem sehr ähnlichen Problem.
GPOs greifen, Anmeldescripte laufen. Aber nur zunächst !!

Die GPOs greifen immer überall, die per GPO zugewiesenen Anmeldescripte laufen auf XP Rechnern, auf W7 Rechnern laufen Sie irgendwann nur noch bei lokalen Administratoren.
Die Anmeldeskripte laufen dann auch noch bei normalen Benutzern, wenn Sie von Hand gestartet werden, oder im AD als Anmeldeskript eingetragen sind.
Es liegt nicht an der UAC, die ist völlig aus!
Es hat mit dem serverbasierten Profil zu tun.

Die Benutzer nutzen ein gemeinsames serverbasiertes Profil. Wenn dieses frisch von einem PC dorthin kopiert wurde (mit der entsprechenden Funktion) laufen die Anmeldescripte bei allen Benutzern.
Erst wenn das Profil einmal bearbeitet wurde (ntuser.man in ntuser.dat > am PC angemeldet > abgemeldet > ntuser.man wieder in ntuser.dat) werden die Anmeldeskripte am W7 Rechner nur noch von lokalen Administratoren abgearbeitet.
Die anderen GPOs greifen weiter.

FAZIT:
Bei der Bearbeitung der ntuser.dat durch den Admin wird irgend ein Eintrag gemacht, der anschließend verhindert, dass per GPO zugewiesene Anmeldeskripte ablaufen.
Es gibt also einen Registry-Schlüssel im HKEY_CURRENT_USER, der bei der Bearbeitung des serverbasierten Profils

Ich habe da bereits verzweifelt. Wer arbeitet auch schon mit serverbasierten Profilen
Wenn jemand noch einen Lösungsansatz hat, würde mich das mehr als freuen!

Klaus
Bitte warten ..
Mitglied: BigWim
18.06.2010 um 15:31 Uhr
Helfen kann ich nicht, aber wir arbeiten auch mit serverbasierten Profilen, allerdings nicht mit schreibgeschützten Profilen.

Wir nutzen W2K3 SE und würden merken, wenn die Loginscripte nicht laufen, weil der Favoritenpfad verbogen wird. Die User hätten sonst keine Einträge ....

Markus
Bitte warten ..
Neuester Wissensbeitrag
Router & Routing

192.168er Adresse im öffentlichen Netz

(2)

Erfahrungsbericht von visco-c zum Thema Router & Routing ...

Ähnliche Inhalte
Windows Userverwaltung
gelöst Active Directory Migration von Benutzern (8)

Frage von JimPiet zum Thema Windows Userverwaltung ...

Erkennung und -Abwehr
Sicherheit: Malware greift Router durch Smartphones an

Link von Frank zum Thema Erkennung und -Abwehr ...

Windows Server
Aktivierung TLS - GPO - Webseite greift nicht auf TLS zurück

Frage von Martin89 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (29)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (22)

Frage von Driphex zum Thema Exchange Server ...

Hyper-V
HYPER V und USB (16)

Frage von Hendrik2586 zum Thema Hyper-V ...

SAN, NAS, DAS
Backupserver für KMU (14)

Frage von Leo-le zum Thema SAN, NAS, DAS ...