Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Anmeldescript login.bat wird ab und zu nicht ausgeführt

Frage Netzwerke LAN, WAN, Wireless

Mitglied: AndreasGrothe

AndreasGrothe (Level 1) - Jetzt verbinden

14.10.2008, aktualisiert 18:35 Uhr, 11099 Aufrufe, 6 Kommentare

Hallo zusammen,

habe hier eine Windows Domäne und habe bei einigen PC täglich das Problem, dass das Anmeldescript nicht ausgeführt wird.
An einigen Tagen klappt es und dann mal wieder nicht der Anwender klickt auch nicht das schwarze dos fenster weg.

Danke für jeden Tipp.
Mitglied: mexx
14.10.2008 um 11:31 Uhr
Was sagen denn die Ereignisprotokolle auf den Clients und auf den Server?
Was passiert denn alles in den Script?
Bitte warten ..
Mitglied: AndreasGrothe
14.10.2008 um 12:20 Uhr
Hallo,

es sollen mehrere Netzlaufwerke verbunden werden. Im Ereignisprotokoll steht nichts.
Bitte warten ..
Mitglied: mexx
14.10.2008 um 13:14 Uhr
Guck Dir mal dieses Beispiel-Script ein.

net use S: "Netzpfad" /PERSISTENT:NO >>"\\FS01\net_logs$\Anmeldungen\logon_%USERNAME%.log" 2>&1

Durch diese Anweisung siehst Du eventuelle Fehlermeldungen, welche beim Ausführen des Befehls NET USE entstehen. Wahrscheinlich passiert da gelegentlich ein Fehler. Kannst ja mal Dein Script posten.
Bitte warten ..
Mitglied: AndreasGrothe
14.10.2008 um 13:43 Uhr
rem Anmeldescript für TEST-Mitarbeiter

net use u: /delete
net use v: /delete
net use x: /delete
net use t: /delete

net use u: \\EXCHANGE\%USERNAME% /persistent:no
net use t: \\TEST\abt /persistent:no
net use v: \\EL-FS\data /persistent:no
net use x: \\dbff\Flowfact-AG /persistent:no

REM ci-sign ausführen...
\\TEST\NETLOGON\ci-sign_1\ci-sign-net.vbs

REM Uhrzeit setzen

net time \\dc-eldisy /set /yes
Bitte warten ..
Mitglied: mexx
14.10.2008 um 14:01 Uhr
Hmmm, nix, was falsch ist. Vielleicht nimmst Du mal das Visual Script raus, auch net time. Dann mal ausprobieren. Das ganze anders herum. Alle net use raus nehmen. Ist halt schwer zu replizieren. Füge mal in jeden Befehl die Doku mit ein. Mal sehen, was dabei rauskommt.
Bitte warten ..
Mitglied: 60730
14.10.2008 um 18:35 Uhr
Servus,


Zitat von AndreasGrothe:
01.
rem Anmeldescript für TEST-Mitarbeiter 
02.
rem nur dann die Laufwerke trennen - wenn Sie auch vorhanden sind - oder zumindestens die "Fehlermeldung" in Device Null umleiten (oder beides). 
03.
 
04.
if exist n:\>nul net use u: /delete >nul 
05.
if exist v:\>nul net use v: /delete >nul 
06.
if exist t:\>nul net use x: /delete >nul 
07.
if exist t:\>nul net use t: /delete >nul 
08.
 
09.
net use u: \\EXCHANGE\%USERNAME% /persistent:no 
10.
net use t: \\TEST\abt /persistent:no 
11.
net use v: \\EL-FS\data /persistent:no 
12.
net use x: \\dbff\Flowfact-AG /persistent:no 
13.
 
14.
REM ci-sign ausführen... 
15.
\\TEST\NETLOGON\ci-sign_1\ci-sign-net.vbs 
16.
 
17.
REM Uhrzeit setzen 
18.
 
19.
net time \\dc-eldisy /set /yes
Das wäre schon mal "besser" als dein bisheriges - obwohl die Ursache, daß das Script nicht gestartet wird - woanders liegt.

Schau mal in der GPO, ob Loginscripte synchron verarbeitet werden und ob der Client auf das Netzwerk warten soll.
Beide Einstellungen sind meistens die Problemlöser für deinen und ähnliche Fälle.

Ps: "Loginscripte" schreibt man am "schönsten" mit Kixtart

Gruß

Ps: In Zeile 9 wird davon ausgegangen, daß du für jeden User eine Freigabe hast?
Auch das ist eher subotimal, oder liegt der "bock" in einer "anonymisierten Zeile des Scripts verborgen?
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
Windows Server
gelöst Login .bat funktioniert nicht immer (5)

Frage von xtra-long zum Thema Windows Server ...

Windows 10
Nonstop Login im Sperrbildschirm (4)

Frage von TiCar zum Thema Windows 10 ...

Microsoft Office
gelöst Makro wird beim öffnen Vorlage nicht ausgeführt (8)

Frage von Sunny89 zum Thema Microsoft Office ...

Batch & Shell
Mehrere.csv Dateien zusammenfügen zu einer Datei mit bat (4)

Frage von Piotrney zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...