Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Anmeldung an SharePoint mit aktuellen Anmeldedaten

Frage Microsoft Windows Server

Mitglied: RicoPausB

RicoPausB (Level 1) - Jetzt verbinden

26.11.2013 um 11:11 Uhr, 3111 Aufrufe, 4 Kommentare

moinmoin ...

... die Authentifizierungsgeschichte beim SharePoint 2013 Foundation habe ich noch nicht ganz verinnerlicht, fürchte ich ...

Der SharePoint läuft und ist von extern erreichbar. (https://shares.externedomain.tld)
Lokal läuft der SharePoint allerdings auf der Domain local.lan

Melde ich mich nun von extern an wird ja immer das Login "local\user" verlangt.
Allerdings wird ja immer computername\user übergeben.

Wir haben hier einige Heim-Arbeitsplätze, bei denen die Anmeldung mit dem lokalen Benutzernamen automatisch erfolgen soll.

Mit den alten WSS3-services konnte ich via Basic-Auth die Domain "forcen", sofern https://shares.externedomain.tld in der Zone "lokales Intranet" lag und die Anmeldung mit den aktuellen Anmeldedaten aktiviert ist.

Mit dem 2013 klappt das aber nicht ...

Hat zufällig irgendjemand etwas ähnliches am Laufen und könnte mir irgendwie auf die Sprünge helfen?
Bin für jeden Tipp dankbar ...

Der Rico
Mitglied: DerWoWusste
26.11.2013 um 11:39 Uhr
Hi.

Ich schätze, du kannst einfach die Browserauthentifizierung abspeichern. Also für die Seite local\user plus Kennwort einspeichern.
Bitte warten ..
Mitglied: RicoPausB
26.11.2013 um 11:48 Uhr
jep ... das klappt ...

aber das war nicht das Ziel meiner Frage ;)

Ich bin ursprünglich davon ausgegangen, dass ich die IIS-Site um Basic-Auth mit SSL erweitern kann, um somit dann eine "forced-domain" zu setzen.
Das klappt aber nicht ... oder ich habe hier einen Denkfehler bei der Config ...

Sobald ich das aktiviere, lande ich in einer Anmelde-Schleife in der ich permanent nach dem login gefragt werde ...
Ich weiss leider nicht, ob das "nur" am IIS liegt oder an der claims-auth vom sharepoint ...
Bitte warten ..
Mitglied: Texas3110
26.11.2013 um 18:35 Uhr
Wo hast Du die Einstellungen gesetzt? Im SharePoint oder im IIS? Eigentlich sollten alle Einstellungen nur im SharePoint vorgenommen werden.

Das richtige Vorgehen ist hier eine WebApplication für internen Zugriff zu erstellen. Diese per HTTP anzubinden (Standard / Default Zone). Dann die WebApplication erweitern und per HTTPS anzubinden. HTTPS gibst Du dann nach außen frei. So können sich die internen User per HTTP anmelden (brauchst Du auch für die Suche) und von aussen kommst Du per HTTPS drauf. Alle Einstellungen kannst Du im SharePoint vornehmen. Im IIS musst Du nur das Zertifikat einbinden.

Gruß
Stefan
Bitte warten ..
Mitglied: RicoPausB
01.12.2014 um 12:06 Uhr
Zitat von Texas3110:

Wo hast Du die Einstellungen gesetzt? Im SharePoint oder im IIS? Eigentlich sollten alle Einstellungen nur im SharePoint
vorgenommen werden.

Das richtige Vorgehen ist hier eine WebApplication für internen Zugriff zu erstellen. Diese per HTTP anzubinden (Standard /
Default Zone).

denke, das habe ich geschafft.
Unter Webanwendungen verwalten steht:
Name: SharePoint - 80
URL: http://srvshare/
Port: 80

Dann die WebApplication erweitern und per HTTPS anzubinden.
HTTPS gibst Du dann nach außen frei.

hoffe, ich habe das richtig verstanden ...

Zentraladministration:
- Webanwendung markiert und "Erweitert" angewählt
- als Name "SharePoint - 443" und auch Port 443 verwendet
- Haken bei "SSL verwenden" gesetzt
- Haken bei "Windows-Authentifizierung aktivieren" und "Basisauthentifizierung" gesetzt
- als öffentliche URL entsprechend die öffentliche URL eintragen "https://srvshare.meinedomain.tld:443"
- als Zone "Internet" ausgewählt

IIS:
- Die Site "SharePoint - 443" markiert
- unter Bindungen das entsprechende Zertifikat ausgewählt
- unter Authentifizierung die Standardauthentifizierung bearbeitet und als Default Domain die domain hinterlegt.
- IIS via conlose neu gestartet mit "iisreset /noforce"

Client (WIN 7 x64) für Zugriff von extern:
- IE gestartet und "https://shares.meinedomain.tld" den "Vertrauenswürdigen Sites" hinzugefügt
- Die Stufe angepasst auf "Anmeldungen mit aktuellem Benutzernamen und Kennwort"
- IE neu gestartet

- Registry angepasst:
- Schlüssel hinzugefügt unter HKLM\SYSTEM\CurrentControlSet\ services\WebClient\Parameters: (Mult-String) “AuthForwardServerList” und entsprechend die URL "https://shares.meinedomain.tld"

So können sich die internen User per HTTP anmelden (brauchst Du auch für die Suche) und von aussen kommst Du per HTTPS
drauf. Alle Einstellungen kannst Du im SharePoint vornehmen. Im IIS musst Du nur das Zertifikat einbinden.

Problem besteht weiterhin ...
Trotz Basic Auth wird weiterhin nach Benutzerdaten gefragt ...

Selbiges Problem auch von einem internen Client, der zum Aufruf allerdings die interne URL verwendet.

Noch jemand eine Idee?

Der Rico
Bitte warten ..
Ähnliche Inhalte
E-Mail
gelöst Thunderbird akzeptiert Exchange-Anmeldedaten nicht (5)

Frage von honeybee zum Thema E-Mail ...

Microsoft
gelöst RemoteApp Anmeldedaten lassen sich bei Win7 nicht abspeichern (8)

Frage von thomasreischer zum Thema Microsoft ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
CNC Maschinen verlieren Netzwerkverbindung (kurioser Fehler) (21)

Frage von NoHopeNoFear zum Thema LAN, WAN, Wireless ...

Webentwicklung
Aktuellen Mitarbeiter auf Homepage anzeigen (12)

Frage von alemanne21 zum Thema Webentwicklung ...