Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Anonyme Freigabe mit 2008 Server als Client UND Server

Frage Microsoft Windows Server

Mitglied: sebezahn

sebezahn (Level 1) - Jetzt verbinden

07.09.2009, aktualisiert 13:56 Uhr, 14940 Aufrufe, 8 Kommentare

Einloggen in eine Netzwerkfreigabe ohne Passwort muss möglich sein. Windows 2008 Server fragt aber immer nach Benutzernamen/Passwort.

Hallo alle,

ich bitte wirklich um Hilfe und habe auch hier und woanders gesucht und gesucht, aber das Szenario ist immer anders. Folgendes:

Ich habe zwei Windows 2008 Server, beide ohne Domaincontroller, einfache Server. Beide sind im gleichen Subnetz. Der eine Server "backend" hat eine Freigabe "daten", der andere Server "frontend" soll auf diese Freigabe zugreifen. Das funktioniert auch soweit. Allerdings soll nun diese Freigabe ohne Benutzername und Passwort stattfinden. Daher habe ich im "backend" den Gast-Account aktiviert und die Freigabe daran gehangen.

Wenn ich jetzt auf dem Server "frontend" folgendes eingebe: "\\backend\daten" kommt immer noch eine Passwortabfrage, die ich mit Benutzernamen "gast" und ohne passwort beantworten kann. Wenn ich das gleiche von einem XP-Rechner im gleichen Netz mache, kommt hingegen KEINE Passwortabfrage, sondern direkt die Anzeige der Daten.

Das Problem ist, dass ein Dienst, genaugenommen ein Apache, auf die Freigabe zugreifen muss, auch wenn gar kein User eingeloggt ist.a

Wenn jemand weiß, wie man das lösen kann, dann bitte ich vielmals um Nachricht! Ich suche mir in der Zeit weiterhin ein Wolf.

Gruß
Sebezahn
Mitglied: tha-a
07.09.2009 um 14:26 Uhr
unterschiedliche Rechtestrucktur Linux / Windows

1. bei 2008 Firewall prüfen (kann eingehende und ausgehende dienste) ich vermute mal der Diesnt kommt über einen bestimmten Port!

2. welches Profil der Netzwerkkarte (LAN) besitzt der W2k8 Server backend? daraus ergibt sich die einstellung der firewall --> wenn ein öffentliches netzwerk ist (was standard ist) würde ich ein arbeitplatzproifl geben --> Netzwerkcenter / Freigabe ---> profil zuweisen

kannst du dem Dienst nicht einen Benutzer hinterlegen mit dem er gestartet wird --> damit der Dienst dann via hinterlegten Benutzer zugreift --> denn Gast würde ich nicht nutzen ist ja dann offenes System!
Bitte warten ..
Mitglied: sebezahn
07.09.2009 um 20:44 Uhr
Hi,

danke schon einmal für die Antwort. Nein, an der Firewall liegt es nicht. Die Freigabe funktioniert ja, ich komme von einem Server auf den anderen, allerdings halt nur nach Abfrage des Passworts. Es wundert mich nur, dass es von einem XP-Rechner aus direkt geht ohne Passwortanfrage, so als würde der den Gast-Account direkt abklopfen.

Über die Sicherheit mache ich mir nicht so viele Sorgen, das System läuft nur intern ohne Kontakt zur Außenwelt.

Das mit dem Benutzer für den Dienst habe ich mir auch schon überlegt. Allerdings sollte das die letzte Lösung sein. Windows 2008 scheint einfach davon auszugehen, dass man vielleicht den Gast-Benutzer nicht benutzen will... Kann man ihm das abgewöhnen?

Gruß
Sebezahn
Bitte warten ..
Mitglied: DerWoWusste
08.09.2009 um 00:03 Uhr
Seit xp ist die Verwendung von Konten ohne Kennwort im Netzwerk nicht erlaubt (per default), dies lässt sich abstellen.
secpol.msc - lokale Richtlinien - Sicherheitsoptionen - (hier engl. :"Accounts: Limit local account use of blank passwords to console logon only") deaktivieren.
Bitte warten ..
Mitglied: DerWoWusste
08.09.2009 um 07:24 Uhr
Wenn ich's mir recht überlege, ist der Fall ein anderer: Bei xp wird's klappen, weil da selbst bei pro per default "forceguest" gesetzt ist, auch "einfache Dateifreigabe" genannt. Siehe http://www.sophos.com/support/knowledgebase/article/12837.html (in 2008 heißt es in den Ordneroptionen (engl.) "use sharing wizard"=simple file sharing an).
Bitte warten ..
Mitglied: sebezahn
08.09.2009 um 10:46 Uhr
Hi,

danke vielmals, das bringt mich zumindest mental ein wenig weiter. Aber leider noch nicht zur Lösung. Ich habe im Client nun "forceguest" auf 1 gesetzt. Neu gestartet, leider überhaupt kein Effekt. Auch die Ordneroption "use wizard" ist eingeschaltet. Dennoch verlangt er immer nach einem Benutzernamen/Passwort.

Ich habe als Client jetzt einen Vista-Rechner benutzt und siehe da, der fragt nicht, sondern öffnet die Freigabe direkt. In dessen Registry allerdings ist "forceguest" auf 0... Ich verstehe die MS-Welt nicht mehr! Auch die anderen Reg-Einstellungen sind an der Stelle identisch.

Alternativ könnte ich auch die Freigaben beim Start des Rechners bereits verbinden, aber geht das überhaupt, wenn man sich gar nicht einloggt? (Muss gestehen, dass ich danach noch nicht gesucht habe, was ich jetzt direkt nachhole...) Die andere Lösung der komplett authentifizierungsfreien Anmeldung wäre mir aber lieber.

Danke vielmals für die Hilfe!
Sebezahn
Bitte warten ..
Mitglied: tha-a
08.09.2009 um 13:55 Uhr
also ist der port für den dienst nicht an der firewall gescheitert ... richtig!

du muss XP einmal das kennwort hinterlegt haben ...merkt sich es ja dann!

man kann bei w2k8 auch netzwerkkennwörter hinterlegen --> das würde ich machen.
standardmäßig ist der gastaccount ja auch deaktiviert d.h. man kann davon ausgehen das windows ihn nicht haben will!

ist die freigabe über den assistenten gemacht worden oder hast du die (laut MS empfl.) freigabe raus genommen (ordnereigenschaften?)
Bitte warten ..
Mitglied: DerWoWusste
09.09.2009 um 22:55 Uhr
Hi. Ich hab's getestet (2 neue, naturbelassene 2008er Server auf vmware) und es läuft so:

Der Server mit der Freigabe heißt A.
-Über den Wizard Testfreigabe auf A für das Konto Gast erstellt (vorher auf X aktiviert: Konto Gast/Guest). Kennwort vom Gast ist default immer leer.
-bei der Installation des Servers X erstelltes Konto Administrator hat ein Kennwort (Test123)

Nun kommt's: Zugriff von einem weiteren 2008er Server (B) aus, ist nur dann ohne Kennwort möglich,
-wenn das zugreifende Konto entweder auf dem Zielrechner nicht existiert oder aber dort deaktiviert ist.
Nochmal:
Windows (egal ob Vista oder 2008 oder...) nimmt immer den Nutzer, der angemeldet ist und schickt sein Kennwort automatisch mit. Ist es falsch, wird nachgefragt. Ist der Nutzer deaktiviert oder auf dem Zielsystem nicht vorhanden, wird das Gastkonto versucht - und das gelingt dann in Standardeinstellungen OHNE Rückfrage, da ohne Kennwort.
Bitte warten ..
Mitglied: sebezahn
10.09.2009 um 07:56 Uhr
Hi,

vielen Dank fuer Eure Muehen, besonders DerDaWusste, aber auch alle anderen! Ich habe es nun hinbekommen, nachdem ich ebenfalls die Gast-Konten aktiviert bzw. deaktiviert hatte.

Zwischenzeitlich hatte ich noch eine andere Loesung: Ich hatte per Skript eine Laufwerksverbing per net use gemappt und danach den Dienst, der zugreifen sollte, gestartet. Das ganze Script hatte ich dann per Taskscheduler als SYSTEM gestartet. Hat funktioniert, und ich kann sogar Kennwoerter verwenden. Beides hat seinen Charme...

Nochmals vielen Dank!
Sebezahn
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...