Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Anonymer Zugriff auf Website via IIS 6.0 klappt nicht!

Frage Microsoft Windows Server

Mitglied: Lensen

Lensen (Level 1) - Jetzt verbinden

07.02.2008, aktualisiert 08.02.2008, 8945 Aufrufe, 2 Kommentare

Hallo,

also vll bin ich gard einfach zu dumm, aber ich bekomme es nicht hin.
Ich habe heute zum erstmal versucht unter Windows 2003 Server Enterprise Edition mit Hilfe des IIS einen Webserver zum laufen zu bekommen. Aber irgendwie stehe ich kurz davor wieder Apache zu benutzen.

Also zu meinen Problem: Ich bekomme keinen anonymen Zugriff! Ich hab schon die MS Anleitung gelesen - dann hier die im Forum aber keine Chance. Bekomme immer:
Die eingegebenen Anmeldeinformationen berechtigen Sie nicht zum Anzeigen dieses Verzeichnisses bzw. dieser Seite.
HTTP-Fehler 401.1 - Nicht autorisiert: Der Zugriff wurde aufgrund ungültiger Anmeldeinformationen verweigert.)


Sobald ich Integrierte Windows Authentifizierung aktiviere kann ich mich mit dem Adminzugang einloggen und bekomme das zusehen was ich möchte. PHP läuft ebenfalls.

Als Anonymen User haben ich :
IUSR_* zugefügt.

Hab schon mit den Dateiberechtigungen rumgespielt. Hat aber leider keinen Erfolg.
Woran könnte es liegen ? Gibts da einen Geheimtrick ? ;D
Habe wie gesagt mehrfach schon nach Diversen ANleitungen den Einrichtungsvorgang wiederholt.

Danke schonmal

Edit:

So nach ein wenig basteln ist as so:
Ich bekomme wenn ich gast eintrage anstat den ISUR zugriff ohne Passwort abfrage!
Allerdings nciht auf PHP dateien diese mus sich anch wie vor via Administrator ansprechen damit sie funktionieren?
Mitglied: Dani
08.02.2008 um 11:01 Uhr
Hi Lensen,
das mag jetzt vllt. komisch klingen...aber wenn du den IIS ( => NICHT DIE ISS) installierst und nichts dran änderst, klappt der normale (ano.) Zugriff ohne Probleme.

Der IUSR ist der Schlüssel, er hat ein zufälliges Passwort. Sprich, diesen User nicht verändern! Den Gastbenutzer als Lösung zu benutzen, ist nicht im SInne des Erfinders.

Wichtig ist, dass du beim Eintragen von Benutzer im Reiter "Sicherheit" immer die vergebenen Rechte übernimmst und nach unten durchvererbst. Das Ganze kannst du über den Reiter "Erweitet" durchführen.


Grüße
Dani
Bitte warten ..
Mitglied: Lensen
08.02.2008 um 11:55 Uhr
Ja ich finde es komisch. Den Benutzer hab ich nie Verändert, denke ich
Kann ich den Benutzer irgendwie auf Standard zurücksetzen ?
Eigentlich stelle ich mich auch nicht so Blöd an, hab nun als Zwischenlösungen einen Apache 2.2 installiert. Der läuft einwandfrei. Wollte aber zur Übung mal den IIS benutzen, wenn die FH mir schon mal eine Windows 2003 Enterprise Lizenz stellt :D
Wie gesagt hab ziemlich alles ausprobiert, aber mit dem ISUR keine chance auf zugriff. Mit gast wie gesagt ging es aber kein PHP. Nur mit Admin plus Passwort ging alles einwandfrei!
Ich hab mich wie gesagt an die MS doku gehalten.
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk
gelöst Anonymer Zugriff auf Netzlaufwerk für WSUS Offline (5)

Frage von hannsgmaulwurf zum Thema Windows Netzwerk ...

Windows Server
gelöst IIS Zugriff über Zertifikat oder IP Restriction (3)

Frage von Broderick zum Thema Windows Server ...

Windows Server
Kein Zugriff mehr auf IIS über HTTPS (1)

Frage von Herbrich19 zum Thema Windows Server ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...

E-Business
Wo tragt ihr eure privaten Termine ein? (13)

Frage von honeybee zum Thema E-Business ...

Batch & Shell
Batch zum suchen und verschieben von Verknüpfungen (12)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Windows Server
Terminalserver starten willkürlich neu (12)

Frage von thaefliger zum Thema Windows Server ...