Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Anwendungen nacheinander starten

Frage Entwicklung Batch & Shell

Mitglied: TCO04

TCO04 (Level 1) - Jetzt verbinden

16.09.2005, aktualisiert 17.10.2012, 12944 Aufrufe, 9 Kommentare

habe mehrere setup-dateien zu starten, welche ich per "start.cmd" autostarten will.

setup 1 = start
setup 2 = erst nach setup1
setup 3 = erst nach setup2
setup 4 = erst nach setup3
usw.

wer kann mir helfen bzw. ein beispielscript schreiben?
Mitglied: 16640
16.09.2005 um 23:38 Uhr
start /wait setup1.exe
start /wait setup2.exe
...
etc.
Bitte warten ..
Mitglied: TCO04
18.09.2005 um 17:15 Uhr
Hallo, ich habe alles so eingegeben. Trotzdem starten die setups hintereinenander, ohne das Ende des voherigen setup abzuwarten. Woran könnte das liegen?

Gruß
TCO04
Bitte warten ..
Mitglied: Biber
18.09.2005 um 19:59 Uhr
Moin, TCO04,

ist nicht Dein Fehler. Da scheint die M$-Doku von "Start /wait in Batchdateien" nicht zu stimmen.

Soll laut Doku: "Start /wait WinGuiProggi" wartet in einer Batchdatei, bis WinGuiProggi fertig ist.

Ist: es wartet nicht.

Workarounds:
a) entweder Setup2.exe erst starten, wenn Setup1 ein Ergebnis geliefert hat (ein Setup-Log zum Beispiel). Kannst Du im Batch mit "if exist ...setup1.log prüfen.
b) Setup2.exe erst starten, wenn Setup1 nicht mehr in der Prozessliste steht.
c) Von M$ einen Bugfix anfordern

Frank / der Biber aus Bremen
Bitte warten ..
Mitglied: 16640
18.09.2005 um 20:15 Uhr
Hi Biber,

das war mir neu - ich verwende hier seit Jahren den 4NT-Kommandoprozessor, der das problemlos beherrscht. Daher ist mir dieses Fehlverhalten überhaupt nicht bekannt gewesen. Werd' ich mir merken. Thx.

dba
Bitte warten ..
Mitglied: Biber
18.09.2005, aktualisiert 17.10.2012
@16640
Ich habe es auch nur durch Zufall vor zwei Wochen durch einen <a href=http://www.administrator.de/forum/prograam-starten-in-batchdatei-und-au ... target="blank">anderen Forumsbeitrag </a> mitbekommen.
Habe aber immer noch die stille Hoffnung, dass ich nur das nicht verstehe, was M$ scherzhaft "Hilfe" nennt.

Normalerweise müssten doch einige hier im Forum solche Scriptchen basteln, die auf wehrlose Clients nacheinander KB000815 bis KB004711 draufnudeln sollen. Wie schaffen die das?

Biber
Bitte warten ..
Mitglied: 16640
19.09.2005 um 09:07 Uhr
Moin zusammen,

ich hab' ja keine Ruhe gefunden ... und zumindest für meine Konfiguration hier im Office kann ich das Gesagte jetzt nicht bestätigen.

Der Kommandoprozessor hier meldet sich auf meinem W2KPro:

<font class="code">
Microsoft Windows 2000 [Version 5.00.2195]
</font>

und ein CMD-File mit folgenden Inhalt:

<font class="code">
start /wait c:\winnt\system32\notepad.exe
start /wait .\start2.bat
start /wait c:\winnt\system32\freecell.exe
</font>

wobei start2.bat diesen Inhalt hat:

<font class="code">
echo Hallo!
pause
exit
</font>

Das alles tut hier wie's soll. Erst wenn Notepad geschlossen wird, kommt das zweite Commandfenster mit dem 'Hallo' und wartet auf einen Tastendruck, bevor Freecell gestartet wird.

Ich kann später am Tage das nochmal auf einem XP oder W2K3 nachvollziehen, aber so ist der Stand zu Zeit.

dba
Bitte warten ..
Mitglied: Biber
19.09.2005 um 12:25 Uhr
@16640
Merkwürdig...

Dann wären für mich nur zwei weitere Erklärungen plausibel:
1) das Verhalten des CMD-Interpreters variiert tatsächlich (abhängig von irgendwelchen RegKeys oder deren Seiteneffekten)
2) Oder er verhält sich "richtig", d.h. die Setup1.exe IST beendet, aber von ihr gestartete Tochter-Prozesse ("Install.exe", "Rumrödel.exe") laufen noch und machen die eigentliche Arbeit.

Halte jedenfalls die Schilderungen von TCO04 und thavron für glaubwürdig.

Lese weiter interessiert mit.

Biber
Bitte warten ..
Mitglied: 16640
19.09.2005 um 12:40 Uhr
2) Oder er verhält sich
"richtig", d.h. die Setup1.exe IST
beendet, aber von ihr gestartete
Tochter-Prozesse ("Install.exe",
"Rumrödel.exe") laufen noch
und machen die eigentliche Arbeit.

Das klingt gut! Probier ich heute abend mal aus, will nicht unbedingt die Produktivsysteme hier so verhunzen


dba
Bitte warten ..
Mitglied: 16640
20.09.2005 um 05:58 Uhr
So, hier nochmal auf XP Pro und W2K3 ausprobiert - verhält sich wie gewollt. Scheint also Bibers Vermutung zu bestätigen.

CMD-Versionen, unter denen es funktioniert:

XP: Microsoft Windows XP [Version 5.1.2600]
W2K3: Microsoft Windows [Version 5.2.3790]
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows 7
Linux über Windows 7 Bootloader starten (4)

Frage von oecke77 zum Thema Windows 7 ...

Windows Installation
PXE Boot-Von CD Starten (2)

Frage von STITDK zum Thema Windows Installation ...

Windows 7
Dataline Office benötigt zum starten Admin-Rechte (3)

Frage von ingoue zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (14)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...