Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Anwendungsproblem auf Citrix Server (Windows Server 2003)

Frage Netzwerke Cluster

Mitglied: Admin580

Admin580 (Level 1) - Jetzt verbinden

30.07.2008, aktualisiert 31.07.2008, 9863 Aufrufe, 3 Kommentare

Hallo zusammen,

ich habe große Probleme mit einer Anwendung auf unseren Citrix-Servern. Ich versuche mal, mein Problem zu schildern und hoffe, dass vielleicht einer von Euch 'ne Idee oder 'nen Tipp hat, was ich noch probieren könnte.

Also... wir haben zwei Citrix-Server (Presentation Server 4.5) in einer Farm. Dort sind diverse Anwendungen (Office, Notes usw.) installiert. U.a. auch ein Programm des Rechenzentrums (eigentlich das wichtigste Programm). Seit einigen Tagen kommt beim Aufruf immer "Beim Start des "Programms" ist eine Exception aufgetreten. Zugriff verweigert. Das Programm wird beendet." Ich bin mir eigentlich sicher, dass wir an der Konfiguration nichts verändert haben.

Lt. Rechenzentrum kann es an der Anwendung selbst nicht liegen. Habe es auch selbst getestet: Wenn ich mit Adminrechten angemeldet bin, funktioniert auch alles reibungslos. Nur als "Normal-User" läufts nicht. Also müsste es ja mit den Rechten zu tun haben. Die Zugriffsrechte auf den Programmverzeichnissen habe ich überprüft -> alles i.O.

Nun habe ich mir mal die Ereignisanzeige etwas genauer angeschaut. Dort tauchen folgende Fehler auf:

Quelle: Folder Redirection
Ereignis-ID: 111
Die Ordnerumleitungsrichtlinie konnte nicht angewendet werden. Die Initialisierung ist fehlgeschlagen.
Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.

UND

Quelle: Userenv
Ereignis-ID: 1085
Die clientseitige Erweiterung Folder Redirection der Gruppenrichtlinien konnte nicht ausgeführt werden. Überprüfen Sie, ob diese Erweiterung bereits früher Fehler verursacht hat.
Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.

So, dann habe ich noch die Ausgabe des Befehls GPRESULT (habe ich als Lösungsansatz auf thomaskoetzing.de gefunden). Diesen Befehl habe ich einmal mit einem Account ausgeführt wo es funktioniert (also Admin..) und einmal, wo es nicht funktioniert. Danach sieht es aus, als ob die Richtlinien nicht gezogen werden. Hier die Werte:

1. Profil, wo es nicht läuft:

Betriebssystem Microsoft (R) Windows (R) Gruppenrichtlinienergebnis-Tool v2.0
Copyright (C) Microsoft Corp. 1981-2001

Am 30.07.2008, um 12:06:36 erstellt



RSOP-Daten fr xxx\User auf CITRIX: Protokollmodus
Betriebssystemtyp: Microsoft(R) Windows(R) Server 2003 Standard Edition
Betriebssystemkonfiguration: Mitgliedsserver
Betriebssystemversion: 5.2.3790
Terminalservermodus: Anwendungsserver
Standortname: Ort
Zwischengespeichertes Profil:\\Server\profiles\User
Lokales Profil: C:\Dokumente und Einstellungen\User
Langsame Verbindung? Nein


BENUTZEREINSTELLUNGEN
CN=User ohne Adminrechte,OU=1234,OU=3456,DC=xxx,DC=yyy,DC=zzz,DC=de
Letzte Gruppenrichtlinienanwendung: Nicht zutreffend
Gruppenrichtlinieanwendung von: Nicht zutreffend
Schwellenwert fr langsame Verbindung:500 kbps
Dom„nenname: xxx
Dom„nentyp: Windows 2000

Angewendete Gruppenrichtlinienobjekte
--------------------------------------
Internetuser
Default Domain Policy

Folgende herausgefilterte Gruppenrichtlinien werden nicht angewendet.
----------------------------------------------------------------------
Richtlinien der lokalen Gruppe
Filterung: Nicht angewendet (Leer)

Der Benutzer ist Mitglied der folgenden Sicherheitsgruppen
----------------------------------------------------------
Dom„nen-Benutzer
Jeder
Benutzer
Remotedesktopbenutzer
INTERAKTIVE REMOTEANMELDUNG
INTERAKTIV
Authentifizierte Benutzer
Diese Organisation
LOKAL
Organisation
TerminalServer Office User
TerminalServer WordExcel User
TerminalServer User



2. Profil, wo es funktioniert:


Betriebssystem Microsoft (R) Windows (R) Gruppenrichtlinienergebnis-Tool v2.0
Copyright (C) Microsoft Corp. 1981-2001

Am 30.07.2008, um 12:14:58 erstellt



RSOP-Daten fr xxx\Admin auf CITRIX: Protokollmodus
Betriebssystemtyp: Microsoft(R) Windows(R) Server 2003 Standard Edition
Betriebssystemkonfiguration: Mitgliedsserver
Betriebssystemversion: 5.2.3790
Terminalservermodus: Anwendungsserver
Standortname: Ort
Zwischengespeichertes Profil:\\Server\profiles\Admin
Lokales Profil: C:\Dokumente und Einstellungen\Admin
Langsame Verbindung? Nein


COMPUTEREINSTELLUNGEN
CN=CITRIX,OU=Terminalserver,DC=xxx,DC=yyy,DC=zzz,DC=de
Letzte Gruppenrichtlinienanwendung: 30.07.2008, um 11:43:10
Gruppenrichtlinieanwendung von: Server.xxx.yyy.zzz.de
Schwellenwert fr langsame Verbindung:0 kbps
Dom„nenname: xxx
Dom„nentyp: Windows 2000

Angewendete Gruppenrichtlinienobjekte
--------------------------------------
Terminalserver
Default Domain Policy
Richtlinien der lokalen Gruppe

Der Computer ist Mitglied der folgenden Sicherheitsgruppen
----------------------------------------------------------
Administratoren
Jeder
Debuggerbenutzer
IIS_WPG
Benutzer
NETZWERK
Authentifizierte Benutzer
Diese Organisation
CITRIX$
TerminalServer Word User
Dom„nencomputer


BENUTZEREINSTELLUNGEN
CN=Admin,OU=1234,OU=3456,DC=xxx,DC=yyy,DC=zzz,DC=de
Letzte Gruppenrichtlinienanwendung: 30.07.2008, um 12:14:10
Gruppenrichtlinieanwendung von: Server.xxx.yyy.zzz.de
Schwellenwert fr langsame Verbindung:0 kbps
Dom„nenname: xxx
Dom„nentyp: Windows 2000

Angewendete Gruppenrichtlinienobjekte
--------------------------------------
Terminalserver
Default Domain Policy
Internetuser
Default Domain Policy

Folgende herausgefilterte Gruppenrichtlinien werden nicht angewendet.
----------------------------------------------------------------------
Richtlinien der lokalen Gruppe
Filterung: Nicht angewendet (Leer)

Richtlinien der lokalen Gruppe
Filterung: Nicht angewendet (Leer)

Der Benutzer ist Mitglied der folgenden Sicherheitsgruppen
----------------------------------------------------------
Dom„nen-Benutzer
Jeder
Benutzer
Remotedesktopbenutzer
Administratoren
INTERAKTIVE REMOTEANMELDUNG
INTERAKTIV
Authentifizierte Benutzer
Diese Organisation
LOKAL
Organisation
TerminalServer Office User
TerminalServer WordExcel User


Gruß
Thomas

P.S. Kann mich morgen erst wieder melden, falls Rückfragen bestehen.
Mitglied: 60730
30.07.2008 um 18:00 Uhr
Servus,

mir fällt auf,

der "Admin" ist in der Gruppe
CITRIX$
"kopiere diesen Admin mal und teste das Programm durch.
Dann den Admin immer in eine Gruppe zusätzlich reinstecken, die der nichtfunktionierende auch hat.
Funktionieren "alle Gruppen", dann die Adminrechte wegnehmen.
Klappt es dann nicht mehr, liegts eventuell an Registry Rechten.

Gruß
Bitte warten ..
Mitglied: Randyman
30.07.2008 um 18:54 Uhr
Hallo,

mit hat schon öfter filemon geholfen um herauszufinden ob noch andere Rechte in anderen Verzeichnissen benötigt werden.
Dummerweise gibts ja immer wieder Programme die Schreibrechte auf System-Verzeichnisse benötigen.

Gruss
Randy
Bitte warten ..
Mitglied: Admin580
31.07.2008 um 12:11 Uhr
Hallo Timo und Randy,

so wie es aussieht hab ich es jetzt. Beide Tipps haben mir geholfen. Vielen Dank dafür!!!!!!

Also: Mit Filemon habe ich leider keine hundertprozentigen Hinweise kriegen können. Dadurch bin ich dann aber auf Regmon gestoßen. Dieses Tool lieferte dann den entscheidenden Hinweis. Es war wirklich ein Berechtigungsproblem in der Registry. Und zwar brachte das Tool den Fehler "Access denied" bei HKCU und im
HKU\Software\Programm. Bei HKCU standen zwar die Domänenbenutzer drin mit Vollzugriff, hab es aber nochmal raus- und wieder reingenommen. Zusätzlich
habe ich der lokalen Benutzergruppe auch Vollzugriff gegeben. Dieselben Berechtigungen habe ich dann bei HKU\Software\Programm gesetzt.

Die ersten Versuche nach der Änderung waren erfolgreich! Ich denke mal, dass es jetzt läuft. Nun warte ich nur nochmal den Reboot der Server heute abend ab
und dass sich alle User neu anmelden und dann schaun 'mer mal.

Wenn alles klappt, setz ich den Thread auf gelöst. Ansonsten meld ich mich nochmal.

Vielen Dank für Eure Unterstützung!

Gruß
Thomas
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Exchange Server
gelöst Exchange 2003 von Windows 2003 Server lösen bzw. entfernen (3)

Frage von plexxus zum Thema Exchange Server ...

Windows Server
Rechtevergabe Fileserver Windows 2003 (1)

Frage von bluepython zum Thema Windows Server ...

Windows Server
Windows 2003 Terminalserver - ausführbare Dateien einschränken (6)

Frage von Excaliburx zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...