Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Wie muss die Apache httpd-vhosts.conf bei Domainweiterleitung -Umleitung aussehen?

Frage Linux Apache Server

Mitglied: D040323

D040323 (Level 1) - Jetzt verbinden

02.01.2008, aktualisiert 24.03.2008, 15208 Aufrufe, 10 Kommentare

Hallo zusammen und ein gutes neus Jahr,

kurze Problemstellung, bei 1&1 ist die Domain hans-ewald.de (NSLookup IP 217.172.xxx.xxx) registriert, dort in der HTTP
Domainweiterleitung steht meine Server Adresse http://85.115.xx.xxx (kann man nur so eingeben)
Hab es auch schon ne Weiterleitung über eine .htaccess versucht,

Redirect / http://85.115.xx.xxx/

Das Problem, ich komme IMMER auf den default vhost, in diesem Fall "localhost". Auch wenn ich direkt im Config Menü zu der Domain die Server IP 85.115.xx.xxx eingeben, bekomme ich das gleiche Ergebnis.
Was muss ich nich in der VHOST Datei berücksichtigen bzw was hab ich falsch gemacht? Bin für jeden Tip dankbar.

Anbei noch ein paar Infos,
- Win 2003 Server,
- XAMPP.

und noch ein paar Details zur Konfiguration.

httpd-vhosts.conf

NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost
ServerAdmin meine@mailadresse.de
DocumentRoot "/xampp/htdocs/"
</VirtualHost>


<VirtualHost *:80>
ServerName hans-ewald.de
ServerAlias www.hans-ewald.de *.hans-ewald.de
ServerAdmin webmaster@dhans-ewald.de
DocumentRoot "D:/xampp/htdocs/hans-ewald"

<Directory "D:/xampp/htdocs/hans-ewald/">
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

Host Datei

127.0.0.1 localhost
217.172.xxx.xxx hans-ewald.de www.hans-ewald.de #DNS A Record laut NSLOOKUP
85.115.xx.xxx hans-ewald.de www.hans-ewald.de #Mein eigener Server
Und das ist der HTTP Aufruf:

Display URL Normal browser lookup of URL http://www.hans-ewald.de/ Completed
Started At 2008-Jan-02 19:40:41.026 Completed
DNS Lookup Lookup of hostname 'www.hans-ewald.de' Completed
Connect Connect to IP address '217.172.xxx.xxx' Completed
HTTP Request Unconditional request sent for http://www.hans-ewald.de/ Completed
HTTP Response Headers and content returned Completed
Redirect A redirect to http://85.115.xx.xxx/ was issued by the server


HTTP Header
(Request-Line) GET / HTTP/1.1
Accept image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
Accept-Encoding gzip, deflate
Accept-Language de
Connection Keep-Alive
Host www.hans-ewald.de
User-Agent Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Danke & Grüße,
Maik
Mitglied: EvilMoe
02.01.2008 um 20:07 Uhr
Soe wie ich das sehe ist deine VHost richtig. Hast du den A-Record auf dein Server/Webspace gesetzt? Was genau möchtest du erreichen soll die Domain auf eine andere weiterleiten oder auf deinen Server "aufschalten"?
Bitte warten ..
Mitglied: D040323
02.01.2008 um 20:31 Uhr
Hallo EvilMoe,
das ging ja Ruck zuck mit der Antwort, danke für die Info. per NSLOOKUP habe ich folgende Info bekommen,
Host Type Value
horst-ewald.de. A 217.172.XXX.XXX
Muss etwa der A-Record auf meine Server IP (85.115.xx.xxx ) zeigen? Sprich, die HTTP Weiterleitung funktioniert gar nicht?

Gruß,
Maik.
Bitte warten ..
Mitglied: EvilMoe
02.01.2008 um 20:35 Uhr
Was hast du denn vor? Soll die Homepage auf deinen Server gehostet werden oder soll die Domain woanders umleiten?
Bitte warten ..
Mitglied: D040323
02.01.2008 um 20:44 Uhr
Ist eigentlich ganz einfach, ich hab eine Domain bei 1und1. Dort kann ich entweder einen Webspace nutzen oder eine Weiterleitung einrichte. Ich habe aber auch noch einen Eigenen Webserver mit fester IP. Die Domain bei 1und1 soll auf die Dateien bzw den virtuellen Host auf meinem Webserver zeigen.

Hoffe die Erläuterung ist verständlich. Es gibt auch noch 2 weitere Domains, bei denen funktioniert es wie gewünscht. Also ich ruf die Domain auf und lande auf meinem Server. Daher vermute ich, dass e sbei 1und1 noch eine Sonderlocke bei der Konfiguration gibt, ich weiß eben nur nicht wo.
Bitte warten ..
Mitglied: EvilMoe
02.01.2008 um 20:49 Uhr
Ja in diesem Fall musste dort irgentwoe gut versteckt die DNS Einstellungen finden und den A-Record auf deine Server IP legen. Dann sollte es auch mit dein VHost klappen ;)
Bitte warten ..
Mitglied: D040323
02.01.2008 um 21:01 Uhr
OK, nur kurz für mich ne Zusammenfassung Ich muss bei 1und1 den DNS EIntrag und den A-Record ändern, korrekt ? Danke schonmal vorab.
Bitte warten ..
Mitglied: EvilMoe
02.01.2008 um 21:05 Uhr
Richtig. Ich wollte aber auch noch sagen das XAMPP nur für eine Testumgebung gedacht ist und nicht für Produktiven Einsatz!
Bitte warten ..
Mitglied: D040323
02.01.2008 um 21:33 Uhr
Danke EvilMoe, dann mach ich mal auf die Suche nach dem DNS Eintrag, im Config Menü gibt es die Option leider nicht. Jetzt bin ich gerade überrascht, warum sollte man XAMPP nicht produktiv einsetzen?
Bitte warten ..
Mitglied: EvilMoe
02.01.2008 um 21:42 Uhr
XAMPP ist zu Testzwecken eingerichtet wurden und ist dementsprechend "offen" eingestellt. Bei einer Testumgebeung spielt das keine große rolle aber Produktiv schon.

Installier den Apache und MYsql einzeln
Bitte warten ..
Mitglied: D040323
24.03.2008 um 22:12 Uhr
Lang lang ist es her,

nicht jede Domain unterstütz die Änderung des A Records, bzw nicht jeder Hoster, ist also abhängig vom Paket.

Greetz,
Maik.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...