Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Apache,PHP,MySql - keine Verbindung zu phpMyAdmin

Frage Linux Apache Server

Mitglied: FELLINGA09

FELLINGA09 (Level 1) - Jetzt verbinden

17.02.2010, aktualisiert 02:23 Uhr, 9809 Aufrufe, 5 Kommentare

Hallo!

kurze Problemerläuterung:
Ich habe Apache PHP und MySql installiert und versuche per phpmyadmin zu Verbinden, doch leider klappt das nicht!

Infos:
*Windows 7 32bit (engl.)

*Apache 2.2.14 (per Installer)
*PHP 5.2.12 (per Zip)
*MySql 5.1.43 (per Installer)
*phpmyadmin 3.2.5 (per Zip)

*Nein ich möchte keine WAMMP XAMMP oder sonst was verwenden!

Mein momentaner Status:
Ich war bereits in hunderten Foren, und habe auch schon nach 2 "Guides" installiert.
Doch immer tritt ein Problem auf.
Momentan läuft der Apache mit PHP einwandfrei. Ich kann also PHP files und alles anzeigen lassen.
Die Phpinfo.php zeigt mir meine Confg an, die Pfade stimmen alle. (soweit ich das beurteilen kann)

In der Phpinfo wird mir angezeigt das MySql mitgeladen wird!!!
Dort steht auch die aktuelle MySql Version: 5.1.43
Wenn ich mich direkt über MySQL einlogge (die Shell) habe ich Zugriff, verwendet wird momentan die mysql database.

Wenn ich jetz auf "localhost/phpmyadmin" gehe kommt das Logininterface, ich gebe die Zugangsdaten ein drücke auf "Login", und nach wenigen Sekunden steht da:

Internet Explorer cannot display the webpage

Firefox bringt:

Fehler: Verbindung unterbrochen
Die Verbindung zum Server wurde zurückgesetzt, während die Seite geladen wurde.

Ich habe mitlerweile sehr viel an der config.inc.php herumgebastelt, mit cookie, http, config, überall das gleiche.


Da mir die PHPinfo anzeigt das MySql geladen wird, denke ich jetzt das es noch an Einstellungen der config.inc.php liegen muss.




Wisst ihr woran ich scheitere?
Vielen Dank schonmal für alle Antworten!

lg
Mitglied: dog
17.02.2010 um 05:00 Uhr
Bitte mal die Ausgabe der error_log posten...
Bitte warten ..
Mitglied: etnobommel1989
17.02.2010 um 07:55 Uhr
Installiere mal Xampp und nicht alle Server einzeln. Müsste funktionieren, hat bei mir auch geklappt und hatte davor desselbe Problem
Bitte warten ..
Mitglied: FELLINGA09
17.02.2010 um 08:08 Uhr
Auszug der error_log von ..\Apache\logs :

[Wed Feb 17 02:14:49 2010] [notice] Parent: child process exited with status 255 -- Restarting.
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
[Wed Feb 17 02:14:49 2010] [notice] Apache/2.2.14 (Win32) PHP/5.2.12 configured -- resuming normal operations
[Wed Feb 17 02:14:49 2010] [notice] Server built: Sep 28 2009 22:41:08
[Wed Feb 17 02:14:49 2010] [notice] Parent: Created child process 2772
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
[Wed Feb 17 02:14:49 2010] [notice] Child 2772: Child process is running
[Wed Feb 17 02:14:49 2010] [notice] Child 2772: Acquired the start mutex.
[Wed Feb 17 02:14:49 2010] [notice] Child 2772: Starting 150 worker threads.
[Wed Feb 17 02:14:49 2010] [notice] Child 2772: Starting thread to listen on port 80.
[Wed Feb 17 02:14:50 2010] [notice] Parent: child process exited with status 255 -- Restarting.
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
[Wed Feb 17 02:14:50 2010] [notice] Apache/2.2.14 (Win32) PHP/5.2.12 configured -- resuming normal operations
[Wed Feb 17 02:14:50 2010] [notice] Server built: Sep 28 2009 22:41:08
[Wed Feb 17 02:14:50 2010] [notice] Parent: Created child process 1356
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName
[Wed Feb 17 02:14:51 2010] [notice] Child 1356: Child process is running
[Wed Feb 17 02:14:51 2010] [notice] Child 1356: Acquired the start mutex.
[Wed Feb 17 02:14:51 2010] [notice] Child 1356: Starting 150 worker threads.
[Wed Feb 17 02:14:51 2010] [notice] Child 1356: Starting thread to listen on port 80.

@etnobommel1989
Ich habe bereits oben erwähnt das ich es nicht verwenden möchte.
Bitte warten ..
Mitglied: nxclass
17.02.2010 um 08:26 Uhr
Das hört sich für mich wie eine unpassende Mysql Konfiguration an. Glaube mich zu erinnern, daß es unter Umständen nicht möglich war sich mit 'localhost' sondern nur mit '127.0.0.1' zu verbinden. ( ... weil Mysql einmal die Pipe und einmal die Netzwerkschnittstelle nutzt ? )

Nein ich möchte keine WAMMP XAMMP oder sonst was verwenden!
Dafür hätte ich mal eine Erklärung. Gut - mir ist das xampp Paket auch viel zu fett, aber es gibt doch auch das xampp-lite. ( http://www.apachefriends.org/de/xampp-windows.html#631 ) Und falls man eine andere PHP version benötigt (zB. php4) dann kann man auch ein 2. PHP's parallel installieren und benutzen.
Bitte warten ..
Mitglied: dog
17.02.2010 um 08:37 Uhr
Der Log nach crasht der Apache Prozess in dem PHP läuft (was ich bereits erwartet hatte).
Bei so einem Problem hilft meist nur andere Versionen verwenden/von vorne anfangen.
Bitte warten ..
Ähnliche Inhalte
Datenbanken
MySQL unter phpMyAdmin richtig vorbereiten?
gelöst Frage von carl7nDatenbanken9 Kommentare

Hallo, ich möchte eine MySQL Datenbank nach diesem Schema aufbauen: ID (auto increment, aber Zahlen manuell änderbar) Aufgabe (Name ...

PHP
PHP Umstellung mysql connect
Frage von DPiegzaPHP7 Kommentare

Hallo zusammen. Ich bekomme immer diese Fehlermeldung / Warnung: Deprecated: mysql_connect(): The mysql extension is deprecated and will be ...

PHP
PHP MySQL Login
Frage von YanmaiPHP7 Kommentare

Hallo ihr Administratoren, ich habe eine Datenbank, in der alle User des Netzwerkes enthalten sind. Wenn ein User sich ...

PHP
MySQL in PHP mit Variablen
gelöst Frage von carl7nPHP10 Kommentare

Hallo, ich habe PHP-Grundkenntnisse, schaffe es aber nicht, nach meinen Vorstellungen ein paar kleine PHP-Scripts zusammen arbeiten zu lassen. ...

Neue Wissensbeiträge
Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 18 MinutenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 34 MinutenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 12 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 19 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement17 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...