Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Apache - WebDAV - SVN mit RHEL 5 (Einbinden über net use unter Windows XP SP3)

Frage Linux Apache Server

Mitglied: quibbuser

quibbuser (Level 1) - Jetzt verbinden

04.11.2008, aktualisiert 13.11.2008, 8602 Aufrufe, 2 Kommentare

Guten Morgen!

Die Konfiguration sieht folgendermaßen aus:

- Red Hat Enterprise 5.1
- Apache 2.2.10 + WebDAV + OpenSSL
- SVN 1.5.4

Alles ist soweit richtig eingerichtet. Der Zugriff über http, https auf Repositorys des SVN funktioniert wunderbar per Browser (Firefox, etc.).

Ein paar Informationen zur Konfiguration des Repository:

SVN (Basic):

<Location /svn>

DAV svn
SVNListParentPath on

SVNParentPath /etc/svn/repository
AuthType Basic
AuthName "Subversion Repository"
AuthUserFile /etc/apache2/conf/auth-file-basic
#AuthzSVNAccessFile /etc/apache2/dav_svn.authz

<LimitExcept GET PROPFIND OPTIONS REPORT>
Require valid-user
</LimitExcept>

#SSLRequireSSL

</Location>

SVN Digest:

<Location /svn>



DAV svn

SVNListParentPath on

SVNParentPath /etc/svn/repository




AuthType Digest

AuthName "svn"

AuthDigestDomain /svn


AuthDigestProvider file

AuthUserFile /etc/apache2/conf/auth-file-digest



Require valid-user



</Location>

Alle benötigten Module wie DAV etc. sind am laufen.

Authentifizierung erfolg über Basic oder Digest, beides ist eingerichtet und getestet.

Das Problem liegt bei net use (Windows XP SP3).
Versuche ich das Repository als Laufwerk einzubinden kommt entweder der Fehler:

- Der Netzwerkpfad kann nicht gefunden werden (existiert aber. getestet)
- Zugriff verweigert (Basic sowie Digest)

Ich hab schon eine ganze Weile im Internet gesucht, doch nicht wirklich eine Lösung zu dem Problem gefunden.


Vielleicht hatte ja schonmal Jmd. das gleich Problem und könnte mir mit ein paar Ratschlägen zur Seite stehen.

PS:
Schaue ich mir die access log an fallen mir ein paar Besonderheiten auf.

Anmeldung über einen Browser auf das Repository:
127.0.0.1 - toby [03/Nov/2008:17:09:07 +0100] "GET /svn/repository/ HTTP/1.1" 500 234

Anmeldung über net use Windows XP SP3:
92.168.1.139 - 192.168.1.119\\toby [03/Nov/2008:17:23:52 +0100] "PROPFIND /svn HTTP/1.1" 301 233
192.168.1.139 - - [03/Nov/2008:17:23:54 +0100] "PROPFIND /svn HTTP/1.1" 401 401
192.168.1.139 - "" [03/Nov/2008:17:23:54 +0100] "PROPFIND /svn HTTP/1.1" 401 401
192.168.1.139 - - [03/Nov/2008:17:24:03 +0100] "PROPFIND /svn HTTP/1.1" 401 401
192.168.1.139 - homebase@toby [03/Nov/2008:17:24:03 +0100] "PROPFIND /svn HTTP/1.1" 401 401
192.168.1.139 - - [03/Nov/2008:17:25:06 +0100] "OPTIONS / HTTP/1.1" 200 -
192.168.1.139 - homebase@toby [03/Nov/2008:17:25:06 +0100] "PROPFIND /svn HTTP/1.1" 401 401
192.168.1.139 - - [03/Nov/2008:17:25:11 +0100] "PROPFIND /svn HTTP/1.1" 401 401
192.168.1.139 - 192.168.1.119\\toby [03/Nov/2008:17:25:11 +0100] "PROPFIND /svn HTTP/1.1" 301 233

Hier habe ich verschiedene Benutzernamen getestet die auch in der htpassw stehen
- toby
- toby@homebase

Doch scheint es als ob Windows die falschen Daten an den Server sendet und somit keine Verbindung stattfinden kann.

Schonmal vielen Dank

Grüße
quibb
Mitglied: dog
04.11.2008 um 19:31 Uhr
Hallo,

es war mir bisher garnicht bekannt, dass net user andere Protokolle als SMB akzeptiert (außer die Vista-Version)?

Offensichtlich kann er es aber doch (aber HTTPS erst ab Vista).

Allerdings kenne ich es, dass Windows ziemlich häufig Probleme mit Apaches webDAV hat.
Dafür gibt es auch extra Anleitungen (die teilweise auch nur leidlich gut funktionieren):

http://www.hss.caltech.edu/help/unix/admin/web/apache-webdav-xp

Ich habe in der Vergangenheit gute Erfahrungen mit Novell NetDrive gemacht (kostenlos - gibt es zwar offiziell nicht mehr, findet man aber immer noch im Internet). Alternativ gibt es auch noch das kostenpflichtige webDrive.
Bitte warten ..
Mitglied: quibbuser
13.11.2008 um 13:46 Uhr
Ja, die Alternative das ganze mit Novell NetDrive einzubinden funktioniert wunderbar und ich kann diese nur empfehlen.

Habe auch zig Lösungen im Netz gefunden die aber alle nicht funktioniert haben. Zumindest nicht für Windows XP SP3.
Getestet auf SP1 oder SP2 habe ich das ganze allerding nicht. Würde auch kein Sinn machen, da hier sowieso die Windows Versionen immer auf den neusten Stand gebracht werden.

Vielen Dank
quibb
Bitte warten ..
Ähnliche Inhalte
Apache Server
Apache und WebDAV
Frage von crazymarc1989Apache Server1 Kommentar

Hallo zusammen, derzeit versuche ich über meinen Server eine WebDAV-Verbindung als Netzlaufwerk herzustellen. Dies funktioniert soweit alles korrekt, wenn ...

Server
Webdav ssl Laufwerk mappen mit net use systemfehler 1244 benutzer nicht authentifiziert
Frage von MeinGottWalterServer9 Kommentare

Moin Kollegen, ich habe ein Problem der seltsamen Art: nach grundsätzlich erfolgreicher Inbetriebnahme der ssl-Verschlüsselung via erworbenem Zertifikat passiert ...

Windows 7
Net use mit gui
Frage von Lebowski23Windows 71 Kommentar

Hallo, folgendes Problem: In einem Netzwerk existiert ein LDAP-Server mit Samba, der für einige Rechner auch als Domain-Server dient. ...

Windows Netzwerk
Printerumleitung mittels net use wollen nicht
Frage von orrybeachWindows Netzwerk6 Kommentare

Ich habe einige Arbeitsstationen von Windows XP auf Win 7 umgestellt. Leider läuft noch ein altes DOS-Programm, welches unter ...

Neue Wissensbeiträge
Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 6 StundenBatch & Shell7 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 8 StundenHumor (lol)6 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 1 TagMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 1 TagSicherheit1 Kommentar

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Heiß diskutierte Inhalte
Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server17 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...

Windows 10
Bitlocker nach Verschlüsselung nicht mehr aufrufbar!
gelöst Frage von alexlazaWindows 1013 Kommentare

Hallo, ich besitze ein HP ZBook 17 G4 mit einem Windows 10 Pro Betriebssystem. Bei diesem Problem handelt sich, ...

Batch & Shell
Neuste Datei via PowerShell kopieren
gelöst Frage von kaiuwe28Batch & Shell11 Kommentare

Hallo zusammen, ich hatte mir mit Hilfe der Suche im Forum einen kleinen Code von colinardo rausgesucht und versucht ...